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Chapter 1: Basic Web Concepts

 

he World Wide Web (the Web) is the most popular medium for electronically distrib-
uting and viewing information as pages of text, graphics, movies, or other media. This 
chapter introduces the concepts, terms, and basic procedures you use to create a Web 

page with Adobe

 

®

 

 PageMill

 

®

 

 software.

 

About the World Wide Web

 

The Web is a collection of electronically linked documents (called 

 

pages

 

) that are accessible 
from the Internet. 

Understanding these common terms will help you as you create Web pages with PageMill 
software: 

 

•

 

Document

 

 and 

 

page

 

 both refer to a single file. You move through and between these pages 
using hypertext links—similar to clicking a topic in an online help system. 

 

•

 

A Web 

 

server

 

 is a computer that stores and delivers Web documents. The server accepts 
requests for documents from other computers and then delivers the documents. 

 

•

 

A 

 

browser

 

 (sometimes called a Web 

 

client

 

) lets you look at documents sent by a server. Many 
browsers are available, including Netscape Navigator

 

®

 

 and Microsoft

 

®

 

 Internet Explorer.

 

•

 

An

 

 Internet Service Provider

 

 (

 

ISP

 

) maintains the server where you send requests and makes 
space available for you to store your own Web pages. (If you work in a company or educational 
institution, your organization probably provides the services you use to get to the Web server.)

T
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Note:

 

 Your own computer can be a Web server if it has the proper software and a direct connection 
to the Internet, but running a Web server involves technical and administrative overhead. Most 
people and small companies avoid this option and have someone else provide them with Web access. 

 

•

 

A 

 

site

 

 is typically a group of related pages on a Web server. You usually enter a Web site via a 
home page. A site can be as small and simple as a single page with no links to an extensive inter-
linked site with hundreds of files.

 

•

 

A 

 

home page

 

 is the Web page that automatically loads when readers access your site on the 
Web. The home page is usually named 

 

index.html

 

. (Check with your ISP or webmaster for the 
name to use.) A home page can also refer to the Web page that automatically loads when you 
first start a browser. 

 

•

 

Your document is 

 

published 

 

when you

 

 upload 

 

a copy of your site to a Web server where the 
rest of the world (or, if you’re working on an intranet, the rest of the company or university) 
can access it. Most ISPs offer customers a few megabytes of space on their servers to store their 
site documents. (Uploading isn’t necessary if you’re able to save your Web pages directly to the 
Web server via a network connection. That is, if you’re able to access your Web server using 
Network Neighborhood, you can use PageMill software to work directly on the site.)

 

About Web addresses

 

To go somewhere on the Web, you enter an Internet address called a Uniform Resource Locator 
(URL) in your browser. The URL is the pathname to the page or object you’re looking for. 

Your machine with
browser software and
connection software

Your Web page
is stored on a server

Server provided by your
ISP publishes Web
pages on the Internet

Users who
access your
Web pages



 

3

 

A URL is made up of several parts: 

 

•

 

Protocol

 

 is the set of rules that describes how you want the information transferred. The 
system used by the Web to transfer data is called Hypertext Transfer Protocol (HTTP). Most 
browsers also support other protocols (see “About URLs” on page 75).

 

•

 

Domain

 

 describes the host name of the server on the Internet.

 

•

 

Directory path

 

 is the location of the Web site within the server’s file structure.

 

•

 

Page name 

 

is the filename of the page you’re requesting.

 

•

 

Anchor

 

 (optional) is a particular location on the page.

 

About Web page design

 

Pages on the World Wide Web are described using Hypertext Markup Language (HTML). 
HTML is a text-only markup language that was designed to allow text to be tagged (or 

 

marked 
up

 

) to designate the content—not the appearance—of the text. Hence, your options for 
designing a Web page differ greatly from those for the printed page. As you design Web pages, 
remember that you don’t have complete control over how the reader sets the page size, the 
width of the text column, the fonts, or the size of the text. 

This documentation does not try to instruct you on the complexities of designing for the Web. 
For help in this area, refer to any of the many excellent third-party books available.

PageMill lets you create pages without typing any HTML codes (also called 

 

tags

 

) that format the 
page. With PageMill, you format text not by typing HTML code but by clicking buttons in the 
toolbar. Similarly, you resize or reposition imported graphics not by working with HTML but 
by dragging them.

Because HTML is a fast-evolving standard, you may want to manually add a special tag not 
directly supported by this version of PageMill. You can do this by entering custom HTML code 
into the page. (See “Viewing and Editing HTML Code” on page 171.) For more information on 
the HTML tags PageMill supports, search the Adobe online technical database for related 
technical documents at 

 

http://www.adobe.com/supportservice/custsupport/database.html

 

. 

PROTOCOL  /  DOMAIN  /  DIRECTORYPATH  /  PAGENAME  #  ANCHOR

http://www.company_name.com/department/sales/western.html#salesinfo
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Web browser considerations

 

Different Web browsers interpret HTML differently. Sometimes, different versions of the same 
browser display a Web page in slightly different ways. PageMill in its Preview mode usually 
shows your page as most browsers will, but it cannot show it as 

 

all

 

 of them will. Because of this, 
you might want to preview your pages in several browsers to see if there are unexpected display 
differences.

 

Layout considerations

 

An HTML page is one column of continuous text with graphics that flow along with the text, 
as if they were text characters themselves. This text-stream model limits your control over page 
layout; for example, it does not let you create layouts that use multiple columns, layered text 
and graphics, or rotated text.

The text-stream model also means that page proportions and line breaks will vary depending 
on the size of the monitor or window in which the page is viewed, the preferences set in 
PageMill, and the preferences set in the Web browser. 

 

Resizing a browser window changes line endings.

 

 To see where your text lines will break in most browsers, design your page using a 

 

default font on a 640-by-480-pixel screen.
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You can’t specify a precise position for a graphic. For example, if you position a graphic at the 
bottom right of a page as it appears on your monitor and a reader decides to make the window 
narrower, the graphic probably will move to the next line down and may end up on the left side 
of the page.

 

Typographical considerations

 

You can’t totally control the typographical appearance of your Web page using HTML, because 
the Web browser’s window size and font settings determine line breaks, letter spacing, and 
word spacing. In addition, you can’t specify the following type characteristics from PageMill 
because most Web browsers either completely control them or do not support them:

 

•

 

Font leading (the space above and below lines of text)

 

•

 

Font width

 

•

 

Tracking and kerning (the space between characters and words)

 

•

 

Tab positions

 

•

 

Spacing before or after a paragraph

To preserve the typography in a short passage of text, such as a company logo, create the text in 
an image-editing program and import it as an image (see page 50).

 

Note:

 

 Even the typographical properties that you can control with PageMill are not absolute. For 
example, text formatted in a specific font using the Style > Font command has no effect if readers 
don’t have that font installed on their computers.

 

Graphics considerations

 

When you’re considering what images to include in a Web page, keep in mind that images take 
longer to download than text. Some browsers don’t display graphics at all, and some readers 
turn off graphics to speed up their browsing. Here are additional considerations for working 
with images that you’ll display on the Web:

 

Keep the file size as small as possible.

 

Because you want a page to load very quickly, no graphic 
should be larger than about 10K. The entire page (all the graphics on the page plus the text) 
should not be larger than 50K (which takes about 20 seconds to download using a standard 
modem connection). For more information about image size and download speed, see 
“Estimating the download time of pages and objects” on page 162.
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You can use the following techniques to reduce a graphic’s file size:

 

•

 

Reduce the image size. Scaling an image in PageMill won’t change its file size or speed its 
downloading. Instead, use an image-editing application such as Adobe Photoshop

 

®

 

 to resize.

 

•

 

Reduce the number of colors used in the image. Use only the built-in Web-safe color palette 
of the 216 colors common to all platforms.

 

•

 

Resample the image to reduce its pixels per inch (ppi). A resolution of 96 ppi is high enough 
for most images because it is the resolution of most readers’ monitors.

 

•

 

Save the file in the right format. A Graphics Interchange Format (GIF) image can contain 
transparent areas and can be interlaced for better downloading (see page 58 and page 59). 
Similarly, the Progressive Joint Photographic Expert Group format (ProJPEG) lets an image 
load in stages, which speeds up its delivery.

 

•

 

Save a JPEG image using the appropriate compression. See your image-editing application 
for more information.

 

Limit the image width. 

 

A width of 480 pixels or less lets most readers view the image easily. 
When you must use larger images, consider placing a 

 

thumbnail

 

 (a smaller version of the 
image) on the main page and linking it to the larger or higher resolution image. Then readers 
can decide if they want to spend the time downloading the larger file.

 

Use a small image as background.

 

Using a very small image to tile as the background is much 
faster and more efficient than tiling a large image.

 

Use a dither-free set of colors.

 

Work in RGB color mode rather than in CMYK mode when 
preparing images in an image-editing application to help prevent 

 

dithered

 

—mixed—colors. 
RGB files are smaller, and use the same color model used by monitors. To avoid dithering colors 
in images, use the Web-safe color palette when you create images.

 

Note: 

 

The Windows

 

®

 

 and Macintosh browser palettes share only 216 of 256 possible colors. To avoid 
dithering, use only the Web-safe colors provided on the PageMill Color Panel (see page 37)

 

Use anti-aliasing. 

 

Low-resolution images often appear with jagged edges where colors change. 
In an image-editing application such as Photoshop, you can apply anti-aliasing to slightly blur 
the edges where colors change and create a smoother transition between adjacent colors. 
(Don’t anti-alias a graphic if you’re making the rectangular background around the image 
transparent or a halo or fringe may appear around the edges.)
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Use the same image in different places.

 

Typically, a browser has to download an image only 
once when it’s repeated in a site or in a page. This lets duplicated elements, such as navigation 
bars and logos, appear quickly. 

 

Know your audience.

 

If you expect modem users to access your page, the total graphics content 
of a single page should not exceed 50K. You can check the download statistics to estimate the 
downloading time for images and graphics before you put your site on a server (see page 162). 
You can relax this file-size limit if the site is being viewed on an intranet.

 

HTML considerations

 

HTML structures information by using named 

 

formats

 

. You apply formats based on the 
function of a particular piece of text, such as a heading, a regular paragraph, or a list. HTML 
formats resemble the named styles in many word-processing programs in that you change the 
appearance of text by applying different formats. However, the appearance of a format can also 
be changed within the browser by the person reading a Web page—something a reader of a 
printed page can’t do. The formats in HTML preserve the functional organization of a page 
even if a reader changes a format’s appearance. For more information, see “Applying paragraph 
formats” on page 28.

 

Preserving a page layout 

 

If preserving page layout is important, consider creating some of your Web pages as Adobe 
Acrobat

 

®

 

 Portable Document Format (PDF) files. PDF files preserve the layout and 
typographical characteristics that HTML does not, and can include hypertext links between 
pages and to the World Wide Web. You can import PDF files into PageMill from any version of 
Acrobat as long as the PDF plug-in (see page 48) or the PDF ActiveX control is installed. For 
information on including PDF files in Web pages, see page 79.

If you include PDF files in your Web pages, also include a link to the free Adobe Acrobat Reader 
application. Acrobat

 

®

 

 Reader or Acrobat Exchange

 

®

 

 must be installed to view PDF files. Acrobat 
Reader runs on Windows, MS-DOS

 

®

 

, Macintosh, OS/2

 

®

 

, and many UNIX systems. For more 
information about PDF files and Acrobat, see the Adobe Web site at 

 

http://www.adobe.com

 

.
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Using Web links

 

The most significant difference between a printed page and a Web page is a 

 

link

 

, which lets you 
arrange pages in a Web site nonsequentially. When you click a link, the Web browser jumps to 
the page or file specified as the link’s destination. Links appear as specially marked text or 
images on a page. Each page can have several links, with each link leading directly to another 
page or file within your site or to pages on any other Web server in the world. 

In PageMill, creating a link can be as simple as dragging the icon of a page onto selected text or 
an image (see page 76).

Your Web site Other Web site

Links
Home page

Link

Pages on
Web server

Page on
another server
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Chapter 2: Basic PageMill 
Concepts

 

o build a Web site in PageMill, you need to set up the proper folder structure and know 
how to create and view Web pages.

 

About building a Web site

 

As with any publishing project, planning is important and can save you much time and trouble 
later. A Web site is structured very differently from printed books and periodicals, and its 
existence depends on both local and network hardware and software. Here are the suggested 
steps to follow in building a Web site:

 

Step 1: Determine the server requirements.

 

To design and upload your site, you need to obtain 
the following information from your Web server’s administrator or from your ISP:

 

•

 

Who will be responsible for uploading the site 

 

•

 

The URL of your Web site

 

•

 

The path to your Web directory from the root directory on the Web server (for example, 
/home/username/public_html/)

 

•

 

The name and the numeric IP address of the Web server you’ll be uploading to

 

•

 

The operating system your Web server is running (UNIX, Windows NT, Windows 95, DOS, 
or Macintosh

 

®

 

)

• How much disk space is available for your site

• How to deliver your files for publishing (file-naming conventions, transfer protocols, via disk 
or modem, and so on)

• If you plan to use forms, the Common Gateway Interface (CGI) scripts that are available

• If you plan to include server-side image maps (see page 99), what kind of map format your 
server uses (NCSA or CERN)

Step 2: Sketch the page layouts and site links. Before you begin creating Web pages, you should 
know who your audience will be and what content you want to present. Then you can decide 
how your pages should look and how they should link together. 

T
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For each page, do the following:

• Sketch the layout of text and images.

• Consider whether tables, movies, sounds, or other multimedia objects such as Java applets or 
ActiveX™ controls would enhance the content of the pages (see page 45).

• Decide where to place links and what elements to use for navigating through the pages. Avoid 
using too many links on a page, which might confuse readers and keep them from following 
the information flow.

For the entire site, do the following:

• Diagram the relationships between the pages, showing the home page and how pages link to 
each other and to pages outside your site.

• Devise a naming scheme for the files that make up your site. For example, the names of image 
files could all start with img.

Step 3: Structure your Web site. Setting up the proper folder structure for your Web site is 
crucial for avoiding problems such as broken links when you upload your pages to a Web server. 
For more information, see “Setting up a folder structure” on page 11.

Step 4: Create and name the pages. Create pages in PageMill, following your layout sketches. 

When naming files and folders, note the following:

• Be sure to follow the file-naming conventions of the Web server’s platform. To be safe, use 
only the characters A to Z, a to z, 0 to 9, - (hyphen), and _ (underscore). Don’t use accented 
characters, spaces, colons, question marks, slashes, or backslashes. (On non-Windows 95/NT 
DOS-based platforms, filenames must not exceed eight characters, not including the three-
character filename extension.) If you name a file or folder with a prohibited character, PageMill 
changes the character to a special code starting with a percent sign (%). To remove the special 
code, you must rename and then relink the file. For more on file-naming, see page 164.

• Take advantage of file-naming conventions of the Web server’s software. For example, if you 
want a page to load automatically when readers enter your site, that page should probably be 
named index.html (check with your ISP or webmaster for details).

• Name HTML pages with either the .html or .htm filename extension. (Use .htm when you’re 
uploading the files to a DOS server or when transporting the files on any removable media 
limited to “8.3” filenames.) Without the file extension, some browsers may interpret the page 
as a text file, displaying its HTML coding instead of showing the page graphically. For details 
on setting the default extension, see page 14.
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• To avoid errors when uploading to a case-sensitive Web server, be sure to keep the option 
“Treat Case-Sensitive URL Differences as Errors” turned on in the Resources page of the Prefer-
ences dialog box (see page 164).

Step 5: Add links. Following your link layout plan, add links between pages. For more infor-
mation, see Chapter 5, “Working with Links.”

Step 6: Test links. Test local links by switching to Preview mode (see page 17). You can also test 
and verify remote links (see page 87).

Step 7: Upload your pages. When you’ve completed and tested your Web pages, upload them to 
the Web server. For information, see Chapter 10, “Working with Web Sites.” Your pages are now 
available to anyone in the world with a Web browser. 

Step 8: Maintain your Web site. Most Web sites need periodic maintenance. For example, you 
may need to restructure your site as it grows; correct information on the pages; or add, delete, 
or rename files. Use PageMill to update your pages. Deleting, moving, or renaming files outside 
of PageMill can break links; always work within PageMill to perform these tasks (see page 158 
and page 159). If a link becomes broken, use the Site Details views to locate and repair it (see 
page 87).

When you’re finished updating your Web site, upload it to the Web server again, replacing the 
old version of the site. 

Setting up a folder structure
To properly display over the Web, all of a site’s page files and images must be stored on the Web 
server. To make sure that all site files transfer together when you upload your site from your 
computer to the Web server, do the following:

• Specify default folders in the Preferences dialog box.

• Set up the folder structure for pages and images.

Ideally, you should do this setup before you start to create pages and content. If you already 
have a site or pages created, you can still structure them using PageMill’s site management 
features.

Important: Be sure to use PageMill—not Windows Explorer—to create, move, and rename files 
and folders (see page 158 and page 159). Doing these tasks within PageMill ensures that links stay 
valid.
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To set up the folder structure for a new Web site:

1 Create a folder on your computer that will hold all the files and folders for your Web site. 
This is called the site’s local root folder. 

2 Choose Site > New Site and specify the local root folder in the Folder text box. PageMill then 
creates a default home page, index.html, in the local root folder.

3 If you don’t want to use the default home page, delete index.html and create a new home 
page in the local root folder.

4 Specify a folder where PageMill will store the GIF files that it converts from imported BMP 
images and where “externals” will be gathered (see page 161). Do this by choosing Edit > 
Preferences, clicking the Site tab, and entering the name in the Site Resources Folder Name text 
box. You don’t need to create this folder yourself; PageMill creates it when it’s needed. For 
example, if you want all converted images and externals to be placed in a folder called Images, 
enter Images in the text box.

5 To make sure the converted images are placed within the site even when you don’t have the 
site loaded, choose Edit > Preferences, click the Resources tab, and enter the full path to the 
same folder you specified in the previous step. For example, to make sure the converted images 
are placed in the site’s Images folder, enter the full path to this folder: C:\Mysite\Images 

For more information on how PageMill treats imported files, see page 45.

Caution: If you don’t set up this folder within the local root folder, PageMill creates a default folder 
called PageMill_Resources, which is outside the local root folder. Converted files stored in the 
default folder are external to your local Web site and are not included when you upload your pages 
unless you choose Site > Gather Externals (see page 161).

6 Click OK.

7 If you’re using server-side image maps, you may have to set additional preferences; see 
“Setting format preferences for server-side image maps” on page 100.

8 Within the local root folder, create any subfolders you want to store pages and image files in. 
Create the folder structure just as it will look once the site is uploaded to the Web server.

Note: If you save, link, or insert any Web files from outside this local root folder (for example, from 
another network drive), these files become “externals” and must be gathered into the root folder 
before uploading to a Web server (see page 161). You can avoid this by linking only to files within 
the local root folder (that is, linking to any folder that appears under the local root folder in the Site 
Overview area).
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To set up the folder structure for an existing Web site:

1 Choose Site > Load > Browse and locate the topmost folder of the existing site.

2 Examine the Errors and the Externals folders in the Site Overview area and then correct the 
errors and gather externals into the local root folder as needed (see page 160).

3 Adjust the site structure as needed by creating, moving, and renaming files and folders 
within PageMill (see page 158 and page 159).

Creating, saving, and opening pages
A Web site is made up of individual Web pages. You can create, save, and open individual pages, 
or you can load a whole site at the same time (see page 151), which lets you see the interrela-
tions between the pages.

Creating new pages

When you create a new page, it is blank and not linked to any other page. Creating a new site 
(see page 151) in an empty folder also creates a default page, called index.html, in the local root 
folder. Because this name is a common one for a home page and may be required by your 
webmaster or ISP, you should usually use it. Also note that all pages must be within the local 
root folder before being uploaded (see page 164).

To create a new page:

Do one of the following:

• To create the first page of a new site, choose Site > New and specify an empty local root folder 
in the Folder text box. This creates a new page, called index.html, in the local root folder.

• To create additional pages in a site, choose File > New Page.

To set the defaults for all new pages:

1 Choose Edit > Preferences and click the Page tab.

2 To set a default background pattern, click Clear below the Background Image area to remove 
a pattern, or click the File button to add one. Then locate an image file to use as a pattern.

3 To set default colors, choose Default or Custom from any of the following pop-up menus:

• Default Text Color controls the color of text.
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• Background Color controls the color behind text. If you have specified a background pattern, 
the background color shows only if the background image has transparent parts.

• Link Color is the color of a link before it’s selected in a browser.

• Active Link Color is the color of the link while you’re selecting it in a browser.

• Visited Link Color is the color of a link after you’ve selected it in a browser.

4 Click OK. The default settings go into effect the next time you create a page.

Saving pages

Remember to save your work often. For file-naming conventions, see page 10.

To save a Web page:

Do one of the following:

• Choose File > Save Page to save a page. 

• To save an existing page with a new name or new location, choose File > Save Page As.

• To save all open documents, choose File > Save All.

To change the defaults for saving files:

1 Choose Edit > Preferences and click the Page tab.

2 Choose a format from the Line Breaks pop-up menu that matches the type of Web server 
you’ll be uploading to (don’t match the type of computer you’re using to create a Web page). If 
you’re uploading to a Microsoft NT server, choose DOS.

3 Choose a default filename extension from the Suffix pop-up menu. Choose .html for 
uploading to UNIX or Macintosh servers; choose .htm for DOS-based servers. (Ask your ISP 
or webmaster if you’re unsure what type of server you’ll be using.)

4 Click OK. The default settings go into effect the next time you save a page.

Opening pages

In addition to opening existing PageMill documents, you can open and edit Web pages you’ve 
downloaded. When opening a non-PageMill Web page on your computer, PageMill interprets 
all HTML tags that it understands, and displays a question mark for any tags that it cannot 
interpret. For more information, see “Viewing and Editing HTML Code” on page 171.
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PageMill may interpret or preview some HTML tags differently than other page-creation appli-
cations. If you open a page that was not created by PageMill to edit it, make a copy of the 
original file before you start to open it. After making sure the edited document looks and acts 
as expected in a browser, you can delete the original file. 

For information on opening files created in other applications, see page 26.

To open a PageMill page:

Do one of the following:

• From within PageMill, choose File > Open.

• From the Windows desktop, right-click the file’s icon and choose Edit with PageMill.

Note: PageMill saves files using the standard Web filename extensions: .html and .htm. Double-
clicking a PageMill file opens the file in the application that Windows associates with that extension 
(.html or .htm), which is usually a Web browser and not PageMill. To make PageMill the appli-
cation associated with these extensions, refer to your Windows online Help for instructions.

To reopen the current page and discard unsaved changes:

Choose File > Revert to Saved.

To open a page from the Web: 

1 Use a Web browser or a file-transfer (ftp) utility (for example, WS_FTP) to download the 
source HTML code to your computer (graphics and linked files are not downloaded). You 
cannot open a page directly over the Web. 

2 In PageMill, choose File > Open, locate the file from its downloaded location on your hard 
disk, and click Open. 

Opening pages in another application

You can open a PageMill page or image in any application that supports HTML or the graphic 
file’s format. This is useful when you want to preview the page in a different browser, or edit a 
page or image using a feature that PageMill doesn’t support. PageMill provides several shortcut 
methods of doing this:

• You can use the Switch To command. 

• You can drag the page icon or the image icon into another application.
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To open a page or image in another application:

1 Start the other application and position it so that its window is showing.

2 In PageMill, open the page or the image (to open an image in the Image window, right-click 
the image and choose Open Image Window).

3 Drag the page icon (the icon to the left of the Title pop-up menu) or the image icon into the 
other application window. 

 You can also drag the page icon or the image icon into an e-mail program to quickly 
add a page or image as an e-mail attachment.

To set up the Switch To menu:

1 Choose Edit > Preferences and click the Switch To tab.

2 Do the following:

• To add an application to the menu, type a name for it in the Name text box, click Browse to 
locate the application’s executable file, and then click Open.

• To remove an application from the menu, click the Remove button next to its name.

To open a page in another application using Switch To:

1 Make sure the page you want to open is the active page in PageMill, and then choose File > 
Save Page.

2 Right-click the page icon, which is to the left of the Title text box, or choose View > Switch To.
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3 Choose the application from the Switch To submenu.

Loading Web sites

A Web site is a group of related pages. When you edit the pages that make up your Web site on 
your computer, the site exists as a group of Web pages inside a single folder (the local root 
folder). The local root folder can contain additional subfolders and files. 

Once a Web site is opened, you can view or edit its organization and the links between pages. 
For details on loading Web sites, see page 151.

Adding page titles
One of the first things to do when creating Web pages is to give them a title. A page’s title 
identifies the page for readers on the Web—it appears on the browser’s title bar and in go-to 
lists in a browser. A page’s title is not the same as its filename, which is the name stored on the 
Web server’s hard disk and is never seen by a reader on the Web. For this reason, a title is not 
limited in length and content the way a filename is. The default title for a new page is Untitled 
Document.

To give a page a title:

In Edit mode (see page 17), enter the title in the Title text box, which appears above the page 
window.

Viewing pages
You can view a page in any of several modes:

• PageMill Preview mode

• Internet Explorer Preview mode

• Edit mode
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You can switch between modes at any time. You can tell which mode is active by looking at the 
Mode button (the large button in upper right corner of the application window).

PageMill Preview mode In this mode, the Mode button appears as a globe icon. This mode is the 
default view when you open an existing page (but you can change this default if you want). You 
can’t make any changes to a Web page in Preview mode. 

When using PageMill to preview, you can see how the page will appear in most Web browsers 
and you can browse links to other pages stored on your local computer. 

The Mode button in PageMill Preview mode is a globe.

Internet Explorer Preview mode If you have Internet Explorer (version 3 or later) installed, you 
can use this preview mode. The Mode button’s icon is a stylized letter e in this mode. When 
using Internet Explorer to preview, you can browse remote linked pages without opening a 
separate window. For example, you could test a link that goes to www.adobe.com. You can also 
preview ActiveX controls (see page 64) and HTML tags that aren’t supported in PageMill 
Preview mode (for example, the BLINK tag or those used in cascading stylesheets). A page must 
be saved before previewing it in Internet Explorer.

The Mode button in Internet Explorer Preview mode is a stylized e.

 You can preview your Web pages in any installed browser, not just in Internet 
Explorer, by adding the browser to the Switch To menu (see page 16).
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Edit mode In this mode, the Mode button appears as a pen-and-paper icon. Edit mode is the 
default view when you create a new page and is the only WYSIWYG view in which you can edit 
Web pages. (Advanced users can also use a non-WYSIWYG version of Edit mode, called Source 
mode, that lets them view and edit the underlying HTML code for a page; see “Viewing and 
Editing HTML Code” on page 171.) The Inspector (see page 22) and the toolbar at the top of 
the window are active only in Edit mode. The contents of the toolbar change depending on 
what type of object is currently selected.

The Mode button in Edit mode is a pen and paper.

To switch between Preview mode and Edit mode:

Do one of the following:

• Click the Mode button in the upper right corner of the page.

• Choose View > Preview Mode.

• Press Control+Enter.

To open linked pages:

In Preview mode, do one of the following:

• To open the linked page in the current window, click the link.

• To open the linked page in a new window, right-click the link and choose New Window 
(PageMill Preview mode) or Open in New Window (Internet Explorer Preview mode).

To specify the default behavior for previewing linked pages:

1 Choose Edit > Preferences and click the General tab.

2 Do the following:
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• To specify whether pages should open in Preview, Edit, or Source mode, make a choice from 
the Open Pages In pop-up menu.

• To specify whether linked pages should open in the same window or in a new window, make 
a choice from the Local Links pop-up menu.

3 Click OK. The default settings go into effect the next time you open a page or click a link.

To move between the most recently visited pages in Preview mode:

Do one of the following:

• Click the Back, Forward, or Home buttons at the top of the page. 

• Choose the page from the Title pop-up menu.

Title pop-up menu

Note: Moving between recently viewed pages is possible only when you’ve previewed pages in the 
same window. 

To specify whether to preview in PageMill or in Internet Explorer:

Do one of the following:

• To specify the default preview application, choose Edit > Preferences, click the General tab, 
choose from the Preview Mode pop-up menu, and click OK.

• To override the default preview setting, right-click the Mode button in the upper right corner 
of the page and choose a preview application.

To save a page automatically when switching to Internet Explorer Preview mode:

Choose Edit > Preferences, click the General tab, and select the option “Save Automatically 
Before Previewing in Internet Explorer.”
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About right-click menus
PageMill offers an extensive set of context-sensitive menus, accessed by right-clicking an object 
or a page. Some commands on these menus are standard (Cut, Copy, and Paste), but most are 
unique to PageMill and are relevant to the place you clicked or to the object selected.

The context menus can also be found on the menus in the main menu bar. When a site is 
loaded, the right-click menus are duplicated in the Site > Site Selection submenu. 

Note: The PageMill documentation does not always mention the alternative of choosing a 
command from the right-click menu unless it’s the easiest or fastest way to access a command.

Controlling the window display
Using the commands on the Window and View menus, you can control how PageMill displays 
its windows, palettes, and the Edit mode toolbar. When working with a site loaded, you can also 
specify the default view for the Site Details window (see page 156).

Several parts of the PageMill window display and environment are context-sensitive, which 
means they change according to the current selection or activity:

• The buttons in the Edit mode toolbar

• The contents of the right-click menus (see page 21)

• The contents of the Inspector and which panels are available (see page 22) 

To cascade (stack), tile, or close all windows:

Choose a command from the Window menu.
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To hide or display the Edit mode toolbar:

Choose View > Toolbar.

To control whether the Edit mode toolbar is shown when you open or create a page:

1 Choose Edit > Preferences and click the General tab.

2 To keep the toolbar from showing when you create a new page or open a page, deselect the 
option “Open Pages with Toolbar Shown.”

To bring an open window to the front:

Choose its name from the Window menu or press Control+Tab to cycle through all open 
windows.

To show or hide the status bar, the Inspector, the Color Panel, or the Pasteboard:

Choose the appropriate command from the View menu.

Using the Inspector
The floating Inspector palette displays information and properties about the current page or 
selected page elements. It is active only in Edit mode and has the following tabbed panels:

• The Frame panel, which has options for the current frame (see “Using Frames” on page 133)

• The Page panel, which has options for the current page (see “Working with Text” on page 25)

• The Form panel, which has options for the script associated with the current form (see 
“Creating Forms” on page 121)

• The Object panel, which has options for selected images, tables, and other objects (see 
“Adding Tables” on page 107 and “Adding Images and Multimedia Objects” on page 45)

A. Frame tab B. Page tab C. Form tab D. Object tab

DCBA
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To display or hide the Inspector:

Choose View > Show Inspector or choose View > Hide Inspector.

To display a panel:

Click the corresponding tab. (The Frame and Object panels are unavailable if no frame or 
object is selected.)

Setting general preferences
You can specify the default behavior for many PageMill features by setting up preferences. 

To set up the defaults for pages and sites:

Choose Edit > Preferences and do any of the following:

• Click the General tab and set preferences (see page 17 and page 21).

• Click the Page tab and set preferences (see page 14 and page 38).

• Click the Active Content tab and set preferences (see page 63 and page 64).

• Click the Resouces tab and set preferences (see page 45 and page 100).

• Click the Server tab and set preferences (see page 84).

• Click the HTML tab and set preferences (see page 174).

• Click the Switch To tab and set preferences (see page 15).

• Click the Site tab and set preferences (see page 151, page 158, and page 160).

To set up the defaults for uploading Web sites:

Follow the steps described on page 167.
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Printing pages
You can print a page from either Edit or Preview mode. If you print from Internet Explorer 
preview mode, you see the PageMill—not the Internet Explorer—Print dialog box.

When you print from a page with frames, you print the contents of the current frame, that is, 
the page in that frame (see page 144).

To print a page:

Choose File > Print.

Using plug-ins
In addition to browser plug-ins (see page 48), you can use PageMill plug-ins, which add features 
to PageMill. Plug-ins are special drop-in files and are distributed and supported by third-party 
vendors. Once installed, a plug-in usually adds its command to one of the PageMill menus 
based on what type of function it performs. Additionally, most plug-ins also appear in the 
Plug-in menu in the main menu bar.

To install a third-party plug-in:

Follow the instructions that came with the plug-in.

To access an installed plug-in:

Choose its command from one of the following locations:

• If a plug-in automates page creation, choose from the File > Create submenu.

• If it inserts content, choose from the Insert > Plug-in submenu.

• If it edits page content, choose from the Edit > Plug-in submenu.

Any or all of these menu locations may not appear, depending on the type of plug-in and where 
it was installed in the Plug-ins folder.

To get more information on an installed plug-in:

Choose Help > About Plug-in and then choose from the submenu. The About dialog box may 
give copyright information as well as information on the features and use of the specified plug-in.
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Chapter 3: Working with Text 

ext and images are the most basic features of a Web page, and form the foundation for 
the links you will add later. You can add text to a Web page and edit it using PageMill 
tools.

Entering text on a page
Most of the time, typing directly on a page is the most straightforward way to add text to a Web 
page. However, HTML imposes a few restrictions when you want to enter multiple spaces or 
special characters.

To type text directly on a page:

1 In Edit mode (if necessary, click the Mode button to switch to Edit mode), click to place the 
insertion point and then type the text.

2 Text word-wraps as needed. You can break a line manually by doing one of the following:

• To start a new paragraph, press Enter. (This creates a P tag and results in an extra line between 
paragraphs.)

• To create a line break within a paragraph (sometimes called a soft return), choose Insert > 
Special Character > Line Break (or press Shift+Enter). (This inserts a BR tag in the HTML code 
and avoids an extra line between paragraphs.)

To type multiple spaces:

In Edit mode, do one of the following:

• Choose Preformatted from the Format pop-up menu (see page 30) and then press the 
spacebar repeatedly.

• Choose Insert > Special Character > Nonbreaking Space (or press Control+spacebar) to 
enter multiple hard space characters. (Unlike regular spaces, multiple nonbreaking spaces are 
not collapsed into a single space by a Web browser.)

• To simulate spacing, you can enter text in table cells (see “Adding Tables” on page 107).

T
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To enter a special character:

In Edit mode, do one of the following:

• To enter a line break, choose Insert > Special Character > Line Break. Adding a line break is 
similar to pressing Enter except that it avoids an extra line between paragraphs.

• To enter a nonbreaking space, choose Insert > Special Character > Nonbreaking Space.

• To enter an accented letter, press Alt and type the four-number ANSI character code from the 
numeric keypad (not the numbers on the first row of the keyboard). For example, to type the 
accented letter in the word resumé, hold down Alt and type 0233. Refer to a Windows reference 
book for a list of ANSI character codes. You can also enter special characters or look up ANSI 
codes by using the Character Map application (which is usually in the Start > Programs > 
Accessories menu).

• To enter an accented letter using its special HTML code, choose View > HTML Source and 
enter the HTML code for the special character. For example, to enter é, you would type 
&eacute;. For a full list of HTML character codes, see page 178.

To delete text:

In Edit mode, select the text, and then choose Edit > Clear, or press Backspace.

Importing text 
You can import text to a Web page in these ways:

• Copy or cut the text from another application, and then paste it into the page in PageMill.

• Drag the text from another application, and then drop it into the page in PageMill.
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• Using the Open command, import text in any of the following formats. 

Note: If a file in another application contains Japanese characters, you cannot open it in PageMill 
using the Open command. However, you can drag and drop or copy and paste the contents of the 
file.

Importing text from another application removes most character or paragraph formatting. 
Because HTML uses the ISO Latin-1 encoding, it cannot preserve and represent some special 
characters (for a list of what can be represented, see page 178). If you try to enter or paste a 
special character that HTML does not support, PageMill filters it out.

To import text or spreadsheet data using the Open command:

1 Choose File > Open.

2 Choose All Files or Convertible Files from the Files of Type pop-up menu to display all 
formats supported by PageMill. To read other text formats, the appropriate converter must be 
installed in the Text Converters folder.

3 Locate and select a file, and click Open. PageMill opens the file into a new, untitled 
document.

If the file contains images in BMP formats, PageMill converts the files to GIF format and saves 
them in the specified resource folder (see page 45). For more information on importing 
graphic files, see “Adding an image or multimedia object” on page 50.

Application or file format Filename extension Versions

AMIPro/Professional WordPro .sam 1.1 and later

ClarisWorks™ .cwk 3.0 and later

HTML files .htm, .html —

Lotus 1-2-3 .wk2, .wk3, etc. 1A to 5.0

Microsoft® Excel .xls 2.1 to 5.0, 7.0

Microsoft Word .doc 1.0 to 2.0 and 6.0 (later versions can be saved in 6.0 format and 
opened in PageMill)

Rich Text Format (RTF) .rtf —

Text .txt —

WordPerfect® .wp5, .wp6 5.0 and 6.0



CHAPTER 328
Working with Text

To import text by dragging and dropping:

1 In Edit mode, set up the PageMill window and the window in the second application so that 
both are visible. The second application must support drag-and-drop features.

2 In the other application, select the text, drag it into the PageMill page window, and then 
release the mouse button.

 The drag-and-drop feature isn’t just for importing. You can quickly move text around 
a page in PageMill or between pages by selecting it and then dragging it.

To import text by copying and pasting: 

1 In another application, copy the text.

2 In PageMill, switch to Edit mode, and place the insertion point where you want to paste.

3 Choose Edit > Paste. PageMill imports only the text; most formatting is not retained.

Applying paragraph formats
Paragraph formats structure the HTML pages. You apply different formats to parts of a page 
that serve different functions, such as headings, paragraphs of body text, and lists. Applying a 
format changes an entire paragraph. (To change the appearance of individual words or 
characters, apply character styles instead; see page 33.) For more information, see “About Web 
page design” on page 3.

With all formats except Preformatted, browsers collapse multiple spaces, tabs, and line-break 
characters into a single space. 

To apply a paragraph format:

In Edit mode, click in a paragraph or select several paragraphs and do the following:
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• Choose a format from the Format pop-up menu in the toolbar. 

• Choose a format from the Format menu. For a description of the formats, see “Standard 
paragraph formats” on page 29 and “Creating lists” on page 31.

Standard paragraph formats

You can choose the following formats either from the toolbar or from the Format menu:

Paragraph A plain format used for body text. Applying the Paragraph format removes other 
paragraph formatting. 
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Preformatted Applies a monospaced (fixed-width) font, retaining all the original spaces and 
line breaks. The Preformatted format tries to preserve the original spacing of text (though not 
its font), and is useful for representing data from spreadsheet applications. Browsers typically 
display the Preformatted format in a monospaced font such as Courier. 

Paragraph format applied to tabular data and Preformatted format applied to the same data

Address Useful for formatting an e-mail address, a postal address, or a telephone number. In 
PageMill, the address appears in italics. The actual appearance depends on the browser. (You 
still must link the mail address to make the browser jump to the mail command; see page 78.)

Note: Although PageMill lets you center and right-align Preformatted and Address text, browsers 
display these two formats as left-aligned text. If you want to center or right-align the text but still 
want it formatted in a monospaced font, use the Paragraph format, specify the alignment, and then 
apply the Teletype character format to the text. You can also change the HTML Syntax Alignment 
preference to <DIV>, as explained on page 174.

Heading formats Organize the text and let you break it into sections. The sizes for the six 
heading formats are relative, because the actual display size depends on the browser used to 
view the page. In general, use the largest size for the main heading on the page and use the other 
sizes for subheadings. When you select a Heading format, PageMill shows the Bold button 
selected (and Bold appears checked in the Style menu) because most browsers display all 
heading formats in bold. You cannot remove the boldface type style. 

List formats Create different kinds of lists. Some list formats add numbers or bullets to list 
items automatically. The actual appearance of a list depends on the browser. For more infor-
mation, see “Creating lists” on page 31.
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Creating lists

Creating a list is similar to applying other paragraph formats except that you can nest lists 
within lists and that some types of lists require two formats. You can choose from six types of 
lists:

Bullet List, Directory List, and Menu List Converts text into an indented, bulleted list. The bullets 
are added automatically in front of each paragraph. Depending on the browser, the items in 
some of these lists may appear without a bullet or in a multicolumn layout.

Bulleted lists

Numbered List Converts text into an indented, numbered list. PageMill inserts number signs 
(#) next to each item in the list. The correct numbers appear in Internet Explorer Preview mode 
or when the page is displayed in a Web browser. 

Numbered lists shown in PageMill and in a browser.
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Term List and Definition List Designed to be used together to present glossary information. The 
Term format positions selected paragraphs flush with the left margin of the page. The 
Definition format indents the selected paragraphs.

A. Term format B. Definition format

To apply a Bullet, Directory, Menu, or Numbered list format:

In Edit mode, select one or more paragraphs and then choose from the Format > List menu or 
choose from the Format pop-up menu in the toolbar.

To add a paragraph to a list:

Do one of the following:

• Press Enter to add another item to the list at the current indent level.

• Press Shift+Enter to add a paragraph that’s indented but unnumbered or unbulleted.

To create a nested list:

In an existing list, select one or more paragraphs and then choose Format > Indent Right. 
PageMill automatically applies a different bullet or numbering style to each level of a nested list. 

To apply Term and Definition list formats:

1 Edit the text so that terms and definitions alternate and are separate paragraphs.

2 Click a term and choose Format > List > Term.

3 Click the definition associated with that term and choose Format > List > Definition.

A

B
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Indenting text

To indent to the left, PageMill removes space from the margins on both sides of text; to indent 
right, it adds space to the margins. The actual amount of the indent depends on the browser 
(some browsers don’t indent at all). Indenting can affect any type of text block, regardless of its 
formatting. PageMill indents nonlist text by nesting instances of the BLOCKQUOTE tag.

Bottom paragraph indented right

To indent text:

In Edit mode, click in a paragraph or select one or more blocks of text and then click the Indent 
Right ( ) or Indent Left ( ) button in the toolbar. You can also choose from the Format > 
Indent menu.

Changing alignment

PageMill lets you align text to the left, center, and right. (Some browsers don’t support center 
or right paragraph alignment.) You can change alignment of any type of text block, regardless 
of its formatting.

To change alignment:

In Edit mode, select one or more paragraphs and then click the Left Align Text button ( ), the 
Center Align Text button ( ), or the Right Align Text button ( ) in the toolbar. You can also 
choose from the Format > Align Text menu.

Note: You can specify what HTML code PageMill uses to center paragraphs (see page 174).

Applying character styles
Character styles distinguish individual characters or words on a page. Applying a character 
style changes only the selected characters. (To change entire paragraphs, apply paragraph 
formats instead; see page 28.) You can choose from physical or logical character styles.
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Some character styles, such as Sample, Keyboard, Code, and Variable, may seem unusually 
technical—a reflection of the roots of the Internet and the HTML language, which were created 
for distributing reports throughout the scientific and technical community. 

To apply a character style:

Select a range of text and use the Style menu to choose a character style. (You can also use the 
toolbar buttons to quickly apply the Bold, Italic, or Underline character styles.)

About physical character styles

A physical style changes the appearance of selected text in a specific way—by making the text 
bold, italicized, underlined, or monospaced (Teletype style). Apply a physical style to make 
character formatting consistent across browsers. You can also apply the Plain character style, 
which uses no special formatting. 

About logical character styles

A logical style tags the selected text, but the actual appearance of the text depends on how a 
particular browser interprets the tag. For example, applying the logical style Emphasis lets a 
browser use its own definition of Emphasis, which could mean italics, underlining, or boldface. 
Apply a logical style when the function of the selected text is more important than its specific 
appearance, or when you want a reader to control the appearance of character styles.

Emphasis Calls attention to the selected text. Many browsers display emphasis with italics.

Strong A more intense emphasis, often displayed with boldface text.
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Citation Used for titles of publications or other media. Many browsers display citations with 
italics.

Sample Useful for representing computer status messages, and is displayed by most browsers 
with a monospaced font.

Keyboard Useful for representing text to enter into a computer, and is displayed by most 
browsers with a monospaced font.

Code Used to represent lines of computer code, and is displayed by most browsers with a 
monospaced font.

Variable Used for variables within computer instructions. For example, use the Variable style 
for the phrase “your_password” in login instructions and the like. Many browsers display 
variables with italics.
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Changing fonts and font sizes
Browsers ordinarily use their default fonts to display text. However, you can override the 
default font with a specific one for selected text. If the text is viewed on a computer that doesn’t 
have the specified font installed, the default font is used. (Try to choose a font that you’re 
confident your viewers will have installed on their computers.)

Although you can’t set an absolute font size for text on a page, you can indicate how the text 
size should differ from the browser’s default size. You can enlarge or decrease the font size, or 
specify a size relative to the surrounding text.

Note: Because not all browsers support font size changes, it’s safest to change the font size only for 
limited special effects. To ensure that all readers can distinguish larger text, use a paragraph 
heading format instead of a font-size change.

You can also change the base font size. The base font size defines the size of text that has no 
formatting. Setting the base font size to 3 means that the font size setting of the viewer’s 
browser will determine the size. Setting the base font smaller (1 or 2) or larger (4, 5, 6, or 7) 
changes the size of unformatted text so that it’s smaller or larger than normal for the browser.

All other font sizes are relative to the base font value (with 7 being the maximum). For example, 
if the base font is set to 4, you can increase the relative font size up to +3; if the base font is 7, 
only negative relative font sizes are available.

A. Decrease relative font size B. Current relative font size C. Increase relative font size

To change the font:

In Edit mode, select the text you want to change and do one of the following:

• If the toolbar is showing, choose a font from the Font pop-up menu on the toolbar. 

• If the toolbar is not showing, choose Style > Font and choose a font from the submenu.

To change the base font setting:

1 In Edit mode, display the Inspector (choose View > Show Inspector) and click the Page tab.

2 Choose a value from the Base Font menu.

CBA
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To change the relative font size:

In Edit mode, select the text and do one of the following:

• Choose Style > Size > Increase Font Size or Decrease Font Size to enlarge or reduce the font 
size by one size.

• Click the relative font size buttons ( ) ( ) in the toolbar. Each click changes the relative font 
size by one size.

• Click the Current Relative Font Size button (between the font size buttons) and choose a new 
size from the menu.

Note: You can specify what HTML code PageMill uses to change font sizes (see page 174).

Working with color
Some uses of color on a Web page are purely decorative, such as changing the background color 
of a page. Other uses of color provide information to readers, such as indicating whether text 
is a link and whether that link has been clicked (visited) lately.

When using colors in Web pages, you will usually want to choose only from the Web-safe color 
palette—a range of 216 colors that appear on all platforms identically, that is, without 
dithering. However, you can choose from a range of colors greater than the 216 colors by using 
the Color dialog box. If you’re designing for a single-platform intranet, you may want to access 
additional colors since you won’t have to worry about cross-platform dithering.

PageMill offers two mechanisms for working with color:

• You can use the Color Panel. The Color Panel can be collapsed to a floating palette of 16 
customizable colors, or expanded to the full palette of 216 Web-safe colors. The collapsed Color 
Panel is initially defined with 16 Web-safe colors, but you can redefine these colors to use any 
other color, including non-Web-safe ones.
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• You can use a Text Color pop-up menu. A Text Color pop-up menu contains color swatches 
for the 16 colors found in the collapsed Color Panel. It also contains commands for accessing 
non-Web-safe colors and for letting the browser determine the color. Text Color pop-up menus 
appear in the toolbar, in the Inspector, and in the Preferences dialog box. If you change a color 
in the collapsed Color Panel, the color also changes in all the pop-up menus.

Expanded Color Panel and Text Color pop-up from toolbar

Note: To differentiate all 216 colors in the expanded Color Panel, your computer must be set to 256-
color (8-bit) mode or higher.

Changing the color of text, links, and page backgrounds

By default, text entered on a page is black and links are blue. You can change the color of text 
and the color of links, active links, and links that have been clicked. (If the link is an image, the 
border color changes.) Some older browsers may not recognize the new colors and may 
continue to display text and links in the default colors for those browsers.

Note: PageMill Preview mode doesn’t show you visited-link colors, but Internet Explorer Preview 
mode does.

To specify a default color for text, links, and background color for new pages you create, use the 
Edit > Preferences command (see page 13). To change the colors for a single page, use the 
Inspector. To change the color of selected text, use the Text Color button in the toolbar. 



39

 PageMill’s default color for a page background is gray. This may not be the same as 
the default background in a browser (for example, the default background in Internet 
Explorer may be white). To ensure a consistent color, manually choose a color for the 
background; don’t leave the setting as Default.

To change the color of text, page background, or links for a specific page:

1 In Edit mode, display the Inspector (choose View > Show Inspector) and click the Page tab.

2 Do one of the following:

• To use a Web-safe color, choose View > Show Color Panel, drag a color from the expanded 
Color Panel, and then drop it on the color box in the Inspector.

• To use a color from the group of 16 colors (which are also Web-safe unless you’ve redefined 
them to use non-Web-safe colors), choose a color swatch from a pop-up menu.

• To use a non-Web-safe color, choose Custom from a pop-up menu and select a new color. 
Then click OK. 

• To let the browser determine the color to use, choose Default from a pop-up menu. 

All changes apply to the entire page.
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To change the color of selected text:

Select the text and then do one of the following:

• Click a color from the Text Color pop-up menu ( ) in the toolbar. 

• Click a color in the Color Panel (either collapsed or expanded).

• Choose Custom from the Text Color pop-up menu ( ) in the toolbar, select a new color, and 
then click OK. (This may apply a non-Web-safe color and so is not advised.)

Note: You cannot change the color of linked text using the Text Color pop-up menu. All linked text 
must be the same color and is set in the Inspector. 

Customizing the Color Panel

The Color Panel is a floating, expandable palette that contains the full set of 216 Web-safe 
colors as well as 16 color buttons that you can customize. You can customize only the 16 
buttons in the collapsed Color Panel; the expanded Color Panel cannot be changed.

To expand or collapse the Color Panel:

Click the arrow button below the 16 color buttons.

To customize the 16 color buttons of the Color Panel:

1 Choose View > Show Color Panel and click the arrow button to show the full palette of 216 
colors, if necessary.

2 Do one of the following:

• To replace a color button with a different Web-safe color, drag a color from the expanded 
palette onto one of the 16 color buttons. 

• To replace color buttons with new colors, including non-Web-safe colors, right-click a color 
button and choose Set Custom Colors. Then define one or more new colors and click OK.

The color changes in the collapsed Color Panel as well as in the Text Color pop-up menus.

To reset all the Color Panel buttons to their default colors:

Right-click a color button and choose Set Default Colors.
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To determine the hex value of a color:

Place the pointer over a color in the Color Panel. After a few seconds, the hex value of that color 
appears. You may need the hex value of a color if you’re editing HTML code when working in 
Source mode (see page 173).

Checking spelling
The Check Spelling command lets you check the spelling in a single file or in all the files in a 
site. PageMill highlights misspelled or unknown words and words with possible capitalization 
errors. 

PageMill also includes a dictionary of common Internet terms and tags and lets you create one 
user dictionary—a separate file that you customize to supplement the main dictionary. The 
user dictionary contains all the words added to the dictionary during spelling checks or when 
correcting capitalization. 

To check spelling:

1 Open the Spell Checker by doing one of the following:

• With a page active in Edit mode, choose Search > Check Spelling.

• With a site loaded, right-click a file or folder in a site window and choose Check Spelling.

The Spell Checker begins immediately and stops at the first unknown word. At this point, you 
can continue checking spelling or you can adjust settings (see page 41).

2 Choose from the following options:

• Click Ignore to continue checking spelling without changing this text or click Ignore All to 
leave all instances of the text unchanged.

• Enter a correction in the Change To text box or select a word from the Suggestions list, and 
then click Change to correct the selected occurrence or click Change All to correct all 
misspelled occurrences in the text.

• Click Add to store the text in the user dictionary and not mark subsequent occurrences as 
incorrect.

To adjust spell-check settings:

1 Open the Spell Checker (see page 41). The Spell Checker begins immediately and stops at the 
first unknown word. 
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2 Choose a language from the pop-up menu in the lower right corner of the Spell Checker to 
load the appropriate main dictionary.

3 From the Scope pop-up menu, do one of the following:

• Choose Page to search the current Web page.

• Choose Site Selection to search the pages of the site that are currently selected.

• Choose Entire Site to search all the pages of the current site.

4 Deselect Wrap if you don’t want to continue searching at the beginning of a document after 
reaching its end.

5 Click Start to continue the spell-check.

To create, save, or use a user dictionary:

1 Exit PageMill and move the User Dictionary file to another folder (or delete it if you won’t 
be needing it again). This file is in the Spelling folder.

2 Do one of the following:

• To create a new user dictionary, restart PageMill. 

• To use a different user dictionary, move the new one into the Spelling folder and restart 
PageMill.

Searching for text
PageMill lets you search for and replace any object you can select, including text. For details, 
see page 68.

Entering Japanese text
If you’re working on a Japanese-enabled system, you can use PageMill to create Web pages that 
contain Japanese and other double-byte characters. These features are not visible on non-
Japanese systems.

Note: If a file in another application such as Microsoft Word or Excel contains Japanese characters, 
you cannot open it in PageMill using the Open command. However, you can drag and drop or copy 
and paste the contents of the file.
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To enter Japanese characters:

In Edit mode, enter Japanese characters as usual, using the front-end processor installed on 
your computer. You can change fonts using the Style > Font command.

To view or change the character set:

1 Choose Format > Character Set. The current character set is shown with a check mark. 
Choose a different character set from the menu list.

2 Restart PageMill.

To set up preferences for entering Japanese characters:

1 Choose Edit > Preferences and click the International tab.

2 Do the following:

• To set the default character set, choose from the Character Set pop-up menu.

• To specify fonts, choose from the Language pop-up menu and then choose a default font for 
displaying proportional characters and a default font for monospaced characters.

3 Click OK.

4 Restart PageMill for your changes to take effect.
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Chapter 4: Adding Images and 
Multimedia Objects

our Web pages can contain more than just text. PageMill lets you add images and a 
wealth of multimedia objects such as Java applets, animated GIFs, movies, animations, 
and sounds. You can also use some of these objects as links to other locations. (But if 

your readers will view your pages using modems, you should minimize the use of these objects 
to let the pages load faster.)

About links to image files
It’s important to understand how images are linked to your Web page, because moving an 
image or other linked file after you have imported it can break the link:

• Importing a GIF or JPEG file into PageMill creates a link from your Web page to that image’s 
file, wherever it was located when you imported it.

• Dragging an image from a Web browser or from an image-editing application into PageMill 
copies the file and then creates a link to the copy.

• Importing a BMP file copies the file (leaving the original intact), converts the copy to GIF 
format, and then names the new file Imagex.gif (Image1.gif, Image2.gif, and so on). The Web 
page links to the GIF copy, not to the BMP original. To change the Imagex.gif name, be sure to 
do so in the Site Overview area so that you won’t break the link (see page 158).

PageMill uses settings from the Preferences dialog box to determine where to place the copies 
of the converted images:

When you’re working with a site loaded Images are placed in the folder specified in the Site 
Resources Folder Name text box (choose Edit > Preferences and click the Site tab). The default 
folder name is Resources and is located within the local root folder for the site.

When you’re working with no site loaded Images are placed in the folder specified in the 
Resource Folder text box (choose Edit > Preferences and click the Resources tab). The default 
folder name is PageMill_Resources. This default location of this folder is usually not within 
your site.

Y
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For best results, both of these locations should specify the same folder, and that folder should 
be within the local root folder. Making the Resource Folder the same as the Site Resources 
Folder ensures that all converted files are stored within the local root folder. Be sure to set up 
the folder before you import any BMP files. For more information, see page 11. 

To view the URL of an image on a page:

Do one of the following:

• In Edit mode, place the pointer over an image and pause there. The full URL appears and 
then disappears after a few moments.

• In the Site Overview area, right-click an image file and choose Properties. The full pathname 
appears in the dialog box.

About file formats
To be recognized by PageMill and browsers, images and multimedia objects (animations, 
movies, Java applets, and sounds) must be named with the correct filename extensions (.gif, 
.mov, .wav, and so on).

Web browsers can display images that are in GIF and JPEG formats. PageMill also lets you 
import BMP files, which PageMill automatically converts to GIF format. 

PageMill can also import Adobe Acrobat Portable Document Format (PDF) files, movies in the 
QuickTime® for Windows format, and Macromedia Shockwave™ files. To use these files, see 
page 48.

Image file formats

PageMill can use images in the following formats:

BMP (.bmp, .dib) The standard Windows bitmap image format. PageMill automatically 
converts a BMP file into a GIF file. A DIB file is a type of BMP file and is treated like files with 
the BMP extension.

GIF (.gif) An 8-bit color format that can display up to 256 colors. It is useful for nonphoto-
graphic images with a fairly narrow range of color. 
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JPEG, ProJPEG (.jpeg or .jpg) Appropriate for images with a wide range of color, such as a 24-bit 
(millions of colors) photograph. ProJPEG files are enhanced JPEG files that can be displayed in 
a browser in stages (progressively). Be sure your JPEG images are saved in RGB or Indexed 
Color mode, and not in CMYK mode, which is not supported by Web browsers.

Portable Document Format (.pdf) The standard document-viewing format created using 
Acrobat Exchange or Distiller. It requires that the correct browser plug-in be installed (see 
page 48). See page 79 for how to create a link to a PDF file.

Movie and animation file formats

PageMill can insert and play movies and animations in the following formats:

Animated GIF (.gif) A version of GIF that contains a sequence of several images in a single file. 
Switching to Preview mode makes an animated GIF file cycle through the images, so you can 
see the animation. You can create animated GIF files using shareware programs available on the 
Web (such as GIF Construction Set) or by using Adobe Premiere®.

Note: Not all browsers fully support animated GIF files, so be sure to preview your page in your 
intended browser. Some browsers play an animation only once or display only the first or last frame 
of the animation. 

Microsoft Video (.avi) Requires that the correct browser plug-in or Active Movie ActiveX control 
be installed (see page 48).

MPEG (.mpg or .mpeg) Requires that the correct browser plug-in be installed (see page 48).

QuickTime (.mov) Requires that QuickTime for Windows 2.0 or later be installed on your 
computer. You must also have the correct browser plug-in installed (see page 48).

Shockwave (.dcr) A Web-based animation format used by Macromedia applications such as 
Director. To use a Shockwave file, you must have the correct browser plug-in installed (see 
page 48).

Sound file formats

Browsers can recognize many formats for sound clips. Inserting a sound actually creates a link 
to the sound file. 

PageMill can insert sound files in the following formats:

AU (.au) The most commonly used format for cross-platform applications.
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Audio Interchange File Format (.aiff, .aif) Widely used on Macintosh and Silicon Graphics 
computers.

MIDI (.mid, .rmi) Is a common format for synthesized music. MIDI sound support is native to 
Windows.

Windows sound (.wav) Is widely used in Windows applications. 

Applets and controls

You can include two types of mini-programs in your Web pages: Java applets and ActiveX 
controls.

Java (.class) A format for small applications (called applets) often used for animations created 
using the Java programming language. PageMill lets you insert and preview them. Older 
browsers may not support Java applets.

ActiveX (.ocx) A format for small applications (called controls) that can interact with readers 
and add functionality to a Web page. PageMill can preview controls only in Internet Explorer 
Preview mode. 

Using browser plug-ins
To use PDF or multimedia objects in PageMill, you may need the appropriate plug-in installed 
in the Browser Plug-ins folder. PageMill is compatible only with plug-ins compatible with 
Navigator 2.0.

Note: Because browser plug-ins vary in quality, save your work before first using a plug-in with 
PageMill. Common ones such as the PDF, QuickTime, and Shockwave plug-ins work well in 
PageMill, but others may not. If PageMill detects a problem with the plug-in, it displays a broken 
plug-in icon in place of the object. Try previewing the plug-in in a browser to see if it works as 
expected.

PageMill ships with the plug-ins for QuickTime movies. The plug-in for viewing PDF 
(Acrobat) files is included when you install Acrobat Exchange or Acrobat Reader.

If you try to insert a file into a Web page but don’t have the correct plug-in installed for that 
type of file, PageMill creates a link to the file instead of inserting it. 

If PageMill doesn’t recognize the filename extension of an object, PageMill assumes that the file 
contains data for a plug-in and creates an empty plug-in data object.
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To insert the browser plug-ins:

1 Determine which browser plug-ins you need and obtain them from their manufacturers.

2 Put a copy of these plug-ins in the PageMill Browser Plug-ins folder. 

3 Restart PageMill.

4 Confirm that there is also a copy of these plug-ins in your browser’s Plug-ins folder.

To set up the plug-in for viewing PDF files:

1 If necessary, install Acrobat Reader or Acrobat Exchange on your computer.

2 Locate the the plug-in file, called Nppdf32.dll, in the Browser folder that you installed 
Acrobat Reader or Exchange to.

3 Copy this plug-in file into the Browser Plug-ins folder, located in the folder you installed 
PageMill to.

4 Also copy this plug-in file into the browser’s Plug-in folder.

About images
An image on a Web page can be used as any of the following:

• A static picture that provides visual information

• A link to another resource (see page 76)

• An image map with multiple links to other resources (see page 95)

• A Submit or Reset button on a form (see page 129)

If you have many static images to display, consider creating a page of thumbnails, small versions 
of each image, in an image-editing application, and then link each thumbnail to a full-size 
version of the image (see page 53). A page of thumbnails downloads much faster than a page 
of full-size images. For help on choosing images to include on a page, see “Graphics consider-
ations” on page 5.

Important: To avoid problems when uploading, store all images within your site’s local root folder 
(see page 11).
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Adding an image or multimedia object
Adding an image or multimedia object to a page means either inserting it or linking to it. An 
inserted object appears right in the page; a linked object is not visible on the page but instead 
opens or plays when you click its link (which could be linked text or a linked graphic).

You can add images or multimedia objects to your Web page in any of the following ways:

Drag and drop Dragging and dropping an image either imports it or links to it. If it is a BMP 
file, PageMill converts to a GIF file named Imagex.gif (where x is a number) and places it in the 
specified resource folder (see page 45).

You can drag and drop any type of image from the following sources to an open PageMill page:

• From another page

• From a desktop folder window

• From a Web browser

• From another application, such as from Adobe Photoshop or Adobe Illustrator 7.0

• From the PageMill Pasteboard (see page 86)

• From an Image window (dragging the image icon in the upper left) 

The results of dropping an image on a page are listed in the following table:

Dragging and droping sounds always create a link. Some special considerations apply when 
dragging and dropping multimedia objects such as movies (see page 47), ActiveX controls (see 
page 64), and PDF files (see page 79).

Copy and paste Copying and pasting an image imports it. If it is a BMP file, PageMill converts 
it to GIF as Imagex.gif (where x is a number) and places it in the specified resource folder (see 
page 45). 

You can copy and paste from another PageMill page or from another application. 

Drag and drop (with no selection) Alt + drag and drop Drop onto a selection

Inserts the object Creates a link to the object Creates a link to the object
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Insert command Choose the Insert > Object command or click the Insert Object button ( ) in 
the toolbar.

Various ways to import images, animations, movies, and sounds into PageMill 

To import by dragging and dropping:

1 Make sure that the target PageMill window is in Edit mode. 

2 Do one of the following to open the source window:

• To drag from another PageMill window, use the File > Open command.

• To drag from another application, open that application.

• To drag from a desktop folder, open that folder.

• To drag from the PageMill Pasteboard, choose View > Show Pasteboard.

• To drag from the PageMill Image window, choose File > Open to open an image file in the 
Image window.

3 Position the source window so that both it and the target window are visible. 

4 Drag the image or object from the source into the open PageMill window, noting the 
following:

• When dragging from another application, be sure that application supports drag-and-drop 
functionality. If it doesn’t, try copying and pasting instead.

• When dragging a Java applet from a desktop folder, drag the .class file.

Desktop
window

Photoshop windowImage window

Pasteboard

Browser window
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• When dragging from the Image window, drag the GIF image icon (above the vertical 
toolbar), not the image itself.

To name the resulting GIF file as you drag and drop a BMP file:

Hold down Shift and Control-drag the BMP file, specify a name and location for the GIF 
version of it, and click Save.

To insert a BMP image without converting it to GIF:

1 Choose File > Open and open the BMP file in the Image window.

2 Drag the BMP image icon from the Image window into your Web page. PageMill inserts the 
BMP file without converting it. (Caution: Not all Web browsers support BMP images.)

To import by copying and pasting:

1 Copy the image in another application, and then click where you want to paste it in a 
PageMill page.

2 In Edit mode, choose Edit > Paste.

To import by using the Insert command or button:

1 In Edit mode, do one of the following:

• Choose Insert > Object and choose a file type.

• Click the Insert Object button ( ) in the toolbar.

• Right-click the Insert Object button ( ) in the toolbar and choose the type of object you 
want to insert.

2 Locate the file you want to insert. To locate an object not present on your hard disk, select 
Remote URL and enter the URL of the object (see “About URLs” on page 75).

3 Insert the object by doing one of the following:

• To embed the object, click Place. Embedded sounds and movies play right in the Web page.

• To create a link to the object, click Link To. Linked sounds and movies play in a separate 
window.



53

To add a small image and link it to a larger version of the image:

1 Create a small version of a larger image in an image-editing application such as Photoshop. 
(Simply resizing the image in PageMill to thumbnail size doesn’t reduce the file size or the time 
it takes to download it.)

2 In PageMill, insert the small image into your Web page.

3 Do one of the following:

• Drag the icon for the original, larger image from an Explorer folder or from the desktop onto 
the smaller image.

• Drag the icon for the original, larger image from the Site Overview area onto the smaller 
image.

• Choose File > Open and open the original, larger image in the Image window. Then drag the 
image icon from the Image window and drop it on the inserted smaller image on your Web 
page.

Note: Linking PDF files to their thumbnails is a special case. For instructions, see page 79.

To insert, not link, an image whose format is not supported by PageMill:

Locate the file whose format is unsupported (for example, a TIFF file) and do one of the 
following in Edit mode:

• Install a plug-in that supports the file type (see page 24 and page 48) and then insert in the 
regular ways (for example, by dragging and dropping).

• Hold down Control and drag the file into the page.

Editing images
The types of editing you can do to an image depend on how you’ve selected the image.

When you’ve selected an image as a whole, a thin line with three handles appears around it, and 
you can do the following:

• Align an image so that text runs around it. 

• Resize the image.

• Change the border around the image.

• Add an alternate text label for the image (see page 61).
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• Change the behavior of the image so that it can function as a button (see page 130).

When you’ve selected an image so that you can edit its contents, a thick dashed line appears 
around it, and you can do the following:

• Add hotspots to the image that you want to use as a client-side image map (see page 96).

• Open it in an Image window.

When you’ve opened the image in an Image window, you can do the following:

• Add hotspots to the image that you want to use as a server-side image map (see page 101).

• Make a GIF file interlaced or a JPEG file progressive so that a low-resolution version of the 
image downloads first (and more quickly) before a higher-resolution version does.

• Make parts of a GIF image transparent.

Selecting images

To edit an image, you must first select it. PageMill has three selection states for images:

• When a thin line with handles surrounds an image, you can edit the image as a whole—for 
example, by aligning or resizing it.

• When a thick dashed line appears around it, you can edit the image to be a client-side image 
map—for example, by adding hotspots (see page 96).
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• When the image is opened in an Image window, you can edit several properties (to make it 
interlaced or transparent) or you can make it into a server-side image map (see page 99).

To select an image as a whole:

In Edit mode, click the image. A thin line with three handles appears around the image, and the 
toolbar changes to include image-positioning buttons.

To select an image so you can make a client-side image map:

In Edit mode, double-click the image. A thick dashed line appears around the image, and the 
toolbar changes to include client-side image map buttons (see page 96).

To open an image in an Image window:

Do one of the following:

• To open an image that’s already in a PageMill page, select the image and then choose Edit > 
Image > Open Image Window. You can also Control-double-click the image or double-click 
the image and then click the Open Image Window button ( ) on the toolbar.

• To open an image that’s not yet in a PageMill page, choose File > Open, locate the image file, 
and click Open.

Aligning images with text

You can align the top, middle, bottom, right side, or left side of the image with text. This is 
useful when an image in a line of text is taller than the text, which results in extra line spacing 
in that line. PageMill also supports wrapping text around an image. 

To align an image with text:

In Edit mode, click an image and then click one of the alignment buttons on the toolbar: Top 
Align Object ( ), Middle Align Object ( ), Bottom Align Object ( ), Left Align Object ( ), 
or Right Align Object ( ).
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To wrap text around an image:

1 In Edit mode, click the image and click the Left Align Object button ( ) or the Right Align 
Object button ( ) on the toolbar.

2 Enter text as usual. When the text reaches the bottom of the image, it returns to the normal 
margin.

3 To end the text wrap before the text has reached the bottom of the image, choose Insert > 
Margin Break. The margin break character ( ) moves the text following it below the image and 
returns to the normal margin.

Resizing images

You can resize an image visually or by a specific amount, either by pixel dimensions or as a 
percentage of the height or width of the browser window size. 

 To quickly change the size of an image that appears on several pages, resize the 
original image in an image-editing application instead of in PageMill. By doing this, all the 
inserted instances of the image will be changed when they’re reopened in PageMill.

Note: Reducing an image’s dimensions in PageMill doesn’t make the image download faster 
because PageMill doesn’t resample (reduce the number of pixels). To make images download faster, 
resample them in an image-editing application such as Photoshop and then reimport them into 
PageMill.

To resize an image visually:

Select the image and drag one of its resize handles. (Shift-dragging constrains the resizing to 
the original proportions.)

Original image and the resized image
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To resize an image numerically:

1 In Edit mode, click the image, display the Inspector (choose View > Show Inspector), and 
click the Object tab.

2 Choose a unit of measurement from the Width or Height pop-up menu:

• To measure in screen pixels, choose Pixels.

• To measure in proportion to the window size, choose Percent, where 100% width or height 
equals the window’s width or height. (The image will automatically resize as the size of the 
browser window changes.) Proportional resizing is useful, for example, for displaying a banner 
image at the full width of a browser window.

3 Do one of the following:

• To change the vertical dimension, deselect the Scale to Width option, and then type a value 
in the Height text box.

• To change the horizontal dimension, deselect the Scale to Height option, and then type a 
value in the Width option.

• To reset the image to its original proportions, select both Scale to Height and Scale to Width.
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Adding borders to images

Images in PageMill have a border of zero (no visible border) by default. You can change the 
image border as needed. 

Note: A border is always rectangular, regardless of the image’s shape.

To add or remove an image border:

1 In Edit mode, click the image and display the Inspector (choose View > Show Inspector).

2 Do one of the following:

• To specify a border width, type a value, in pixels, into the Border text box.

• To specify no border, type 0 (zero) into the Border text box.

• To let the browser determine if a border will appear around the image, leave the Border text 
box empty. Most Web browsers then use a 2-pixel border around a linked image and no border 
around an unlinked image. 

Border value 5 applied

Creating interlaced GIF or progressive JPEG images

An interlaced GIF image or a progressive JPEG (ProJPEG) image downloads in stages, gradually 
revealing the full image. Web browsers that do not support interlacing can still display inter-
laced GIFs or progressive JPEGs, but without the interlacing effect.

Interlacing affects all instances of the image that appear in the Web page. You can preview the 
interlaced effect only when you use Internet Explorer Preview mode.

To create an interlaced or progressive image:

1 In Edit mode, click the GIF or JPEG image and then choose Edit > Image > Open Image 
Window. (You can also Control-double-click the image or double-click the image and then 
click the Open Image Window button on the toolbar.) The image appears in an Image window.
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2 In the Image window, click the Interlace button ( ), close the Image window, and save the 
file. 

Making parts of a GIF image transparent

You can make parts of a GIF image (but not a JPEG image) transparent by making one of its 
colors transparent. The transparent areas appear in the page’s background color (or pattern). 
If you use this file more than once in your site, all instances of it use the same transparency 
settings.

If the original image doesn’t have a solid-color area that would look good transparent, you can 
modify the image in an application such as Photoshop.

 Even though PageMill can make only one color transparent, you can use an appli-
cation such as Photoshop to make multiple colors transparent. But if you do use 
Photoshop, don’t anti-alias the edges of the image to avoid creating creating a halo around 
the image.

GIF files do not lose color information when you apply transparency, so you can undo the setting 
at any time. For example, if you applied transparency to red areas of an image and then later apply 
transparency to green areas, the original red color information reappears.

Image before and after applying transparency

To prepare a GIF image for transparency (optional):

1 In an image-editing application such as Photoshop, select the part of the GIF image that will 
remain (not be transparent). Fill all other areas with one color (but not a color used in the parts 
of the image that you want visible). 

2 Save the file in GIF format.



CHAPTER 460
Adding Images and Multimedia Objects

 You can easily switch between PageMill and an image-editing program such as 
Photoshop by using the Switch To command (see page 15).

To make parts of a GIF image transparent:

1 In Edit mode in PageMill, select the image (see page 54) and then choose Edit > Image > 
Open Image Window. (You can also Control-double-click the image or double-click the image 
and then click the Open Image Window button on the toolbar.) The image appears in an Image 
window.

2 In the Image window, select the Make Transparent button ( ), and click the color you want 
to make transparent.

3 Close the Image window and save the file.

To change a transparent area back to its original color:

1 In Edit mode in PageMill, select the image (see page 54) and then choose Edit > Image > 
Open Image Window. (You can also Control-double-click the image or double-click the image 
and then click the Open Image Window button on the toolbar.) The image appears in an Image 
window.

2 In the Image window, select the Make Transparent button ( ) and do one of the following:

• To make a new color transparent, click a new color. The formerly transparent parts of the 
image return to their original color.

• To remove all transparent colors, click the transparent part of the image. The original color 
returns.
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Setting up text labels for images
Some readers use browsers that cannot display graphics; others choose not to display graphics 
in order to speed up their access to the Web. To keep your Web pages meaningful to these 
readers, you should include a text label that the Web browser can use in place of the image. 

Image label in browser

To add a text label to an image:

1 In Edit mode, click the image and display the Inspector (choose View > Show Inspector).

2 Click the Object tab.

3 Enter text in the Alternate Label text box.

Playing multimedia objects
Multimedia objects add motion, sound, and special effects to your Web pages. You should test 
their effects before you upload your Web pages.

To play a multimedia object:

1 Confirm that you have all necessary plug-ins installed in the Browser Plug-ins folder (see 
page 48).

2 Do one of the following:

• To play an animated GIF, change to Preview mode. In PageMill Preview mode (not Internet 
Explorer Preview mode), you can pause the animation by clicking it and resume the animation 
by double-clicking it.

• To play a movie or sound that doesn’t automatically play, click its link or the play button on 
its playback bar. 

PageMill does not load a movie or a sound into memory before starting playback. For this 
reason, playback over a network might be slow or unpredictable.

• To play a Java applet, insert it into a page; an applet begins to play immediately. You can pause 
it by clicking Suspend in the Inspector when the applet is selected.
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To control how a movie plays in your Web page:

1 Create or locate a QuickTime or Microsoft Video movie that you want to use. 

 QuickTime movies used in Web pages must be flattened (that is, made cross-platform 
compatible). To quickly create such a movie in Adobe Premiere, use File > Export > 
Flattened Movie.

2 Insert the file on your Web page using Insert > Object > Other File. Be sure to click Place to 
insert the file, not Link To.

3 Select the movie and display the Object panel of the Inspector (choose View > Inspector).

4 Adjust the Width and Height values and then set any of the following properties:

5 Preview the movie in a browser or in Internet Explorer Preview mode to confirm that the 
sound plays correctly. (If it doesn’t, confirm that the browser has the appropriate plug-in to 
handle the file format.)

To play music in the background in your Web page:

1 Do one of the following:

• Create or locate a sound or music file, such as a .mid or .wav file (.wav files tend to have the 
smallest file size).

• Create or locate a QuickTime movie that has a sound track you want to use. To reduce the 
file size, the movie should not have an image—all you need is its sound portion.

2 Insert the file on your Web page using Insert > Object. Be sure to click Place to insert the file, 
not Link To.

3 Select the object and display the Object panel of the Inspector (choose View > Inspector).

Name Value Meaning

autoplay true or false Whether the movie automatically plays when the Web page is first opened.

loop true or false Whether the movie plays continuously or only once.

controller true or false Whether the playback bar appears or not.
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4 Set the following properties:

5 Select the object and choose View > Download Statistics to see if the download time for this 
object is acceptable (sound files can be large and won’t start playing until they are fully 
downloaded). For how to interpret the download statistics, see page 162.

6 Preview in a browser or in Internet Explorer Preview mode to confirm that the music plays 
correctly. (If it doesn’t, confirm that the browser has the appropriate plug-in to handle the file 
format.)

Working with Java applets
Java applets sometimes need to be customized before they look or act the way you want them 
to. For example, an animated bullet applet can easily be modified into an animated horizontal 
rule by changing its width, height, and style properties.

By default, an applet runs in both Preview and Edit modes. However, you can control when a 
Java applet runs as well as when it reloads.

To modify a Java applet:

1 In Edit mode, select the applet and display the Inspector (choose View > Inspector).

2 Do the following:

• To change the width or height of the applet, enter new values for the Width or Height 
properties. (You can also resize the applet on the page by dragging one of its selection handles.) 
After resizing an applet, you may have to click Reload to restart it.

• To change or add other properties, which for applets are called parameter, PARAM, 
properties, edit the Name and Value text boxes. Each set of Name and Value entries creates a 
parameter change for the applet. As you enter a value, a new row is added for the next property.

• To restart an applet after you’ve made some changes, click Reload.

• To pause an applet, click Suspend.

Name Value

autoplay true

loop true

hidden true
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 Some applications (for example, Macromedia AppletAce) place applet parameters in 
a text file and not in the .class file. You can incorporate the parameters by copying them 
from the text file. Then place the .class file in PageMill, switch to Source mode, and paste 
the code before the </APPLET> tag. The new parameters appear in the Inspector. This 
technique lets you change many parameters at the same time. 

To control how an applet runs and loads:

1 Choose Edit > Preferences and click the Active Content tab.

2 Do the following:

• To allow applets to run in PageMill, select Enable Java Applets.

• To make applets run only in Preview mode and not in Edit mode, deselect Run Applets in 
Edit Mode.

• To automate reloading applets from their source, select “Reload Applets When Switching to 
Preview Mode.”

• To specify that applets should look elsewhere for additional code to run, select Use 
CLASSPATH Environment Variable. (Leave this option off unless the documentation for the 
applet states it should be on. Selecting this option may cause applets to stop working when 
uploaded to a Web server.)

3 Click OK.

To view advanced information on a Java applet:

Choose View > Show Java Console. This dialog box provides diagnostic information on the 
state of an applet, which you could use in troubleshooting problems with an applet.

Working with ActiveX controls
ActiveX is a technology from Microsoft that lets applications embed small programs, called 
controls, into Web pages and other types of documents.
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ActiveX controls can perform a wide range of functions—including many that can enhance a 
Web page. For example, the Calendar Control adds a working calendar to a page, and the PDF 
Control inserts a fully functioning Acrobat window into your Web page.

Unlike other objects, you don’t insert an ActiveX control by inserting its file (its .ocx file) into 
a Web page. Instead, you insert a control in one of two ways:

• You can insert an object file such as a sound or PDF file and have PageMill use an appropriate 
ActiveX control to display it. When you insert a control by choosing a file, PageMill looks at the 
type of file and determines if there is a control installed that’s appropriate for that type of file. 
If so, it inserts the content of the file as part of the control. For example, when you insert a WAV 
sound file or a PDF file, PageMill inserts the sound or the Acrobat file in your Web page using 
the appropriate ActiveX control.
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• You can choose an ActiveX control from a list of installed controls. The list that PageMill 
displays comes from the Windows registry. Some controls on this list may not be fully present 
or installed properly on your machine. If you insert a control that’s not fully accessible to 
PageMill, only an alert icon appears on the Web page. If possible, insert a control from a file 
(use Insert > Object > ActiveX Control > Select File), which usually results in more usable 
controls.

To insert a file using an ActiveX control:

1 In Edit mode, choose Insert > Object > ActiveX > Select File.

2 Select the file that contains the ActiveX control data and click Insert. The control appears 
either as an icon or as the full control, depending on how the preferences are set (see page 67).

To insert a file using an ActiveX control by dragging and dropping:

In Edit mode, hold down Shift and Control and drag from a Windows folder into a Web page.

To insert an ActiveX control from a list of installed controls:

1 In Edit mode, choose Insert > Object > ActiveX > Select Control.

2 Select an ActiveX control from the list box and click Insert. The control appears either as an 
icon or as the full control, depending on how the preferences are set (see page 67).

To edit an ActiveX control:

In Edit mode, select the control, choose View > Inspector to display the Inspector, and do the 
following:

• To give the control a name so you can refer to it elsewhere (for example, in scripts), fill in the 
Name text box.

• To tell Web browsers where to find the control for downloading when the page is loaded, 
enter the control’s URL or network location in the Codebase text box. You can also click Browse 
to find the location.

• To tell Web browsers where to find the file containing any run-time parameters the control 
may need, enter its URL or network location in the Data Source text box. You can also click 
Browse to find the location.
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• To modify the control’s properties, enter values, in pixels, for Width, Height, or Border, or 
click Properties to access any other properties unique to the control. (A Properties page is 
available only if the programmer of the control created one.)

To specify when an ActiveX control can be run:

1 Choose Edit > Preferences and click the Active Content tab.

2 Do the following:

• To let ActiveX controls run in PageMill, select Enable ActiveX Controls.

• To let ActiveX controls run only in Preview mode, deselect Create ActiveX Controls in Edit 
Mode. 

You can still insert an ActiveX control even when these options are deselected. In that case, the 
control is inserted as a placeholder icon and its functions and properties are unavailable.

Locating missing objects 
An icon with an exclamation mark appearing in Preview mode means that an object cannot be 
found on the disk. An object may be missing if you deleted, moved, or renamed it on your 
computer (see page 92 for tips on keeping links valid). The missing-object icon also displays 
the path and the name of the object it’s looking for. 

Missing-object icon

To find a missing object:

1 In Edit mode, double-click the missing-object icon.

2 Locate the object and then click OK.
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Finding and replacing
PageMill lets you search for and replace anything that you can select—including text, images, 
multimedia objects, ActiveX controls, and objects such as form controls, buttons, and links. 
You can search and replace on a single page or across a whole site.

To search for text or an object:

1 In Edit mode, do one of the following:

• To search multiple Web pages, load a site (see page 151), right-click a file or folder, and 
choose Find.

• To search a single Web page, click in the page and choose Search > Find. 

2 In the Find dialog box, drag or paste the selection (for example, an image) into the Find text 
box, or type the text you want to find.

3 From the Find pop-up menu, do one of the following:

• To search for page objects or text, choose Page Content.

• To search for URLs used in the links, choose Link Address.

4 From the Search Path Scope pop-up menu, do one of the following:

• Choose Page to search the entire Web page. 

• Choose Site Selection to search the pages of the site that are currently selected.

• Choose Entire Site to search all the pages of the current site.

5 Leave the Wrap option selected to continue the search at the beginning when you reach the 
end.

6 In the Constraints area, do the following:

• Click Text Case to match the case (upper- or lowercase) of the selection.

• Click Text Style to match the typeface style of the selection.

• Click Whole Word to match the selection to occurrences as whole words.

• Click Object Size to match the size of the original selection.
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To replace text or an object:

1 Follow the steps in the procedure on searching (page 68).

2 Drag, type, or paste the replacement item into the Replace With text box. (The replacement 
item can be anything you can select: text, an image, and so on.)

3 Click Find Next. PageMill highlights found text or objects on the page, or displays the URL 
of found links in the Link To bar.

4 To continue the search, do one of the following:

• Click Find Next to find the next occurrence.

• Click Replace to replace the found occurrence with the item in the Replace With text box.

• Click Replace & Find Next to replace the found occurrence with the item in the Replace With 
text box, and then find the next occurrence.

• Click Replace All to change all occurrences of the found selection with the item in the Replace 
With text box.

To search and replace in HTML source code for a site:

1 Follow the steps in the procedure on searching in a site (page 68).

2 Choose Site from the Scope pop-up menu.

3 Select the Source option to search or replace in the HTML source code for the pages.
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Creating page backgrounds
You can use an image as the background pattern for a page. When a Web browser that supports 
backgrounds displays the page, the browser tiles, or repeats, the pattern behind the text and 
graphics on the page. 

Although you can use any image that PageMill can import (see page 46), here are some consid-
erations for creating an effective background:

• Don’t use an animated GIF file as a background image (because only the first or last frame of 
the image appears).

• Avoid intensely colored or visually busy backgrounds so that text will be legible.

• Use a small image so that it downloads quickly.

To add a page background using the Inspector:

1 In Edit mode, display the Inspector (choose View > Show Inspector) and click the Page tab. 

2 Do one of the following:

• In the Page panel, click the File button below the Background Image area, and locate and 
open a file. 
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• Drag a file from a desktop folder window into the Background Image area.

• Drag an image from a PageMill page or from another application into the Background Image 
area.

To add a page background using the page icon:

In Edit mode, drag the file from a desktop folder window or drag the image from an open 
document and drop it onto the page icon on the PageMill page.
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To remove a background image:

1 In Edit mode, display the Inspector (choose View > Show Inspector) and click the Page tab. 

2 Click the Clear button below the Background Image area.

To set the default background for all new pages:

1 Choose Edit > Preferences and click the Page tab.

2 Do one of the following:

• To remove a pattern, click Clear below the Background Image area.

• To add a pattern, click File below the Background Image area, and then locate an image file 
to use as a pattern.

3 Click OK. The default settings go into effect the next time you create a new page.

Adding horizontal rules
Horizontal rules are useful for dividing your Web page into sections. Rules are shaded by 
default, but you can make them unshaded. You can also change the thickness and width of a 
horizontal rule visually or numerically. 

To add a horizontal rule:

In Edit mode, click where you want to insert the rule and then choose Insert > Horizontal Rule 
or click the Insert Horizontal Rule button ( ) on the toolbar. 

To make a horizontal rule unshaded:

1 In Edit mode, select the rule and display the Inspector (choose View > Show Inspector).

2 Select No Shade. 
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To change the dimensions of a rule visually:

In Edit mode, select the rule and drag one of its resize handles. (Shift-dragging constrains the 
resizing to the original proportions.)

To change the dimensions of a rule numerically:

1 In Edit mode, select the rule and display the Inspector (choose View > Show Inspector).

2 Do the following:

• To resize a rule in screen pixels, choose Pixels from the Width pop-up menu and then enter 
a value.

• To resize a rule in proportion to the window size, choose Percent from the Width pop-up 
menu and then enter a percentage. A value of 100% equals the window’s width. (The rule will 
automatically resize as the size of the browser window changes.)

• To change the thickness, enter a value in pixels in the Size text box to specify the rule’s 
thickness.

A. Default horizontal rule B. A customized horizontal rule

A
B
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Chapter 5: Working with Links

link takes you from the current page to another location—somewhere else on the same 
page, on another page within your Web site, or on another page on any other server 
on the Internet. A link can be any text, image, or part of an image (called an image 

map) on your page.

How links appear on a Web page
In PageMill, as in most browsers, text links appear in blue, and image links—when an image 
has a border—appear with a blue border by default. When you’re in Preview mode or in a 
browser and pass the pointer over a link, the pointer changes to a hand. In a Web browser, after 
you use a link, it usually changes color to let you know you’ve clicked it.

Linked text and linked graphic

You can set the colors for normal, active, and visited links on your page (see page 38).

About URLs
Every link uses a Uniform Resource Locator (URL) to find its destination. A URL is similar to 
the directory paths used in operating systems such as DOS or UNIX, and includes the appro-
priate protocol required by the link. (For information about the structure of a URL, see page 2.) 

URLs are either absolute or relative:

• An absolute URL gives the complete pathname from the root of the server to the name of the 
page to be linked. You might need to use an absolute URL to link to a clip art file that resides in 
your company’s Web site. If possible, avoid using absolute URLs—they will no longer be 
correct (links will break) if you move the referenced files to another folder or server. The 
following URL is absolute:

A
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http://www.company.com/department/sales.html

The problems associated with absolute URLs can be prevented by using local aliases (see 
page 84) or relative URLs.

• A relative URL describes the location of the linked page relative to the current page. In the 
following example, the two periods tell the browser that the file is located in the folder above 
the folder containing the current page. Relative URLs are portable; that is, if you move a file 
referenced by a relative URL to another folder or server, the link continues to work as long as 
the file exists one folder up in the hierarchy. When you upload a site from your computer to a 
Web server, relative URLs are more likely to preserve the links on both machines.

../sales.html

You can link to other URL types supported by World Wide Web browsers such as ftp, gopher, 
and mailto (see page 78). PageMill supports the following URL protocols:

Linking to Web pages
When readers click a link to a Web page, they jump to the destination specified by the URL (see 
page 75). You don’t need to type a URL—when you link pages in PageMill, you can paste or 
drag file icons or links. You can also store often-used links on the Pasteboard and then drag 
them onto your pages.

Protocol Use

file:// Opens a file on a mounted volume

http:// Opens a World Wide Web page

ftp:// Connects to a server using the File Transfer Protocol

gopher:// Connects to a Gopher server

telnet:// Connects to a server using Telnet

news: Connects to a Usenet newsgroup

mailto: Sends an electronic mail message

snews: Opens a secure newsgroup connection

shttp:// Opens a secure World Wide Web connection 
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A link to a page leads to the top of a page. (To link to a location elsewhere on a page, create an 
anchor first and then link to the anchor; see page 82).

When you link to a local Web page (that is, a page accessible on your hard disk, on removable 
media, or through a network connection), the page becomes an “external” if it is not within the 
local root folder of the site (see page 161). 

When you link to a remote Web page (that is, a page on the Internet or on an intranet), the page 
is added to the WWW Links folder in the Site Overview area (see page 151).

To create a link to a local Web page:

1 Select the text, image, or object that you want to become the link. If you don’t make a 
selection, the linked page’s title, filename, or URL is inserted and linked.

2 Do one of the following:

• Open the page you want to link to and drag its page icon onto the selection. (The destination 
document must be saved before its page icon is available.)

Select text in the first window, then drag the page icon from the second window to create a link.

• Drag a file icon from a desktop folder window onto the selection. 

• Drag a file from either the Site Overview area or the Site Details window onto the selection.

• Choose Edit > Make Link, locate a file in the dialog box, and click Link To.

• Click the Browse button next to the Link To bar at the bottom of the PageMill window, locate 
the file, and click Link To.

• Choose Insert > Object. Select the file that you want to link to, and click Link To. 
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• Hold down Alt and drag an image file icon from a Windows Explorer window, the desktop, 
a folder, or the PageMill Image window onto a page. This creates a link to the image without 
placing it on the page. (The name of the image file appears instead of the image itself.)

To create a link to a remote Web page:

1 Select the text, image, or object that you want to become the link. If you don’t make a 
selection, the linked page’s title, filename, or URL becomes the linked text.

2 Do one of the following:

• Drag linked text from a browser page, from a bookmark from the Navigator Bookmarks 
Window, or from the Internet Explorer Favorites panel onto the selection. 

• Drag links from a browser page into the Link To bar. 

• Choose Insert > Object. Select Remote URL and enter the URL of the file you want to link to.

• Click the Link To bar at the bottom of the PageMill window, type the URL of the destination 
page.

 In the Link To bar, typing the first letter of the URL protocol or type of domain and 
then pressing the Tab key enters the rest of the URL protocol for you. (For example, to 
enter http:, type h and press Tab.)

To create a link by using the Pasteboard:

In Edit mode, drag a link from the Pasteboard onto a page (for information on the Pasteboard, 
see page 86).

Linking to e-mail addresses
You can link to e-mail addresses by using the mailto Web protocol. When readers click the 
linked text or image, the Web browser opens an e-mail window where they can compose and 
send a message.

To create a link to an e-mail address:

1 In Edit mode, select the text or image you want to link to the e-mail address.

2 Enter the e-mail address in the Link To bar preceded by the mailto protocol. For example, 
mailto:myaccount@myISP.com
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3 To specify default text that will appear in the subject line of the e-mail message, add a subject 
parameter. The following example adds the word Feedback to the subject line: 
mailto:myaccount@myISP.com?subject=Feedback

Linking to PDF files
To use PDF files in PageMill, you must have the Acrobat plug-in installed in your Browser Plug-
ins folder (see page 48) or the PDF ActiveX control installed. You also need either Acrobat 
Reader or Acrobat Exchange.

PDF files in Web pages can be embedded, linked, or included in an embedded version of 
Acrobat:

• Embedded PDF files appear as thumbnails, small graphic images of their first pages (if the 
Acrobat 3.0 plug-in is installed). Clicking them in Preview mode performs no action.

• Linked PDF files are similar to other links—the file can be linked to text or to any graphic of 
your choosing. In addition, you can also link a PDF file to its embedded thumbnail. Clicking 
them in Preview mode or in a browser lets a reader view and move through the entire PDF file. 
(The file might open in Acrobat in a separate window or within the browser window, 
depending on what plug-ins you have installed.)
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• PDF files included in an embedded version of Acrobat use the PDF ActiveX control, which is 
automatically installed when Acrobat Reader or Exchange is installed. When you add a PDF file 
using the ActiveX control, the Acrobat toolbar, scrollbars, and status line are also included. 
Readers can use them within the Web page just as in Acrobat. (For details on ActiveX controls, 
see page 64.)

Readers must have Acrobat Reader or Acrobat Exchange installed on their computers to view 
the PDF files in your Web pages. For this reason, you may want to include a link to the URL 
where they can download the free Adobe Acrobat Reader. Versions of Acrobat Reader are 
available for Windows, DOS, Macintosh, and some UNIX systems. See http://www.adobe.com 
for more information.



81

To embed a thumbnail image of a PDF file:

In Edit mode, do one of the following:

• Drag the PDF file icon from its desktop folder into the page. The thumbnail image of the first 
page of the document appears. (If the PDF plug-in is not installed on your computer, a link to 
the file is created instead of embedding the file; see page 48.)

• Choose Insert > Object > Acrobat File, locate the file, and click Place.

 You can control which page of the PDF file displays as the thumbnail by opening the 
file in Acrobat Exchange and using the File > Document Info > Open command.

To link to an entire PDF file:

In Edit mode, do one of the following:

• Hold down Alt as you drag the PDF file icon from its desktop folder into an object on the 
page (text or a graphic). The linked URL appears on the page.

• Choose Insert > Object > Acrobat File, locate the file, and click Link To.

To link the PDF’s thumbnail to the whole PDF file (Navigator only):

1 In Edit mode, select the PDF thumbnail, open the Inspector (choose View > Show 
Inspector), and click the Object tab.

2 In the left column, type HREF. In the right column, type the relative pathname of the PDF 
file, as shown in the following example (if the PDF file is in the same folder as the Web page, 
enter just the PDF filename): 

Note: In Internet Explorer, the PDF ActiveX control is automatically used to display the whole PDF 
file.

 A foolproof way to enter the relative pathname is to create a text link to the PDF file, 
save the page, select the link, and then copy the pathname from the Link To bar.

Name Value

HREF externals\brochure.pdf
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To include a PDF file in an embedded version of Acrobat using the PDF ActiveX control:

In Edit mode, do one of the following:

• Choose Insert > Object > ActiveX > Select File, locate the PDF file you want to insert, and 
click Insert.

• Hold down Shift and Control and drag from a Windows folder into a Web page.

Using anchors
By default, links to Web pages always link to the top of the destination page. To create a link to 
a place other than the top of the page, you need to create a destination anchor in the page. 
Anchors help readers navigate through long pages. For example, a table of contents or a 
navigation bar at the top of the page can list topics that link to anchors attached to headings 
throughout the page.

PageMill names anchors as Anchorxx using randomly generated numbers. You can change the 
default name of an anchor, but be sure to do so from within PageMill (see page 158).

Note: Anchors are always hidden in Preview mode and always visible in Edit mode (unless you 
choose View > Hide Invisibles, which hides anchors in both modes).

To create an anchor:

In Edit mode, do one of the following:

• Click to the left of the text or object where you want to place the anchor, and choose Insert > 
Anchor.

• If the file has already been saved and is not part of a frameset, drag its page icon anywhere 
into the same document window.

To rename an anchor:

1 Select the anchor, display the Inspector (choose View > Show Inspector), and click the 
Object tab.

2 Type a new name for the anchor, using only alphanumeric characters and no spaces.

To link to an anchor:

1 Select the text or object that will link to the anchor. 
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2 Scroll to the anchor, or open the page containing the anchor so that both it and the selection 
are visible. (The file containing the anchor must have been saved.)

3 Drag the anchor icon ( ) onto the selected text or object. 

To link to an anchor without first making a selection:

Hold down Alt, and drag the anchor icon ( ) to another location. Initially, the anchor name 
appears as the link, but you can change the link text without losing the link to the anchor.

To link to an anchor when the link text and anchor are not both visible at the same time:

1 Insert the anchor temporarily next to the text or object it will link to.

2 Select the text or object that will be the link and then drag the anchor onto the text or object.

3 Select the anchor and choose Edit > Cut.

4 Move to the anchor’s final location and click to place the insertion point.

5 Choose Edit > Paste.
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To hide anchor icons:

Choose View > Hide Invisibles.

Using local aliases
In some cases, you may find it convenient to map a local folder—a local alias—to a remote one. 
PageMill looks to the local folder when it’s verifying and accessing links. However, after you 
upload the site, the Web server looks to the remote location instead of the local folder. The local 
folder must have the same contents as the remote location.

You may want to do this, for example, to refer to an art folder that resides in your company’s 
Web site. Also, because the local path can be an absolute path and the remote link is always an 
absolute path, you may need this feature to create absolute paths in URLs (such as when 
creating server-side image maps as described on page 99). 

The local root folder of the site on your computer maps to the remote root directory.

To set up a local alias:

1 Choose Edit > Preferences and click the Server tab.

2 In the URL text box, enter the remote directory, which is where the Web server will look to 
complete links that you map locally. Enter the absolute URL to the top level of remote site, 
ending with a slash, for example, http://www.earthandware.com/

Local machine

marketing

images

departments

www.company_name.com

marketing

images
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3 Click Browse next to the Local text box to locate the local folder that mirrors the remote 
site—the local root folder on your hard disk—and then click OK. This folder can neither 
contain nor be within another aliased folder.

The above example tells PageMill to use the relative local path when verifying the remote links 
to http://www.earthandware.com/ but to use the absolute path when the site is uploaded to a 
Web server. 

4 If necessary, enter additional local aliases for other remote links used in your site. When you 
enter the first alias, space for the second entry appears automatically.

5 Click OK.

To view all the local aliases used in a site:

1 Choose Site > Load and either select a site from the list or choose Browse to locate the local 
root folder of a site.

2 Right-click the Externals folder and choose Expand > All. 

3 Right-click an externals file and choose Show Details to open the Site Details window. The 
local alias, if any, for each remote link is shown.
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Keeping frequently used links handy
PageMill has several ways to keep frequently used links available so that you can quickly copy 
or drag them onto the pages you create:

• Create a Web page containing frequently used links so that you can copy links from the file. 

• If you use Netscape Navigator, open the Bookmark.htm file and drag the links from the file 
onto the PageMill page.

• If you use Internet Explorer, display the Favorites panel and drag a link onto the PageMill 
page.

• Store frequently used links on the Pasteboard. For example, if you keep a navigation bar on 
the Pasteboard, you can easily insert it in your Web pages as needed, instead of re-creating each 
link in the navigation bar. 

To display or hide the Pasteboard:

Choose View > Show Pasteboard or View > Hide Pasteboard.

To move a link or object to the Pasteboard:

1 Click the numbered tab of the Pasteboard to display the panel you want to paste to.
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2 In Edit mode, drag the link or object to the Pasteboard.

To move a link or object from the Pasteboard:

1 Click the numbered tab of the Pasteboard to display the desired panel.

2 In Edit mode, do one of the following:

• To move a link or object to a page and remove it from the Pasteboard, drag it from the Paste-
board to the page.

• To copy a link or object to a page and keep it on the Pasteboard, hold down Control as you 
drag.

To empty all objects on the Pasteboard:

1 Delete the Adobe PageMill Pasteboard file from the Program Data folder.

2 Restart PageMill.

Note: Be sure to remove objects from the Pasteboard after you no longer need them. Because 
PageMill loads the Pasteboard data into memory, storing large objects there can affect how fast 
PageMill opens. 

Testing and verifying links
PageMill lets you test local links in either of its two Preview modes (PageMill mode and 
Internet Explorer mode) and to test remote links either in a separate window or in the PageMill 
window itself.

You can also verify remote links without going to the remote site. Verifying is usually faster than 
testing. You must be connected to the Internet to test or verify remote links. (If you’re working 
in a corporation that has an Internet security system, called a firewall, and have trouble 
verifying remote links, ask your webmaster or system administrator to set up the correct proxy 
servers to use.)

If a link doesn’t go where you want, you can change it. You can edit a link (see page 90) and 
change pages without breaking links (see page 92).

To test a local link:

In Preview mode, click the local link.
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To test a remote link in the PageMill window using Internet Explorer:

1 Right-click the Mode button in the upper right and choose Internet Explorer from the pop-
up menu.

2 Click the remote link.

To test a remote link in a separate window using Navigator or another browser:

1 Choose Edit > Preferences and click the General tab.

2 In the Open Remote Links Using text box, enter the name and path to the browser or click 
Browse to locate the application.

3 Click Open and then click OK.

4 In Preview mode, click the link.

To verify remote links without opening the remote sites:

1 Choose Site > Load and either select a site from the list or choose Browse to locate the root 
folder of a site.

2 Right-click the WWW Links folder and choose Show Details to open the List view of the Site 
Details window. The remote links display a question mark (?) if they have never been verified 
and their icons contain a question mark. In the Link view, an unverified link has a gray arrow, 
and a verified link has a blue arrow.

3 Do one of the following:

• To verify all remote links in the site, right-click the WWW Links folder and choose Verify All 
External URLs.

• To verify a particular remote link, right-click a link in the WWW Links folder and choose 
Verify This URL.

PageMill accesses the remote sites on the Internet and updates their status to either OK or Not 
Found. The question mark is also removed from the icon of a verified URL. However, PageMill 
cannot verify mailto links.

To cancel verification of remote links:

Choose Site > Cancel Remote URL Verification.
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Viewing links
You can view not only the URL for an individual link, but also all the incoming links (links in 
your site leading to that page) and outgoing links (those within the page leading to other pages 
in the site) for a page of your site (see also page 154).

To view the URL for a single link: 

1 Do one of the following:

• In Preview mode, move the pointer over the link.

• In Edit mode, click the link if it is a linked image or hotspot in an image map.

• In Edit mode, click in the link if the link is text and choose Edit > Edit Link.

2 View the URL in the Link To bar.

To view the incoming or outgoing links for a page:

1 Choose Site > Load and open a previously loaded site or browse for a site folder.

2 Right-click the local root folder in the Site Overview area and choose Show Details. The List 
view shows the files in that folder and the number of links leading into and out of each file. A 
red x indicates no incoming links.
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3 To see the names of the linked files, right-click the file and choose Show Details. The Site 
Details window now shows the Link view, a pictorial view of the links with all the link names. 
Click the plus signs or minus signs to collapse or expand the shown links.

A. List view B. Link view

Editing links
When you move text or an image that functions as a link, the link goes with the text or image. 
You can also remove the link or change the link address.

When you remove a link from text, it returns to its normal color. When you remove a link from 
an image, the image loses the border—if present—that indicates a link.

In a Web site with many interlinked pages, you’ll find it most convenient to edit links in the Site 
windows.

To select and edit a link:

1 Do one of the following:

• To select a linked image or hotspot in an image map, click the image or hotspot.

A

B
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• To select a text link, click anywhere in the link and choose Edit > Edit Link.

The link destination appears in the Link To bar at the bottom of the window.

2 Click in the Link To bar and edit the link as needed.

To move or copy linked text or a linked image:

Select the linked text or a linked image and then do one of the following:

• To move the link, drag it to a new location; or choose Edit > Cut, click where you want to 
move it, and then choose Edit > Paste.

• To copy the link, choose Edit > Copy, click where you want to add a link, and then choose 
Edit > Paste.

To remove a link on a page:

In Edit mode, select the linked text or image and then do one of the following:

• To remove the link along with the text or image, press Delete.

• To remove the link but leave the text or image, choose Edit > Remove Link.

To remove all incoming links for a Web page:

1 Choose Site > Load and either select a site from the list or choose Browse to locate the root 
folder of a site.

2 Right-click a Web page and choose Unlink. An alert message tells you how many files must 
be modified to unlink this page.

3 Click OK. All links in other pages that point to this page are removed.

To replace one link with another:

1 In Edit mode, choose Search > Find and then drag, type, or paste the link address into the 
Find text box.

2 Choose Link Address from the Find pop-up menu.

3 Choose Site from the Scope pop-up menu to change the link in all the files of the current site.

4 Set the other search options (see page 68) and then replace the links.
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Keeping links valid
Links can become invalid for several reasons:

• You may have changed the name or location of a linked page outside of PageMill.

• The remote site a link refers to may have been moved or removed from the Internet.

PageMill’s site-maintenance features help you locate and fix these invalid links. They also help 
you prevent broken links by automatically updating links as you move pages or change their 
names and by verifying remote links for you. You can also use PageMill to find pages that have 
no references to them (such unreferenced pages would be inaccessible to readers unless you 
gave them the exact URL for that page).

See page 160 for more information on fixing errors and avoiding problems in Web sites.

To locate and fix invalid links:

1 Choose Site > Load and either select a site from the list or choose Browse to locate the root 
folder of a site.

2 Double-click the Errors folder to open it. (If there are no errors, double-clicking does 
nothing.)

3 Right-click a file in the Errors folder and do one of the following:

• To fix the link by removing it, choose Unlink.

• To fix and keep the link, choose Correct Error, locate the correct file, and click Open. Then 
click OK to modify the file.

 To see the errors in context, you can locate and fix them in the Site Details window 
instead of the Site Overview area. Right-click the local root folder, choose Show Details, 
and then browse the site looking for errors. (Invalid links are shown in the Link view with 
red arrows.)

To rename or move a page without breaking links to it:

Always move or rename a page using the Site Overview area or the Site Details window so that 
PageMill can adjust the links as needed. For details, see page 158.
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To find an unreferenced page:

1 Choose Site > Load and either select a site from the list or choose Browse to locate the root 
folder of a site.

2 Right-click the local root folder and choose Show Details. 

3 Look at the In column for a red x, which indicates that there are no incoming links to that 
page. A page with a red x is unreferenced and therefore inaccessible.

To open a file that refers to a broken link:

1 Right-click the Errors folder in the Site Overview area and choose Show Details. The In 
column in the Site Details window shows you how many files refer to the file that can’t be 
found.

2 Click an underlined number in the In column and choose a filename. The file opens and you 
can remove or fix the link on the page (see page 90).

To correct a link broken due to a file being renamed outside of PageMill:

1 Display the correct filename in the Site Overview area by opening the folders of the site. For 
example, if the Sales.html file was renamed to Sales98.html, open folders so that Sales98.html 
is visible.

2 Right-click the Errors folder in the Site Overview area and choose Show Details. 

3 Click the file with the out-of-date name. For example, click the Sales.html file in the Errors 
folder.
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4 Drag the correct file from the Site Overview area onto the incorrect file either in the Errors 
folder or in the Link view.

5 Click OK to confirm changing the files so that they now link to the renamed file. (You can 
also relink the file by double-clicking the old filename in the Site Overview area or in the Link 
view and locating the new filename in the Correct Error dialog box.)

To correct broken links by locating the correct file:

1 Right-click the Errors folder in the Site Overview area and choose Show Details.

2 Double-click a filename in the Errors view in the Site Details window. (You can also double-
click the filename in the Site Overview area or in the Link view, or right-click the filename and 
choose Correct Error.)

3 In the Correct Error dialog box, locate the file that will correct the broken link and then click 
Open.

Note: Locating files does not correct broken links to anchors or remote URLs. You must correct these 
links in the Errors view (see page 92).
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Chapter 6: Creating Image Maps

mage maps are used with a single image to indicate multiple links. (To link a whole image 
to a single destination, you should not use an image map; instead, simply link the image as 
described on page 76.) Clicking hotspots—clickable, linked areas of the image—moves the 

reader to the locations specified in the hotspot links. 

About image maps
PageMill lets you create two types of image maps: client-side and server-side. The image maps 
differ in the location of the image map files and the speed with which the linked page appears. 

Client-side image maps These image maps store the hotspot coordinates and links directly 
within the HTML page, not in a separate map-definition file as do server-side maps. Thus, they 
display linked pages faster, and you can test links for them without uploading to the Web server. 
When the reader passes the pointer over a hotspot, the client-side map shows the exact address 
the hotspot links to. When the reader clicks a hotspot, the browser sends the server a URL 
request. The server contacts the Web server storing the page and sends the page back to the 
browser.

Navigator 2.x and later and all versions of Internet Explorer support client-side image maps.

Server-side image maps These image maps require two files: an HTML file containing the image 
and a separate map-definition file for the links. This image map file is stored on the Web server. 
When the reader passes the pointer over a hotspot, the coordinate numbers of the image map 
appear. When the reader clicks a hotspot, the browser sends the click coordinates to the server, 
the server looks up the coordinates in the map file, and then the server sends the URL back to 
the browser. The browser then sends a request for that URL back to the server, the server 
contacts the Web server storing the linked page, and finally the server sends the correct page 
back to the browser. 

This communication is time-consuming, and maintaining the correct server-side files can be 
difficult. For these reasons, if you have a choice, you should always create client-side image 
maps instead of server-side image maps. (However, you may need to use server-side image 
maps if your intended audience is restricted to older browsers that don’t support client-side 
image maps.)

I
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About editing image maps
To create an image map, you must use the appropriate image-editing tools. PageMill has 
separate tools for client-side and server-side image maps:

• A client-side image map is edited in the regular page window. When selected, the image 
appears with a thick dashed line around it, and client-side hotspot tools are added to the 
regular toolbar.

• A server-side image map is edited not in the page window, but in a separate Image window. 
When the image is in this window, server-side hotspot tools appear to the left of the image.

Creating client-side image maps
Creating a client-side image map is a fourfold process:

• Select the GIF or JPEG image on the PageMill page.

• Edit the image map by drawing the hotspots and creating links to them. 

• Save the page.

• Test the links. 

You edit client-side image maps in the PageMill window. Editing a client-side image map is 
sometimes called in-line or in-place editing because it’s done within the page.

Adding hotspots and default links to client-side image maps

You add hotspots to an image map using the drawing tools in the toolbar. 

A. Selector Tool B. Rectangle Hotspot C. Circle Hotspot D. Polygon Hotspot E. Shuffle Hotspot F. Hotspot 
Color G. Show Hotspot Label H. Open Image Window

BA C D FE G H
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A default link is used when someone clicks an area of the image that’s not covered by a hotspot. 
Generally you link it to a page that says something like “Sorry, try again,” or you can just link it 
to the page containing the image map image so that the page simply reloads in the browser.

Note: It’s a good idea to specify a default link, because some image map servers or scripts won’t work 
unless you do. Ask your ISP if your image map script requires a default link.

To add hotspots to an image:

1 In Edit mode, double-click an image. A thick dashed line appears around the selected image, 
and the drawing tools appear in the toolbar. 

2 Click the rectangle ( ), circle ( ), or polygon ( ) button in the toolbar and drag over the 
image to draw a shape. PageMill numbers each hotspot as you draw it, with lower-numbered 
hotspots in front. These numbers appear only in Edit mode.

Hotspots in image map

3 Create a link for each hotspot (you can use any of the methods described on page 76 except 
for using Insert > Object). The filename or title of the linked page appears in the hotspot. 

4 To turn off link display and reduce screen clutter, click the Show Hotspot Label button ( ) 
in the toolbar.
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To create a default link:

1 Decide on or create a page that you want to be the default link (that is, the page you want 
displayed if a reader clicks on the image but outsideof its hotspots).

2 Do one of the following:

• Drag a page icon ( ) of the default page onto a non-linked part of the image.

• Drag an anchor icon ( ) from the default page onto a non-linked part of the image.

• Click a non-linked part of the image, type a URL of the default page in the Link To bar at the 
bottom of the page or Image window, and press Enter.

Editing hotspots in client-side image maps

You can edit the hotspots you create by selecting them and then moving or resizing them, or 
changing their colors to make them more visible. 

Hotspots can overlap other hotspots. You can move overlapping hotspots forward or backward 
in the layer order. The frontmost one has the lowest number and is the one that will be activated 
when clicked in a browser.

To edit a hotspot:

1 In Edit mode, double-click the image and click a hotspot. Handles appear around the 
hotspot.

2 Do the following:

• To resize a hotspot, drag any of its handles.

• To move a hotspot, drag it from anyplace except its handles.

• To change the color of the border for all hotspots in PageMill, click the Hotspot Color button 
in the toolbar ( ) and select a color. (The hotspot shape and color don’t appear in the browser, 
so you should make the clickable area obvious when designing the image.)

• To delete a hotspot, press Backspace.

To change the layering order of hotspots:

1 In Edit mode, double-click the image and click a hotspot.

2 Click the Shuffle Hotspot button ( ) and choose a command from the pop-up menu:

• Bring To Front moves the selected hotspot to the top layer.



99

• Send To Back moves the selected hotspot to the bottom layer.

• Shuffle Forward moves the selected hotspot forward one layer.

• Shuffle Back moves the selected hotspot back one layer.

Testing client-side image maps

You can test a client-side image map, just as you test any other type of link (see page 87). You 
can also preview client-side maps from the hard drive in a browser that supports them. 

If the client-side image map doesn’t work as expected, make sure you have not resized the 
image in an image-editing application after adding the hotspots. To resize the image outside of 
PageMill after adding hotspots, you must deselect and reselect Scale to Height and Scale to 
Width in the Inspector so that the image’s new dimensions are loaded.

Creating server-side image maps
Setting up a server-side image map is more complicated than setting up a client-side image 
map. Links to server-side image maps may depend on a Common Gateway Interface (CGI) 
script that is closely tied to the type of server that publishes your Web site. (CGI is a language 
that allows communication between a Web browser and a Web server.)

When you set up an image as a server-side map, PageMill creates an image map file that 
describes the links to the file (the hotspots) you created. The image map file must contain the 
Web server locations of link destinations. You can use only one image map file per image; 
however, you can use an image and image map file more than once in a site or on a page.

Creating a server-side image map requires several steps:

• Use the Preferences command to set the map format, line break format, and suffix prefer-
ences and to set local aliases.

• Open the image that you’re using as an image map in the Image window, and add hotspots 
and create links to them. 

• Create a link to a default page or errors page.

• In the Inspector, mark the image as an image map.

• Link the image on the page to the map file (and to a CGI script, if required).

• Test the links from the Web server.
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Setting format preferences for server-side image maps

Be sure to set up all preferences before creating a server-side image map. To create a server-side 
image map file, you must first obtain the following information from your Internet Service 
Provider (ISP):

• The server platform

• The Web site map format, NCSA or CERN 

• The location of your site’s root folder on the Web server (the Remote Root Directory) 

• How to link the image to the image map file and script (often called the A HREF to the map 
file)

To specify the format preferences:

1 Choose Edit > Preferences and click the Resources tab.

2 Choose a server type from the Map Format pop-up menu. The map format controls how the 
shape, coordinate, and link information is specified in the map file. (If you’re unsure, try 
NCSA, which is the more common format.)

3 Click the Page tab.

4 Choose the Web server platform (not the platform on which you are creating Web pages) 
from the Line Breaks pop-up menu.

5 Choose a suffix from the Suffix pop-up menu that matches the server platform:

• Use .html for all platforms except DOS.

• Use .htm for all servers except for some UNIX servers (some UNIX servers prefer .html).

6 Click OK.

Setting local aliases for server-side image maps

A local alias provides the information PageMill needs to create the server-side image map file 
correctly. The local alias identifies the remote root directory (the URL to the Web site’s home 
page, minus the filename of the home page) and the local root folder (the site folder on the local 
hard drive that contains the site’s main home page and all linked files, images, and subfolders 
for that site).
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When you set up a local alias for your site, the local root folder is aliased to one of the following:

• The full URL of the root of the site on the server; for example:
http://www.ispname.com/~username/

• The relative path of the site from the root of the server; for example:
/~username/

Be sure to enter the slash at the end of the pathname in both cases.

To set up a local alias for a server-side image map, follow the steps on page 84.

Adding hotspots to server-side image maps

You add hotspots to an image map using the drawing tools in the Image window. Editing a 
server-side image map is called out-of-place editing because it is done in the Image window (as 
opposed to in-place editing, which is done in the PageMill window).

A. Selector Tool B. Rectangle Hotspot C. Circle Hotspot D. Polygon Hotspot E. Make Transparent
F. Shuffle Hotspot G. Hotspot Color H. Show Hotspot Label I. Make Interlaced J. Zoom In and Zoom Out

You also need to add a default link, which is used when someone clicks an area of the image 
that’s not covered by a hotspot (see page 98).

To add hotspots:

1 Do one of the following to display the image in an Image window:

A

B

C

D

E

F

G

H

I

J
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• Right-click the image and choose Open Image Window.

• Hold down Control and double-click the image.

2 Select a rectangle ( ), circle ( ), or polygon ( ) button and draw a shape on the image. 
PageMill numbers each hotspot as you draw it, with lower-numbered hotspots in front. 

 If you need to enlarge the image to draw hotspots precisely where you want them, use 
the Zoom In button in the Image window.

3 Link the hotspots (see page 103).

4 Close and save the Image window.
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PageMill saves the new file containing the hotspot data in the same folder as the image, and 
names the data file the same as the image plus the extension .map. (For example, the image map 
for Sun.gif would be Sun.map.) The hotspot data contains the shape of the hotspot, the link 
path to the linked file, and the coordinates for the position of the hotspot. 

Important: Be sure you don’t scale the image when working with server-side image maps. Scaling 
changes the image size but does not change the hotspot coordinates, so the hotspots will not appear 
in the correct location. If you must scale an image intended for a server-side image map, first change 
its size in an image-editing application, then insert the image, and finally create the image map.

Editing hotspots in server-side image maps

You can edit the hotspots you create by selecting them and then moving or resizing them, or 
changing their colors to make them more visible.

You can also layer overlapping hotspots. You can move overlapping hotspots forward or 
backward in the layer order. The frontmost one has the lowest number and is the one that will 
be activated when clicked in a browser (see page 98).

To edit a hotspot:

1 Do one of the following to display the image in an Image window:

• Double-click the image and then click the Open Image Window button on ( ) the toolbar.

• Hold down Control and double-click the image.

2 Select a hotspot and follow the steps for editing client-side image maps (see page 98).

Creating and displaying links in server-side image maps

Once you’ve added a hotspot, you must link it to a destination. Linking a hotspot to another 
page or URL is just like linking text or images (see page 76) except that you can’t use the 
Insert > Object command or the Insert Object button on the toolbar.

When you select a hotspot or drag a link onto a hotspot, the filename of the link appears over 
the hotspot and the link URL appears in the Link To bar. 

You can turn off the link display to make pages appear visually less cluttered.

To turn off link display:

Click the Show Hotspot Label button ( ) in the vertical toolbar in the Image window.
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Marking images as server-side image maps

Before you can test the hotspot links for a server-side image map, you must mark the image as 
an image map. When you preview an image map, if the pointer doesn’t change when it’s over 
the map image, you’ve probably forgotten to do this.

To mark the image as an image map:

1 In Edit mode, select the image and display the Inspector (View > Show Inspector).

2 Click the Object tab and then click Map.

3 Enter the image map location by typing the pathname to the image map file in the Link To 
bar at the bottom of the page. 

About pathnames to server-side image maps

To implement the links to the server-side image map, you must specify where the CGI script 
and the image map data file (the .map file) will be stored on the server, with a pathname specific 
to the server. The pathname can vary depending on how your ISP has set up image maps to 
work on the server.

If you’re using a Netscape server, such as Netsite, or Microsoft Internet Information Server, use 
either a relative or an absolute path from your HTML document to the image map file. For 
example, if the HTML file is in the same folder as an Images folder, and the Images folder 
contains the .map file, type this relative pathname in the Link To bar:

images/image.map

where image.map is the name of the map file associated with the image.

You could also type the full URL to the map file (http://www.company.com/~username/ 
images/image.map) or the absolute path from the root of the server to the map file 
(/~username/images/image.map) in the Link To bar.

If you are using an NCSA server, depending on the server software your Web server uses, you 
may have to specify the directory containing the CGI script and the script name. Then specify 
the path to the image map data file. (Ask your ISP if this is necessary.) For example, in the Link 
To bar, type the following: 

/cgi-bin/imagemap/~username/images/image.map
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where /cgi-bin/imagemap is the path from the root of the Web server to the image map script 
called imagemap, and /~username/images/image.map is the path from the root of the Web 
server to the map file for this particular image map.

(For more information, send an e-mail to techdocs@adobe.com and type 202130 in the subject 
line. A technical note on this subject will be e-mailed back to you.)

Testing and troubleshooting server-side image maps

To make sure that an image map’s hotspots work as expected, test the map. To test a server-side 
map, upload your site to a Web server and then test the image map in your browser.

Use the following table to troubleshoot problems in server-side image maps: 

Problem Possible cause

An error message about the map file 
appears.

You didn’t create a default link for the image map (if required by your 
server). See page 98.

You didn’t specify the correct root folder location, server type, and line 
breaks for the platform of your Web server. See page 100.

You didn’t specify the correct location of the CGI script and the image map 
data file on the server, with a pathname specific to the server. See 
page 104.

An error message about the file that the 
hotspot was linked to appears.

You didn’t upload the contents of your local root (site) folder to your Web 
server to mirror the directory structure of your computer’s hard drive.

The pointer doesn’t change to a hand 
when it passes over the image (and no 
coordinates are displayed in the browser’s 
link-display area).

You didn’t select the Map option in the Object panel of the Inspector. See 
page 104.

The wrong page opens when you click 
the image map.

You resized the image in PageMill instead of in an image-editing applica-
tion.
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Chapter 7: Adding Tables

ables are an efficient way to organize information into rows and columns. 

Note: Some older browsers don’t support tables.

About tables
Tables are made up of cells in columns and rows. Tables may also have captions, headings, and 
borders.

Table with cell borders: A. Caption B. Heading C. Row D. Border E. Column

Tables without cell borders are also a handy way to lay out text and images on your page.

A table without cell borders used as a layout tool (all screen elements are actually in cells)

T

C

B
A

D

E
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Creating tables
You can create a new table within PageMill or copy and paste Microsoft Excel data into PageMill 
to create a table.

Note: You can’t create two tables next to each other. To achieve the same effect, you can nest two 
tables within a single table (see page 119) and then make the outer table borderless (see page 117).

To create a table:

1 In Edit mode, click the page where you want to add a table.

2 Choose Insert > Table or click the Insert Table button ( ) in the toolbar.

3 Enter the number of rows and columns.

4 Do any of the following:

• To specify table or cell constraints, enter values for Table Width or Cell Width (see page 114).

• To change the border, enter a value for Border (see page 117).

• To set up cell spacing or padding, enter values for Cell Spacing or Cell Padding (see page 118).

5 Click OK. 

 If you drag down and to the right over the Insert Table button ( ), you can quickly 
create a table containing up to 10 rows and 10 columns.

To create a table from Microsoft Excel:

Do one of the following:

• Copy the cells you want from Microsoft Excel. In Edit mode in PageMill, click where you 
want the table to appear and choose Edit > Paste. If you click inside a table, pasting Excel data 
creates a new table nested within the first one.

• Select the cells you want from Excel and then drag them into a PageMill page.



109

Selecting cells, cell contents, or tables
You can select table cells, the contents of a cell, or an entire table. PageMill indicates the type of 
selection as follows:

• A thick dashed line around a table indicates that you’re working within a table—that is, you 
have an insertion point in a cell, have one or more cells selected, or have the contents of a cell 
selected. 

A. Selected cells B. Selected cell contents

• A thin line around a table with handles indicates that the entire table is selected.

A B
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To select one, several, or all table cells:

1 In Edit mode, click the cell you want to select to place the insertion point there (if the table 
is already selected, you have to double-click the cell to place the insertion point).

2 Press Control+9 to select the cell (you can also choose Edit > Table > Select More).

3 Do one of the following:

• To select a different cell, click the new cell.

• To extend the selection, hold down Shift and click in the table.

• To select all cells, press Control+A (or choose Edit > Select All).

 You select table cells when you want to constrain their width, format them as header 
cells or non-wrapping cells, change their alignment or background color, merge or split 
them, or add or remove columns and rows.

To select cell contents:

Do one of the following:

• If there is currently no table selection, click in the cell and select the contents as you would 
any other text or object.

• If the cell is selected, press Shift+Control+9 (or choose Edit > Table > Select Less).

• If the table is selected, press Shift+Control+9 twice (or choose Edit > Table > Select Less).

To move to a cell and select its contents:

Do one of the following:

• Press Tab to move to the next cell.

• Press Shift+Tab to move to the previous cell. 

• Hold down Control+Alt and press an arrow key to move in a specific direction.

To select an entire table:

Do one of the following:

• Click inside the table and then click the thick line surrounding the table.

• Click inside the table and then press Control+9 twice (or choose Edit > Table > Select More).
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• Control-click the table.

• Click the outer border of the table, if there is one.

The table is outlined with a thin line with handles.

 You select an entire table when you want to change its width, add a caption or a 
border, change the cell spacing or padding, align the table on the page, or delete the entire 
table.

Adding and deleting columns and rows
You can easily add or delete rows or columns to or from an existing table. Rows are added below 
the selection; columns are usually added to the right of the selection.

To add a row or column:

1 In Edit mode, select adjacent cells in a row or column.

2 Do one of the following:

• To add a row, click the Insert Row ( ) button in the toolbar or choose Edit > Table > Insert 
Row.

• To add a column, click the Insert Column ( ) button in the toolbar or choose Edit > Table > 
Insert Column.

• To add multiple rows or columns, select that number of rows or columns before clicking the 
Insert button. For example, if you select five rows, five more rows will be added.

• To add an empty row above the first row (for example, for headings), insert a row and then 
cut and paste the original contents of the first row into the second row.

To add a row or column without first selecting cells:

Hold down Control and click a horizontal or vertical divider line in the table.

To delete a row or column:

1 In Edit mode, select adjacent cells in a row or column.

2 Do one of the following:
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• To delete a row, click the Delete Row ( ) button in the toolbar or choose Edit > Table > 
Delete Row.

• To delete a column, click the Delete Column ( ) button in the toolbar or choose Edit > 
Table > Delete Column.

• To delete multiple rows or columns, select that number of rows or columns before clicking a 
Delete button on the toolbar. You can’t delete all the rows or columns of a table.

Working in cells
You enter or replace data in a cell using regular editing techniques. If the cell gets too wide as 
you enter data, you can constrain or control it (see page 114). You can also manually shorten a 
long entry in a table by pressing Shift+Enter to insert a line break, which moves the remaining 
data down a line without inserting an empty line. You can also format and align the contents 
of cells.

Entering and deleting data in cells

Every cell is created with a nonbreaking space character in it so that its border is visible. If you 
want the cell to remain “empty” but still be displayed with a border, don’t remove the space 
character. If you want to add contents, select and delete the space so that the new contents wrap 
and align properly.

A. Empty cell with space deleted B. Cell with space before the number does not align properly.

To enter data into a cell:

1 In Edit mode, click a cell to place the insertion point or select its current contents.

2 Type the text, drag and drop text or objects, or paste the data. For more information, see 
“Importing text” on page 26 or “Adding an image or multimedia object” on page 50.

A B
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To delete a cell’s contents:

In Edit mode, select the cell contents and press Backspace, or choose Edit > Clear. If you delete 
all the contents—including the nonbreaking space character that’s inserted at the start of every 
cell when it’s first created—that cell’s border is removed, and PageMill displays a dotted-line 
border instead. This dotted line doesn’t display in Preview mode or in a Web browser.

To delete the nonbreaking spaces from multiple cells:

1 In Edit mode, select a cell and Shift-click in the table to extend the selection.

2 Choose Edit > Clear. The cell borders no longer display (but they will reappear when you 
enter text in the cells).

Formatting and aligning cell contents

You format the contents of a cell just as you do text in a page. To change the text appearance, 
apply any of the paragraph formats or character styles. For example, to create a bulleted list in 
a cell, select the text and then choose Format > List > Bullet. 

By default, a table has the same color as the background color; you can change the color of the 
cells but you can’t change the color of a table border.

To format the text of a cell:

1 Select the text you want to format.

2 Change the tag, alignment, color, font, and relative font size by choosing a command from 
the Style or Format menu or by using the toolbar. For information, see Chapter 3, “Working 
with Text.”

Note: You must format each cell in a table separately. If you select more than one cell, the text 
formatting options are unavailable.

To format a cell as a heading, align cell contents, or choose a cell background color:

1 In Edit mode, select one or more cells and display the Inspector (choose View > Show 
Inspector).

2 Do the following:

• To have the contents of the cell display as a heading in a browser, select Header Cell. Some 
browsers display table heading cells in centered, bold typeface. 

• To set alignment, select an option from the Vertical Align and Horizontal Align boxes.
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• To choose a background color, choose a color from the Background pop-up menu or choose 
Custom to select a color from the Color dialog box. (You can also click a color on the Color 
Panel.)

 Because background cell color is lost when you join cells (see page 119), you should 
finish the table layout before assigning background colors.

Changing cell and table widths and heights
You can affect the height of cells by setting a height constraint in the Inspector. You can affect 
the width of cells either visually (by inserting a line break in a cell or by dragging a border), or 
automatically (by setting a width property in the Inspector).

The width and height of a table as a whole can also be changed either visually (by dragging its 
handles) or automatically (by setting its width and height properties). The interaction of 
constrained cells and tables can become complex; avoid constraining widths unless the 
contents of your table requires you to.

Changing cell widths and heights

Keep the following information in mind when you’re setting cell widths:

• The dimensions of a table and its cells that you enter are sizing recommendations. The Web 
browser determines how the table appears.

• When there is more than one constrained cell in a column, the maximum pixel cell constraint 
and the minimum percent constraint are used. Percent constraints always take precedence over 
pixel constraints. 

• Cells are never made smaller than their largest item. For this reason, pixel values don’t always 
represent the actual width of a cell. If a cell contains an item too large to fit in the constrained 
width, the cell is sized to fit the item and the other cells shrink proportionally. 

• By default, every table cell contains a space. Because of this, inserting an image that is wider 
than the cell may push the image down a line (the text is wrapping) unless you delete the space 
or set the cell to No Wrap. 

To control selected cell widths:

1 In Edit mode, select one or more cells and display the Inspector (choose View > Show 
Inspector).
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2 Do one of the following:

• To let the width be determined by the contents of the cell, choose None from the Width 
Constraint pop-up menu. This setting is often the most desirable.

• To resize the width visually, drag a row divider. You can’t resize beyond the constraints set for 
that cell. 

• To prevent text from wrapping, select No Wrap.

• To specify the width as a percentage of the table’s width, choose Percent from the Width 
Constraint pop-up menu and then enter a value.

• To specify the width in pixels, choose Pixels from the Width Constraint pop-up menu and 
then enter a value.

If you don’t specify a value, the width changes as needed to remain proportionate to the height.

Note: You can also specify these options to either pixels or percentage as you create a table, by using 
the Insert Table button ( ) in the toolbar. 

To control selected cell heights:

1 In Edit mode, select one or more cells and display the Inspector (choose View > Show 
Inspector).

2 Do one of the following:

• To let the height be determined by the contents of the cell, choose None from the Height 
Constraint pop-up menu. This setting is often the most desirable.

• To resize the height visually, drag a row divider. You can’t resize beyond the constraints set for 
that cell. 

• To specify the height as a percentage of the table’s height, choose Percent from the Height 
Constraint pop-up menu and then enter a value.

• To specify the height in pixels, choose Pixels from the Height Constraint pop-up menu and 
then enter a value.

If you don’t specify a value, the height changes as needed to remain proportionate to the width.

Creating dynamic and fixed-width tables

By changing the width settings of a table as a whole, you can affect how it works in a browser. 
The two main types of table are as follows:
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• Dynamic tables resize to fit the width of the Web browser (their dimensions are set to be a 
percentage of the page size).

• Fixed tables do not resize when viewed in a Web browser (their dimensions are set to specific 
pixel values).

You can also create tables that have some fixed-width columns and some dynamic columns (see 
page 114).

To control the width of a table:

1 In Edit mode, select the table (not the table cells; see page 109) and display the Inspector 
(choose View > Show Inspector).

2 Do one of the following:

• To let the width be determined by the contents of the rows, choose None from the Width 
Constraint pop-up menu.

• To specify a dynamic table, choose Percent from the Width Constraint pop-up menu and 
then enter a value.

• To specify a fixed-width table, choose Pixels from the Width Constraint pop-up menu and 
then enter a value.

Note: You can also specify this setting as you create a table, by using the Insert Table button ( ) 
in the toolbar.

Changing table heights

You can constrain the height of a table or let its height change as the contents of its cells change.

To control the height of a table:

1 In Edit mode, select the table (not the table cells; see page 109) and display the Inspector 
(choose View > Show Inspector).

2 Click the Object tab and do one of the following:

• To let the table height be determined by the contents of its cells, choose None from the Height 
Constraint pop-up menu.

• To resize the height visually, drag a handle. You can’t resize a table beyond the constraints set 
for that table. 

• To specify the height as a percentage of the height of the browser window, choose Percent 
from the Height Constraint pop-up menu and then enter a value.
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• To specify the height in pixels, choose Pixels from the Height Constraint pop-up menu and 
then enter a value.

If you don’t specify a value, the height changes according to the content of the cells and the 
width constraints on the cells. 

Adding, removing, and changing borders
A border helps distinguish a table from the page background and from the other objects on a 
Web page. By default, a table has a border of 1 pixel. You can’t change the border color. 

Table with border

Table with no border and borderless table in Edit mode

HTML dictates that empty cells are always borderless. This is why PageMill initially creates cells 
with a space character in every cell. If you delete the space character in a cell and don’t replace 
it with anything, that cell’s border is removed, and PageMill displays a dotted-line border 
instead. This dotted line does not display in Preview mode or in a Web browser.

 To create the appearance of multiple columns, you can use borderless tables to help 
lay out a Web page. For example, you could use a fixed-width borderless table to create a 
three-column bulleted list to place images and text precisely next to each other.

To add, remove, or change a table border:

1 In Edit mode, select the table (not the table cells; see page 109) and display the Inspector 
(choose View > Show Inspector).

2 Do one of the following:

• To add or change the visible border, enter a pixel value in the Border text box.
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• To remove the border, enter 0 (zero) in the Border text box.

Note: To add a border as you create the table, use the Insert Table dialog box (see page 108).

Changing cell spacing and padding
Cell spacing is the amount of space between the cells—that is, the width of the shaded lines that 
separate the cells. Cell padding is the amount of space from the edge of the cell to the beginning 
of the cell’s contents. Changing a table’s cell spacing or cell padding affects all cell dividers and 
cells. (Changing the cell spacing does not affect the border; see page 117.)

Cell Spacing=2 and Cell Spacing=5

Cell Padding=0 and Cell Padding=5

To change the cell spacing or padding:

1 In Edit mode, select the table (not the table cells; see page 109) and display the Inspector 
(choose View > Show Inspector).

2 Enter a value (from 0 to 500 pixels) in the Cell Spacing text box or in the Cell Padding text 
box.

Note: To set the cell spacing and padding as you create the table, use the Insert Table dialog box (see 
page 108).
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Joining and splitting cells
When you create a table, all rows have the same number of cells and all columns have the same 
number of rows. You can modify a table so that some rows or columns have fewer cells—
joining some cells so that one cell occupies the space previously occupied by two or more. 
Joined cells are useful for entering long headings or for creating special effects. 

A. Joined cells in a row B. Joined cells in a column

To join the cells in a row or column:

In Edit mode, select two or more cells and click the Join Cells button ( ) in the toolbar. You 
can also choose Edit > Table > Join Cells. Joining cells combines the contents of the cells. 

To split cells that have already been joined:

In Edit mode, do one of the following:

• Click in a joined cell and choose Edit > Table > Split Cell Horizontally or Split Cell Vertically. 
When you split a cell in this way, the contents to the left of the insertion point are placed in one 
cell, and the contents to the right are placed in the other.

• Select the joined cell and choose Edit > Table > Split Cell Horizontally or Split Cell Vertically 
(or click the Split Vertically or Split Horizontally button on the toolbar). When you split a cell 
in this way, all the content is placed in the leftmost or topmost cell. The other cell, because it 
now has no content, loses its border. You can enter a space character in the borderless cell to 
make its border reappear.

Creating nested tables
You can insert, or nest, one table inside another. You may want to nest tables when using a 
borderless table as a design aid, or to format the data in a single cell as a table. 

A

B



CHAPTER 7120
Adding Tables

To nest a table inside another:

In Edit mode, do one of the following:

• Click in a cell and then click and drag over the Insert Table button ( ) or click that button.

• Select an existing table and drag it into a cell.

• Select cells and drag them into a cell.

• Copy cells and paste them into a cell.

Adding and changing captions
You can include a caption for a table that describes its contents. A caption can appear either 
above or below the table. 

Table with caption above and with caption below.

To add or change a caption:

1 In Edit mode, select the table (not the table cells; see page 109) and display the Inspector 
(choose View > Show Inspector).

2 Do one of the following:

• To add a caption, select Caption and click the button above or below the table icon on the 
Inspector. Then select the word caption in the table itself and type the caption you want.

• To move a caption, click the unselected button above or below the table icon on the Inspector.

• To remove a caption, deselect the Caption option. 
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Chapter 8: Creating Forms

Web page can function as a form. A form lets the reader type information and send it 
to the Web server, which can store, analyze, or act on the information depending on 
how it is programmed. For example, you can create a Web version of a product catalog 

and set up one of its pages as an order form that readers can use to order products. You can also 
use forms to let readers specify search criteria, to enter a password, or to get customer feedback.

Creating a form involves three activities: 

• Deciding what your form will look like and what data you need to collect

• Adding the form controls and options to a page

• Linking to a script that acts on the data that the reader enters

About form scripts
When the reader submits a form (clicks the button that sends the data to the server), the server 
processes the data according to a Common Gateway Interface (CGI) script written in a 
scripting or programming language such as Perl. A script can send the contents of the form 
somewhere, or it can do more complex tasks, such as collecting data in a database or generating 
a new page based on the form’s content.

Every form you create must have a corresponding CGI script on the server, provided by you, 
your ISP, or your script programmer. To work properly, this script must recognize the names 
and values it receives from the form objects on your page. For more information, see “Associ-
ating a CGI script with a form” on page 131. 

Specific information about programming CGI scripts is outside the scope of this guide, but 
many sources for CGI information exist on the Web. Also, many ISPs have common CGI scripts 
already running on their servers; contact your ISP for more information.

A
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Adding form objects
You can add form objects by using the commands on the Insert > Form menu or by using the 
toolbar. 

A. Checkbox B. Radio button C. Text area D. Text field E. Password field F. Pop-up menu G. Submit button
H. Reset button I. Form Break button

Several of the form objects (such as the checkbox and the radio button) are standard user-
interface objects. To minimize confusion, be sure to use these controls as they’re used in 
standard applications (for example, use radio buttons, not checkboxes, for mutually exclusive 
choices).

Adding checkboxes

Use checkboxes when you want readers to choose one or more options. Checkboxes can appear 
singly or in groups.

To add a checkbox:

1 In Edit mode, click where you want to add the checkbox and then choose Insert > Form > 
Checkbox or click the Insert Checkbox button ( ) in the toolbar.

2 Add text next to the checkbox describing it. (See Chapter 3, “Working with Text.”)

To quickly duplicate a checkbox:

1 In Edit mode, select the checkbox you want to duplicate.

2 Control-drag a checkbox to add a new one to the group. The new checkbox is a copy of the 
first one and has the same name and value as the original one.

A B C D E F G H I
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To customize a checkbox:

1 In Edit mode, select a checkbox and display the Inspector (choose View > Show Inspector).

2 Do the following:

• To assign a descriptive name to the checkbox (the form script will use this name to track 
which checkbox is sending data), type a name in the Name text box. 

• To tell the form script what a checkbox means when a viewer selects it, type a value in the 
Value text box. This value is determined by the CGI script being used; ask your ISP or the script 
designer for the value needed. For example, you could give a checkbox named Overnight 
Delivery a value of Yes.

• To make the checkbox be selected or deselected by default, click Checked. (You can also do 
this by triple-clicking the checkbox on the page.) For example, you could deselect Checked for 
a checkbox named Overnight Delivery because it is a more expensive option for a customer.

 Whenever you change the name or value of a checkbox, make sure you or your script 
programmer also changes the CGI script that interprets the form’s data. 

Adding radio buttons

Use radio buttons when you want readers to select only one option from a group, such as a 
color choice. Clicking one radio button deselects all other buttons in the group. Radio buttons 
always appear in groups of two or more.

A radio button group

To add and customize a radio button group:

1 In Edit mode, click where you want to add the radio button and then choose Insert > Form > 
Radio Button or click Insert Radio Button ( ) in the toolbar.

2 Select a radio button and display the Inspector (choose View > Show Inspector).

3 Type a descriptive name in the Name text box. The form script will use this name to track 
which radio button group is sending data. All the radio buttons in a group must have the same 
name. 
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4 Hold down Control and drag the radio button on the page to add as many new ones to the 
group as needed.

Note: Naming the button before Control-dragging it ensures that all buttons in the radio button 
group have the same name.

5 Add text to the page next to each radio button describing it. (See Chapter 3, “Working with 
Text.”)

6 Select each radio button in the group in turn, and do the following in the Inspector:

• To tell the form script what a radio button means when it’s clicked, type a value in the Value 
text box. This value is determined by the CGI script being used; ask your ISP or the script 
designer for the value needed. For example, one button could have a value of Blue, and another, 
a value of Red.

• To set a radio button to be selected by default (and thereby deselecting all the others in the 
group), click Checked. (You can also do this by triple-clicking the radio button on the page.) 

 Whenever you change the name or value of a radio button, make sure you or your 
script programmer also changes the CGI script that interprets the form’s data. 

Adding text fields

A text field lets a reader type text in a form. A text field can contain default text and can be 
single-line, password, or multiline:

• A single-line text field lets readers enter information that typically is fairly short, such as 
names, telephone numbers, and filenames.

• A password field is a special kind of single-line text field that displays a series of bullets or 
asterisks instead of the actual typed characters. (However, the text is not encrypted.)

Note: To set up security or passwords for directories or pages, contact your ISP. 
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• A text area, or multiline text field, lets a reader type a long passage of text into a scrollable box.

To add a multiline, single-line, or password text field:

1 In Edit mode, click where you want to add the text field and type an onscreen label for the 
text field.

2 Click the Insert Text Area ( ), Insert Text Field ( ), or Insert Password Field ( ) button 
on the toolbar or choose one of these commands from the Insert > Form menu.

3 For a single-line or multiline text field, to add text that appears by default, double-click in 
the text field and type the text.

To rename a text field:

1 In Edit mode, select a text field and display the Inspector (choose View > Show Inspector).

2 Type a new name in the Name text box.

To resize a single-line or password text field:

In Edit mode, select a text field and do one of the following:

• To resize visually, drag its handle.

• To resize numerically, display the Object panel of the Inspector and enter a Size value for the 
number of monospaced characters that will show. Then enter a Max Length value to control 
how many characters can be entered into the field. (The Max Length value is ignored in 
PageMill Preview mode.)

To resize a multiline text field:

In Edit mode, select a text field and do one of the following:

• To resize visually, drag one of its handles (Shift-drag the bottom right handle to maintain its 
proportions).
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• To resize numerically, display the Object panel of the Inspector and enter a value for Rows to 
specify the number of lines of text visible. Then enter a value for Columns to specify the 
number of monospaced characters visible horizontally.

To make text entered in a multiline text field wrap:

1 Make a backup of your file so that you can revert to it later if you have to.

2 In Edit mode, select the text field and choose View > HTML Source.

3 After the COLS attribute in the TEXTAREA tag, enter a WRAP attribute, as in the following 
example:

<TEXTAREA NAME="name" ROWS="4" 
COLS="27" WRAP="VIRTUAL"></TEXTAREA>

You can enter either of the following types of wraps:

• To wrap text in a browser but not when the data is submitted to the Web server, enter 
WRAP="VIRTUAL"

• To wrap text in a browser as well as when the data is submitted to the Web server, enter 
WRAP="PHYSICAL"

4 Preview the word-wrap in Internet Explorer Preview mode.

Adding hidden fields

Hidden fields appear only in HTML code, and do not appear on the form when viewed by 
readers. A common use of hidden fields is in mailback scripts. For example, many ISPs provide 
a standard CGI script for receiving form data and mailing it to your e-mail box. This CGI script 
requires a hidden field containing the site owner’s mail address, so that the script knows what 
address to send the form information to (see also page 174).

To add a hidden field:

In Edit mode, click where you want to add the hidden field and choose Insert > Hidden Field.

The field appears on the page as a small box with an H in it ( ). This marker and hidden fields 
are visible only in Edit mode. To turn off the display of hidden fields, choose View > Hide Invis-
ibles.
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To customize a hidden field:

1 In Edit mode, select a hidden field and display the Inspector (choose View > Show 
Inspector).

2 Do the following:

• To assign a descriptive name to the field so that the form script can know which field is 
sending data, type a name in the Name text box. The name is determined by the CGI script. For 
example, the name of a hidden field might be “Mailed from.” Ask your ISP or the script designer 
for the exact name.

• To tell the form script what value the hidden field has, type a value in the Value text box. This 
value is determined by the CGI script being used; ask your ISP or the script designer for the 
value needed. For example, the value of a hidden field might be an e-mail address. Ask your ISP 
or the script designer for the needed value.

 Whenever you change the name or value of a hidden field, make sure you or your 
script programmer also changes the CGI script that interprets the form’s data. 

Adding pop-up menus or list-selection fields

Pop-up menus and list-selection fields let readers choose from a set of options:

• Use a pop-up menu when you want the reader to choose only one item from a group. In this 
way, a pop-up menu resembles a radio button group, but a pop-up menu takes up less space.

• Use a list-selection field when you want the reader to choose one or more items from a list. 
To create a list-selection field, create a pop-up menu first, and then convert it to a list-selection 
field.

Pop-up menu List-selection field

To add a pop-up menu:

1 In Edit mode, click where you want to add the pop-up menu or list-selection field and type 
an onscreen label.
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2 Choose Insert > Form > Popup or click the Insert Pop-up button ( ) in the toolbar.

To convert between a pop-up menu and a list-selection field:

In Edit mode, select the pop-up menu and do one of the following:

• To convert a pop-up menu to a list-selection field, select the pop-up and then click Allow 
Multiple Selections in the Object panel of the Inspector.

• To convert a list-selection field to a pop-up menu, select the field and then deselect the Allow 
Multiple Selections option in the Object panel of the Inspector.

To set up the choices in a pop-up menu or list-selection field:

1 In Edit mode, double-click the pop-up menu or the list-selection field.

2 Choose Edit > Select All, type an entry, and then press Enter. Repeat for each additional 
entry.

3 Do one of the following:

• To specify which item will be the default in a pop-up menu, drag the triangle to position it 
next to a menu item.

• To specify which item will be the default in a list-selection field, check the box next to an item 
in the list. (These checkboxes are only for setting the default; the reader will not see these check-
boxes.)

To specify the values for the options of a pop-up menu or a list-selection field:

1 In Edit mode, select a pop-up menu or list-selection field and display the Inspector (choose 
View > Show Inspector).

2 Type a value next to each item name to tell the form script what a menu option means when 
it’s selected. This value is determined by the CGI script being used; ask your ISP or the script 
designer for the value needed.

 If you change the name or value of a menu option, make sure you or your script 
programmer also changes the CGI script that interprets the form’s data. 
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To resize a list-selection field:

In Edit mode, select the list-selection field and do one of the following:

• To resize visually, drag its handle.

• To resize numerically, display the Object panel of the Inspector and enter a value in the Items 
Visible text box. The value must be equal to or smaller than the total number of items in the 
list. Additional items won’t be visible until the reader scrolls the field.

Note: Typing a value of 1 into the Items Visible option converts the field to a pop-up menu if the 
Allow Multiple Selections option is deselected.

To allow or disallow multiple choices in a pop-up menu or list-selection field:

1 In Edit mode, select a pop-up menu or list-selection field and display the Inspector (choose 
View > Show Inspector).

2 Select or deselect Allow Multiple Selections. Readers of the form can make multiple selec-
tions by Control-clicking or Shift-clicking the items they want.

Adding Submit and Reset buttons

A Web page form does not send any form information to the Web server until the reader 
explicitly requests it to do so. Typically, readers send information by clicking a Submit button, 
and can clear a form and start over by clicking a Reset button. You should use only one Submit 
button per form.

The exact names and appearances of the Submit and Reset buttons may vary. Some Web pages 
use a graphic for a Submit button to match the graphic identity of the page. You can use a 
default image or any image you’ve placed on your Web page as a Submit or Reset button.

To add a default Submit or a Reset button:

1 In Edit mode, click where you want to add the button and then click Insert Submit Button 
( ) or Insert Reset Button ( ) in the toolbar, or choose one of these commands from the 
Insert > Form menu.
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2 If you want to change the button’s label, double-click the Submit button or the Reset button 
on the Web page, select the text, and then type the text you want. The button resizes to accom-
modate the new text.

To use an image as a Submit or Reset button:

1 In Edit mode, select the image on your Web page and display the Inspector (choose View > 
Show Inspector).

2 Click Button as its behavior.

3 Click the Form tab of the Inspector and associate an action with this button object.

Creating multiple forms on a page
You may need to create more than one form on a Web page. For example, you may want to use 
one form to gather address information and use another form to solicit feedback on your site. 
Each form will have its own set of controls and buttons—including a Submit and Reset button.

To start a new form on a Web page:

In Edit mode, click where you want to start a new form and then choose Insert > Form > Form 
Break or click the Insert Form Break button ( ) in the toolbar. A Form Break bar indicates the 
boundary between the two forms in PageMill but does not appear in a browser.

To remove a form break:

1 In Edit mode, click the Form Break bar that separates the forms and press Delete. The 
contents of the two forms are combined.

2 Delete any form objects that were part of the form you want to remove.
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Associating a CGI script with a form
Once you’ve associated the Submit button with a script, clicking it causes the browser to send 
the values of every option and text field on a form to the Web server. Each form must have a 
corresponding CGI script on the server—provided by you or by your script programmer—that 
recognizes and can process the names and values it receives from the form objects on your page. 
Work with the CGI script programmer to ensure that the form objects’ names and values are 
consistent with those in the script. For more information about setting up names and values of 
form objects, see “Adding form objects” on page 122.

To associate the appropriate CGI script with a form:

1 In Edit mode, click in the form you want and display the Inspector (choose View > Show 
Inspector).

2 Click the Form tab and then type the pathname for the CGI script on the Web server into the 
Action text box.

3 In the pop-up menu below the Action option, choose GET or POST. (When the POST 
option is selected, the CGI script collects information from the form and sends it to the Web 
server. When the GET option is selected, the script sends information from the Web server to 
the form.) For more information about which to choose, consult your script programmer or 
contact your ISP.





133

Chapter 9: Using Frames

rames divide a browser window so that more than one Web page can be shown at once. 

In a page with no frames, a reader clicks link A. to open new page B. In a page with frames, a reader clicks link 
C. and linked information appears in the targeted frame D. on the same page.

About frames and framesets
Frames let you create pages where only sections of the page change rather than the entire page. 
They are useful for displaying static, unchanging items, such as a navigation bar or a table of 
contents, where clicking a word or image in one frame brings up a different page in another 
frame.

The content of each frame is a separate page (and separate file) with its own URL, independent 
of other frames. 

F

A

B

C

D
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When you divide a page into frames, you’re creating a special frameset document along with 
the frame source documents. 

• The frameset document is created by PageMill and works behind the scenes to organize the 
frames—it tells the browser how to display the frame windows and which documents to display 
inside each frame. The frameset filename appears in the PageMill title bar when you’re working 
in a page containing frames. You can view the source code for a frameset document (see 
page 171), but you don’t use the View > HTML Source command to do it.

• The frame source documents are the pages that appear in the frames. These filenames also 
appear in the PageMill title bar.

Some older browsers do not support frames. A special “no frames” message is displayed when 
a user of these browsers tries to view a Web page that contains frames (see page 136).

 You can have as many frames in a frameset as you want, but don’t overdo it. Too many 
frames can look cluttered and cause long load times. 

Here’s an overview of the typical process for creating a frameset:

• Design your frameset—decide which frames will be static and which will change.

• Create and name the frameset (see page 135).

• Add the content to the frames. Save your frame source documents as you place or edit them 
in the frames (see page 136).

• Save the frameset (see page 137).

• Create and target the links and save the frame documents with the links in place (see 
page 144).

• Preview and troubleshoot the links (see page 92).
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Creating framesets
A frameset document stores the frameset title and keeps track of the size, placement, contents, 
and other attributes of each frame in the set. You create a frameset document by dividing a page 
into frames. You can also nest frames (create one frameset inside of another).

Frames on a page
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To create a frameset:

1 In Edit mode, do the following:

• Hold down Control and move the pointer to the inside edge of the window. When the pointer 
changes to an arrow (such as ), drag out a frame border.

• Hold down Shift and Control and move the pointer to the inside edge of the window. When 
the pointer changes to an arrow (such as ), drag out a frame the full width or height of the 
window. 

2 Resize the frames as needed by dragging their borders.

 You can also click a page or a frame and choose or Edit > Frame > Split Frame 
Horizontally or Edit > Frame > Split Frame Vertically.

To remove a frame:

1 In Edit mode, move the pointer over the frame border until it changes to a double-headed 
arrow and then drag the border to the edge of the window or to the edge of an adjoining frame. 
A dialog box appears asking you to confirm that you want to remove the frame. (If no dialog 
box appears, you didn’t drag the border close enough to the edge or you dragged past it.)

2 Click OK.

To change the message that appears in browsers that don’t support frames:

1 In Edit mode, choose Edit > Frame > No Frames Message. The current no-frames message 
appears in a separate window.

2 Edit the message.

3 Close the window and choose File > Frameset > Save Frameset.

Adding content to frames
Every new frame is an untitled document that you can add content to as you would to any other 
Web page. You can also insert an existing page into a frame or clear out the contents of a frame 
with a new, blank page.

When a frame is small, you may find it easier to add content to it by opening it into a separate 
window. Be sure to save a frame (see page 137) before you open it in a separate window or 
preview any links on it.
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To insert a page in a frame:

In Edit mode, select the frame and do one of the following:

• To insert a page you’ve already created, choose File > Frameset > Insert Page, select a file from 
the Open dialog box, and click Open.

• To clear out the contents of a frame and insert a new blank page, choose File > Frameset > 
Insert New.

To add content to a frame:

In Edit mode, select the frame and add contents just as you do on a Web page (by typing, 
pasting, inserting, dropping, and so on).

To open a frame in a separate window:

In Edit mode, click in the frame and choose File > Frameset > Open into Window. The frame 
in the frameset turns gray while you’re editing it in a separate window.

To spell-check a frameset:

Do one of the following:

• In Edit mode, click in each frame in turn and choose Search > Check Spelling (see page 41).

• If the frameset is part of a site, load the site and check spelling for the entire site (see 
page 157), including all the pages of the frameset.

Saving frames and framesets
When working with frames, you need to save both the frames and the frameset. When you save 
a frame, you save its contents (the source document in the frame). When you save the frameset, 
you save the layout of the frames, the properties of all the frames, and the no-frames message. 
PageMill lets you save just a frame or just the frameset, or both together.

Before you save a frameset, be sure the page and the individual frames appear as you want them 
to when the reader opens the page. For example, if you’ve followed a link in a frame, be sure to 
return to the original page before saving the frameset.

If you close a frameset that has unsaved changes, a series of dialog boxes prompts you to save 
each frame in turn and then the frameset file itself.
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To save a frame:

1 In Edit mode, select a frame and do one of the following:

• To save the frame, choose File > Save Frame. 

• To save the frame under a new name or in a new location, choose File > Save Frame As.

2 Click Save.

To save a frameset:

1 In Edit mode, do one of the following:

• To save the frameset, choose File > Frameset > Save Frameset.

• To save the frameset under a new name or in a new location, choose File > Frameset > Save 
Frameset As.

2 Click Save.

To save all the frames and the frameset at the same time:

In Edit mode, choose File > Frameset > Save Everything.

To revert to the last saved version of a frame or a frameset:

In Edit mode, do one of the following:

• To go back to the last saved version of a frame, select a frame and choose File > Revert to 
Saved.

• To go back to the last saved version of a frameset, choose File > Frameset > Revert to Saved 
Frameset.

Editing frames
You can select a frame and then specify the following properties for it:

• The frame name, title, size, and margins 

• Whether the frame displays scrollbars or borders

• Whether a frame is resizable by the reader

• Whether a frame opens at the top of a page or at a specified location on the page
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To select a frame:

In Edit mode, click anywhere inside a frame. A light border appears around the frame 
indicating it’s selected.

Renaming and retitling frames

Every frame has two types of names:

• A frame’s filename is the name of the file as it is stored on a computer’s hard disk. For 
example, a frame’s filename might be Contents.html.

• A frame’s name is an internal name that you use when targeting and creating links to a frame. 
Each frame is initially named Framexx, where xx is a randomly generated number. Because you 
use these names when targeting a link (see page 144), you may want to give a frame a more 
descriptive name. (Be careful to give your frames unique names; a browser might get confused 
if two frames have the same name in a single frameset.)

Caution: Be sure you rename a frame before you create any links to it. Renaming a frame after 
targeting links breaks previous targets to it.

A frame’s name is not the same as its title. You can edit two types of titles for a frame document:

• The title for a frameset is the title that identifies it for readers on the Web—it appears on the 
browser’s title bar and in go-to lists in a browser. 

• The title of a source document appearing in a frameset is not displayed in a Web browser 
unless the source page is opened independently of the frameset.

To rename a frame:

1 In Edit mode, select a frame and display the Inspector (choose View > Show Inspector).

2 Enter a new name for the frame in the Name text box. Use only alphanumeric characters and 
no spaces in the new name. 

3 Choose File > Frameset > Save Frameset.

To change the title of a frameset:

In Edit mode, enter the title in the Title text box, which appears above the page window.

To change the title of a frame source document:

1 In Edit mode, click in the frame whose source-document title you want to change.
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2 Choose File > Frameset > Open into Window.

3 Enter the new title in the Title text box and save and close the window. 

Resizing frames

You can resize a frame by simply dragging its borders or by using the Inspector.

Resizing a frame to improve the word-wrap on the left

To resize nested frames (frames within frames), use the Inspector’s Frames Resizing Box. This 
box, in the Frame panel of the Inspector, displays a series of nested squares. Each square repre-
sents a frame level. A single square indicates the selected frame is one level deep and is the 
topmost level (that is, it’s not inside another frame). Any settings you enter apply to this frame. 
Two squares indicate the selected frame is nested inside another frame, three squares that the 
nested frame is nested inside another frame, and so on. Click a square to select it. The values 
you enter for Height or Width are applied to the selected frame.

To resize a frame visually:

1 In Edit mode, move the pointer over a border between two frames until the pointer turns 
into a double-headed arrow, then drag the border.

2 Choose File > Frameset > Save Frameset.
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To resize a frame numerically: 

1 In Edit mode, select a frame and display the Inspector (choose View > Show Inspector), and 
then click the Frame tab.

2 If you want to resize a nested frame, click the box in the Inspector that represents the level of 
nesting you want the change to be related to. For example, clicking the outermost box changes 
the size in relation to the whole window, but clicking the innermost box changes the size in 
relation to the most adjacent frame.

3 Look at the Width or Height option. (If the frame fills the width of the window, only the 
Height option appears; if the frame fills the height of the window, only the Width option 
appears.)

Note: When the combined frame widths don’t equal the width of the browser window, the browser 
will adjust the frames by proportionally increasing or decreasing the frame dimensions. 

4 Choose a unit of measurement and enter a value as shown in the following table:

Measurement Meaning and use Example values

Pixels Creates a frame that won’t be resized when the browser window is resized. Use 
this to display text or images at their full size, no matter what the browser win-
dow size. 

40, 200, 345
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5 Choose File > Frameset > Save Frameset.

Setting frame margins

Margins determine the space between the frame contents and the page edges.

To set frame margins:

1 In Edit mode, select a frame and display the Inspector (choose View > Show Inspector).

2 Click the Frame tab and enter a new pixel value for Margin Height or Width. The Margin 
Height determines the distance between the frame contents and the top and bottom of the 
page; the Margin Width determines the distance between the frame contents and the right and 
left sides of the page.

3 Choose File > Frameset  > Save Frameset.

Setting scrollbar display

Scrollbars appear automatically when the page in the frame exceeds the frame dimensions. You 
can change this behavior and hide them or make them always appear.

To set the display of scrollbars:

1 In Edit mode, select a frame and display the Inspector (choose View > Show Inspector).

2 Click the Frame tab and do one of the following:

• To always show scrollbars, choose Yes from the Scrollbars pop-up menu.

• To never show scrollbars, choose No from the Scrollbars pop-up menu.

• To show scrollbars only when necessary, choose Auto from the Scrollbars pop-up menu. 
(This is the default setting.)

Percent Specifies what proportion of the browser window will be used to display the 
frame. (Caution: A frame set to 100 would display at the browser window’s full 
width and would therefore knock out adjacent frames.)

20, 50, 80

Relative Makes the frame proportional to the other frames in the frameset. Use this, for 
example, to have one frame always be twice the width of another (set one 
frame’s width to 1, and the other to 2).

1, 2, 3, 4

Measurement Meaning and use Example values
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Turning off frame borders

By default, a frame appears with a black border around it, but you can turn off these borders. 
Turning off the border of one frame turns them off for all frames in the frameset.

 You can make a frame completely blend in with the adjacent frames by removing 
frame borders, turning off scrollbars (page 142), and making sure each frame uses the 
same background color or pattern (see page 38).

To turn off a frame border:

1 In Edit mode, select a frame and display the Inspector (choose View > Show Inspector).

2 Click the Frame tab and deselect Frame Border.

3 Choose File > Frameset  > Save Frameset.

Opening pages in frames at specified locations

By default, the page in a frame is displayed starting at the top of the page, but you can have a 
frame display at a specified location when the frameset is opened.

To set up a frame to open its page at a specified location:

1 In Edit mode, scroll to the page location where you want the frame to open.

2 Choose Insert > Anchor (rename the anchor, if you want; see page 82), and select the anchor 
and copy its name.

3 Click the frame and display the Inspector (choose View > Show Inspector) and paste the 
anchor name in the Anchor At text field in the Inspector.

Preventing frame resizing

By default, a reader can resize the frame in the browser, but you can set up the frame so that it 
can’t be resized. PageMill can correctly preview resizable frame-based pages only when 
previewing in Internet Explorer Preview mode.

To prevent a frame from being resized:

1 In Edit mode, select a frame and display the Inspector (choose View > Show Inspector).
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2 Click the Frame tab and deselect the Viewer Resizable option. Any frames sharing a border 
with the frame will also not be resizable.

Printing frames
When you print from a page with frames, you print the contents of the current frame (that is, 
the page in that frame). You can print an entire frameset from your browser.

To print a frame:

Select a frame and choose File > Print Frame.

To print an entire frameset:

1 Choose File > Frameset > Save Everything.

2 Open the frameset in a browser capable of printing entire framesets (for example, Internet 
Explorer 4.0) and print from there.

Targeting links in frames
By default, a linked page opens into the frame that contains the link. However, you may want 
a link in one frame to display a page in a different frame. For example, the links in a frame 
containing a table of contents are typically all targeted to another frame. That way, the table of 
contents remains visible and available.
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You define the target using the Target menu, a pop-up menu that contains a thumbnail of the 
frameset layout. The special target commands appear above the thumbnail and provide 
additional control over how frames are targeted within a frameset. 

A. Target menu B. Special target commands C. Thumbnails of frames

Caution: Be sure all the frame source documents and the frameset file have been saved and named 
the way you want them before you target links in frames.

You can also specify a base target, a destination the browser uses for any links that don’t have 
defined targets. Setting up a default target saves you from having to define each link separately. 
Even if you specify a base target, you will probably still want to manually set up links that open 
in frames other than the base target.

Note: Some older browsers may not support base targets.

To specify which frame or window a link should open in:

1 If necessary, create the link in a frame (see page 76). 

2 Click the linked image or hotspot, or click anywhere in the linked text and do one of the 
following:

• Right-click the link to display the Target menu.

• Select the entire link and then click the Target button ( ) in the lower right corner of the 
frameset window to display the Target pop-up menu. 

3 Do one of the following:

• To specify which frame the link should open in, drag over its thumbnail version. 

• To specify that the linked page should open in a new window, choose New Window.

C

B

A
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• To specify that the linked page should open within its own original frameset instead of within 
the frameset currently displayed, choose Parent Window.

Note: PageMill can correctly display frame-based pages that have Parent Window links only when 
previewing in Internet Explorer Preview mode.

• To specify that the linked page open using the entire current browser window, choose Same 
Window. Use this command when the link is to a page that is part of a frameset and you want 
the frameset to open in a new window, not in the current frameset—that is, in the “same 
window” as it would normally open in if the link were opened outside of a frame’s page. 

To reset a link to open in the same frame that contains the link:

1 In Edit mode, click the linked image or hotspot or click anywhere in the linked text and do 
one of the following:

• Right-click the link to display the Target menu.

• Select the entire link and then click the Target button ( ) in the lower right corner of the 
frameset window to display the Target pop-up menu. 

2 Do one of the following:

• To specify that the linked page open in the same frame as the link—or in the base target 
frame—choose Default.

• To specify that the linked page open in the same frame as the link—even overriding the base 
target—choose Same Frame. 

For information on base targets, see page 145.

To specify a base target (a default destination for links that don’t have defined targets):

1 In Edit mode, click in the frame that will contain the links.

2 Display the Inspector (choose View > Show Inspector) and click the Page tab.

3 Choose an option from the Base Target ( ) pop-up menu as described on page 145.

Overriding targeted frames when previewing
When you’re testing your Web pages with linked frames, you may want to keep them from 
opening inside their targeted frame and instead have them open in either the same window or 
in a new window. 



147

To override targeted frames when previewing:

In Preview mode, right-click a link and do one of the following:

• In PageMill Preview mode, choose New Window to display the linked page in a new, separate 
window or choose Same Window to display the linked page in the current window.

• In Internet Explorer Preview mode, choose Open in New Window to display the linked page 
in a new, separate window or choose Open to display the linked page in the current window.

Moving backward and forward in frames
When you work in Preview mode, you can move backward and forward between pages in a 
frame without leaving the frameset.

To move back and forward in a frame:

Do one of the following:

• In PageMill Preview mode, move the pointer over an unlinked section of a frame, right-click, 
and choose Back in Frame or Forward in Frame. 

• In Internet Explorer Preview mode, click the Back or Forward button in the toolbar.
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Chapter 10: Working with Web 
Sites

n the World Wide Web, a Web site is a group of related pages that reside together on a 
Web server. When you edit your site in PageMill, the site exists as a group of Web pages 
inside a site folder. The site folder can contain additional subfolders and files. All the 

files making up your site are usually contained within this one local root folder. 

About site management
Site management consists of several important activities:

• Updating your pages to change or improve the contents of the pages. 

• Keeping the links on the pages current and in working order. Web links—especially links to 
sites that you have no control of—often change or sometimes disappear.

• Adding, moving, or removing pages.

• Uploading the new or changed files to the Web server, and deleting any used files from the 
server.

Important: Some site maintenance activities could be performed outside of PageMill. For example, 
it’s possible to rename a Web page in a Windows Explorer window. Doing this is not recommended. 
Performing site maintenance within PageMill ensures the integrity of links and avoids error when 
you upload to a Web server. Only changes made from within PageMill are reflected in the site 
automatically.

PageMill gives you three areas to view and work with your site, one overview area and two 
detailed-view windows:

O
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Site Overview area Displays the names and hierarchy of all the files in your site. This area also 
includes three special folders for working with errors and files external to the site folder.

List view Displays the contents of the site folder, the Errors folder, the Externals folder, or the 
WWW Links folder. The List view of the site folder includes the titles for all the files and folders 
as well as their sizes, their modification dates, and the number of links going into and out of 
each item. You can move, cut, copy, unlink, and rename files in this window.
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Links view Displays a pictorial representation of your site, where each linked file is shown 
graphically linked by an arrow. 

Working with Web sites
PageMill lets you create and open sites either by loading a folder location or by first assigning 
a name to a site and then loading that site by name. Naming a site is convenient if you’re 
working on several sites at once and might otherwise get them confused.

A site must have a local root folder, which is the folder on your hard disk or network that 
contains all the site files. PageMill automatically displays this local root folder in the Site 
Overview area along with several other special folders.

Folder Contents

Site name Displays the name of the site. If you haven’t named the site, it repeats the name of the 
local root folder. This folder appears only in PageMill and has no counterpart on your 
hard disk.

Local root folder The topmost folder on your hard disk or network containing the other files and folders 
for the site.

Errors A folder that displays any errors that PageMill finds. As you fix errors, items are 
removed from this folder. This folder appears only in PageMill and has no counterpart 
on your hard disk.

Externals A folder showing the path to files used in your site but that are not contained within 
the local root folder. This folder appears only in PageMill and has no counterpart on 
your hard disk.

WWW Links A folder showing the URLs used in your site that point to other places on the Internet. 
This folder appears only in PageMill and has no counterpart on your hard disk.
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Many common commands appear in the Site Details toolbar. They are dimmed when the 
current context makes them inapplicable.

A. Folder Navigation pop-up menu B. Move up one level C. Create new folder D. Create new page E. Cut, Copy, 
and Paste F. Delete G. Unlink H. Verify I. List & Links J. List only K. Links only

To create and name a site:

1 Choose Site > New.

2 Enter a name in the Name text box. (A site’s name appears only in PageMill; it doesn’t have 
to be the same as the name of the local root folder.)

3 To create or specify a folder as the local root folder, do one of the following:

• Enter a path in the Location text box (for example, c:\personal\mysite). 

• Click Browse, use the dialog box and the Folder text box to create and open a new folder, and 
then click OK.

• To enter further settings, used when uploading the site, click Settings. See page 167 for 
details.

4 Click Create. The Site Overview area opens with the new site loaded and a default home 
page, index.html, is created in the local root folder.

To load a site:

Choose Site > Load and then do one of the following:

• To load a site by its name, choose a name from the top of the menu.

• To load a site by its path to a local root folder, choose a pathname (if no pathname appears, 
you haven’t yet chosen a site by its pathname).

• To locate a local root folder, choose Browse, select a folder, and click OK.

Loading a site automatically closes a site that’s already open.

 Dragging a folder onto the PageMill application icon loads that folder in PageMill as 
a site. You can also right-click a folder and choose Open as Site in PageMill.

A B C D E F G H I J K
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To cancel loading a site:

Press Esc or click the Cancel button next to the progress bar as a site is loading.

To turn off alert messages that appear when loading a site:

1 Choose Edit > Preferences and click the Site tab.

2 Do the following:

• To turn off messages warning you that there are read-only files in the site you’re opening, 
deselect “Display alert if locked files are found in the site.” The icons for locked files in site 
windows contain a padlock. When selected, this option also detects any PDF file whose security 
setting disallows changing the document.

• To turn off messages warning you about corrupted image maps, deselect “Display alert if bad 
image map files are found in the site.”

3 Click OK.

To reload a site:

Choose Site > Reload.

Note: Reloading is necessary if a filename or location has been changed in the site from outside of 
PageMill (only changes made from within PageMill are reflected in the site automatically). Because 
PageMill can make changes to your site without breaking links, you should always use PageMill to 
make such changes.

To rename a site:

1 Right-click the topmost site folder (the folder with the site name and the house icon) in the 
Site Overview area and choose Edit Current Site Settings. This command is present only if a 
named site is currently loaded.

2 Change the name in the Site Name text box. (A site’s name appears only in PageMill; it 
doesn’t have to be the same as the name of the local root folder.)

3 Click OK.

To close a site:

Do one of the following:

• To close the current site, choose Site > Close.
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• To close the current site and open another one, choose Site > Load.

Viewing the contents of Web sites
PageMill offers you a number of ways to view the files that make up a Web site (see page 149). 
You can also view a summary of a site’s contents.

To get an overview of a site:

Expand or collapse the contents of a folder in the Site Overview area by clicking its plus sign or 
its minus sign. You can also use the arrow keys to move up and down and to expand (Right 
Arrow) or collapse (Left Arrow).

To hide the Site Overview area:

Do one of the following:

• Click the arrow in to the Site Overview title bar. Click it again to restore the area.

• Choose View > Hide Site Overview. Choose View > Show Site Overview to restore the area.

To view details of a site:

1 If the Site Details window is not already showing, right-click the site root folder in the Site 
Overview area and choose Show Details.

2 Click in the Site Overview area and click or use the arrow keys to move up and down and to 
expand (Right Arrow) or collapse (Left Arrow) folders. As you select files or folders in the site, 
the Site Details window is updated to give you information on the selection. Note the following:

• The Type column displays Image, Page, or Folder. An unrecognized type is displayed as Other.

• The In and Out columns tell you how many incoming and outgoing links there are for that 
selection. A red x indicates no incoming links; a blue dash (–) indicates no outgoing links. You 
can click the link number to see the names of the linked files. (Selecting a filename will open 
that file.)

• The Page Title column displays the title of the page, if it has one. Clicking the title opens the 
page.
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3 To change the view in the Site Details window, choose a command from the View > Details 
menu or do one of the following:

• To see the List view above the Links view, click the List & Links button ( ) in the toolbar.

• To see only the List view, click the List Only button ( ) in the toolbar.

• To see only the Links view, click the Links Only button ( ) in the toolbar.

To sort the List view of a site:

Click a column label in the Site Details window to sort in ascending order by the contents of 
that column. Click again to re-sort in descending order.

To view link details:

1 Do one of the following:

• Right-click a file (not a folder) in the Site Overview area and choose Show Details.

• Click a file in the List view.

• Click a link number in the In or Out column of the List view and choose Open Link View.

2 Choose View > Links (or right-click the background in the Links view) and choose from the 
following:

• To show all files with each level alphabetized by name, choose Show All by Name.

• To show all files with each level organized by file type, choose Show All by Type.

• To show only Web pages, but not image files, sounds, anchors, and so forth, choose Show 
Pages Only.
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To view a summary of a site’s contents:

1 Choose Site > Show Statistics. 

2 Do the following:

• Click the Site Content tab to see how many pages, images, applets, and so forth are in the site.

• Click the Site Resources tab to see how many errors, externals, and WWW links there are in 
the site.

To view properties for site files:

Right-click a file in the Site Overview area or in the Site Details window and choose Properties. 
The dialog box shows you basic file information, including the full pathname of the file, and 
lets you adjust its read-only attribute.

To specify the defaults for showing the Site Details window:

Choose Edit > Preferences, click the Site tab, and do one of the following:

• To have the Site Details window not open automatically when you load a site, deselect the 
option “Automatically Show Details When Loading a New Site.”

• To have the Site Details window be displayed with the List view above and the Links view 
below, click the first icon ( ) in the Default Details Mode area.

• To have the Site Details window be displayed with only the List view, click the second icon 
( ) in the Default Details Mode area.
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• To have the Site Details window be displayed with only the Links view, click the third icon 
( ) in the Default Details Mode area.

Editing Web sites
Most changes to the content of individual pages are made in a Page window (in Edit mode). 
Two exceptions are site-wide searching and site-wide spell-checking; you perform these activ-
ities from the site windows.

In addition to content changes, you can make the following changes to a site:

• Move and rename files and folders (PageMill updates all links to use the new names or 
locations)

• Change the URLs of links pointing to external Web sites

• Create and delete files and folders

• Unlink files

• Locate and fix errors

No save or undo command is available or needed when you’re editing a site; PageMill saves site-
wide changes as you make them. Changes you make to individual pages or images, which affect 
one file at a time, are saved when you choose File > Save.

Searching and spell-checking sites

When you search or spell-check a site, PageMill opens all the files in the site one at a time. 

To search and replace across some or all of a site:

1 In the Site Overview area or the Site Details window, right-click a file or folder, and choose 
Find. (You can also choose Search > Find.)

2 From the Search Path Scope pop-up menu, do one of the following:

• Choose Site Selection to search the pages of the site that are currently selected.

• Choose Entire Site to search all the pages of the current site.

3 Adjust other options in the dialog box as needed (see page 68). If you want to search and 
replace in the HTML code, be sure to select the Source option.

4 Click Find Next.
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5 When done, choose File > Save All to save the changes to all the open pages. (PageMill 
automatically saves any changes to pages that aren’t open.)

To spell-check some or all the Web pages in a site:

1 In the Site Overview area or the Site Details window, right-click a file or folder, and choose 
Check Spelling. (You can also choose Search > Check Spelling.) The Spell Checker begins 
immediately and stops at the first unknown word. 

2 From the Scope pop-up menu, do one of the following:

• Choose Site Selection to search the pages of the site that are currently selected.

• Choose Entire Site to search all the pages of the current site.

3 Adjust other options in the dialog box as needed (see page 41) and click Start. 

4 When done, choose File > Save All to save the changes to all the open pages. (PageMill 
automatically saves any changes to unopen pages.)

Moving, renaming, and unlinking files, folders, and anchors

When you move, rename, or unlink a file or folder, PageMill looks at all the links going into the 
file or files and adjusts them for you as needed. When unlinking a file, its links to other pages 
are not changed. When renaming an anchor, PageMill looks at all the links going into the 
anchor and adjusts them for you as needed. 

To move a file or folder in a site:

1 Drag a file or folder into a different folder in the Site Overview area, in the Site Details 
window, or from the one to the other.

2 If a message informs you that files will have to be relinked, click OK.

To rename a file, folder, or anchor in a site:

1 Right-click a file, folder, or anchor in the Site Overview area or in the Site Details window, 
choose Rename and type a new name. 

2 If a message informs you that files will have to be relinked, click OK.

To turn off alert messages that appear when moving or renaming files:

1 Choose Edit > Preferences and click the Site tab.
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2 Deselect “Confirm move or rename operations.”

3 Click OK.

To remove all incoming links to a file:

1 In the Site Overview area or in a Site Details window, right-click a file, and choose Unlink.

2 Click OK to change all the files that currently link to this file. (Outgoing links from this file 
are not changed.)

Viewing and Changing URLs of WWW links

The Site Overview area contains a special folder, named WWW Links, that collects all the links 
in your site that point to external Web destinations. If you’ve set up a browser to view remote 
links (see page 88), you can open a link in this folder.

If you edit the URL destinations, PageMill changes and saves the pages that contain them. 

To view the site of a WWW Link:

Do one of the following:

• Double-click a link in the WWW Links folder.

• Right-click a link in the WWW Links folder and choose Open in Browser.

To change the URL of a WWW link:

1 In the Site Overview area, right-click the WWW Links folder and choose Show Details.

2 Right-click a link, choose Rename, and enter a new URL (pasting it from another source, if 
possible, to reduce the chances of typing errors).

3 When a message informs you that a file will have to be changed, click OK.

Creating and deleting files and folders

You can create a new folder anywhere in a site and then drag files to it or create new files in it. 
When you create a new file, you can double-click it to open it in a Page window where you can 
add content and links.

When you delete a file or folder, make sure there are no links into it or you will break those 
links. You can’t delete the local root folder of a site.



CHAPTER 10160
Working with Web Sites

To create a new file or folder:

In the Site Overview area or in a Site Details window, right-click a file or folder, and choose New 
Blank Page or New Folder.

To delete a file or folder:

1 In the Site Overview area or in a Site Details window, right-click a file or folder, and choose 
Delete.

2 Click OK.

Fixing Errors

PageMill provides several convenient ways to spot and fix errors and possible problems in your 
sites:

• Broken links are displayed as red arrows in the Links view in the Site Details window. A red 
arrow is always an error and should be fixed.

• A file with no incoming links is displayed with a red x in the List view window. A red x may 
indicate that you’ve forgotten to link the page. (The home page for a site probably won’t have 
incoming links.)

• A file with no incoming and no outgoing links is displayed with a red x and a blue dash (–) 
in the List view of the Site Details window. A file with no links is not necessarily an error, but it 
may mean that you forgot to link the page. Such an unreferenced file will be unreachable to 
your readers unless they have its exact URL.

• Local files that are linked to your site but that are not within the local root folder are external 
files. Such files will be left behind when you upload to a Web server. This error is often the cause 
of missing graphics and unreachable links once a site has been uploaded to a Web server. 
PageMill lists these files in the Externals folder and provides a convenient way to bring them 
within your site prior to uploading, by using the Gather All Externals command. 

Caution: Don’t use Windows shortcut files (.lnk files) in the local root folder to access other folders. 
Such files are not recognized properly by PageMill or when you upload to a Web server.

• An external file that is missing is ordinarily considered an error (and appears in the Errors 
folder). However, you can turn off this type of error checking so that you can work on parts of 
a site without having to have all files available. For example, you may want to take a few files 
home to work on, but leave the rest at work. In that case, you can specify that missing external 
files not be counted as errors.
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• Due to the changeable nature of the Internet, links to Internet URLs—though valid when you 
first created them—may no longer be accurate. You can verify their accuracy before you upload 
a site.

• You can have PageMill display an alert message before trying to access a server when 
previewing links. This lets you quickly spot errors you may have made in entering URLs 
without waiting for a time-out error.

• When the case of a filename in a hand-typed URL does not match the true case of the 
filename, PageMill reports it as an error in the Errors folder. This avoids problems when 
uploading to a case-sensitive Web server. (For information on file-naming, see page 164.)

See page 92 for information on fixing link errors and page 87 for information on verifying 
remote links.

To avoid leaving files behind when you upload to a Web server:

1 Look at the Externals folder in the Site Overview area to see if there is a plus sign (+) next to 
it. If so, some linked files in your site are not within the topmost site folder. These externals need 
to be copied into the site folder before uploading your site.

2 Fully expand the Externals folder by right-clicking it and choosing Expand > All.

3 Do one of the following:

• To copy all the external files into the local root folder, right-click any folder or file in the 
Externals folder and choose Gather All Externals. 

• To copy just one external file into the local root folder, right-click the file and choose Gather 
This External. 

The gathered files are copied into a folder named Resources (which is created if necessary; see 
page 45), and all the links are adjusted to refer to that location.

4 If the files copied into the Resources folder have external links in them, PageMill asks if you 
want these additional files gathered into the site as well. Click OK to continue.

To see the full path of an external:

1 Select the Externals folder in the Site Overview area.

2 Do one of the following:

• Press the asterisk key (*) on the numeric keypad to fully expand all the folders in the 
Externals folder.
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• Right-click the Externals folder and choose Expand > All.

3 To see the path spelled out, right-click an external file and choose Properties.

To specify that missing external files not be considered errors:

Choose Edit > Preferences, click the Site tab, and deselect the option “Treat Missing Externals 
as Errors.” 

To specify where external files are copied:

1 Choose Edit > Preferences and click the Site tab.

2 Enter a name in the Site Resources Folder Name text box (the default is Resources). This 
folder will be created if needed and is where PageMill copies external files in a site as well as 
where converted images are placed (see page 45).

To have PageMill display an alert message before trying to access a server when previewing links:

Choose Edit > Preferences, click the Site tab, and select the option “Ask Before Accessing a New 
Server.”

To specify that mismatches in case in URLs not be considered errors:

Choose Edit > Preferences, click the Resources tab, and turn off the “Treat Case-Sensitive URL 
Differences as Errors” option. PageMill will no longer compare the case of filenames in URLs 
to the actual case of the filenames (mismatches of case will no longer appear in the Errors folder 
in the Site Overview area). For information on file-naming and case-sensitivity issues, see 
page 164.

Estimating the download time of pages and objects
Knowing how much time graphics and other objects will take to download from a Web server 
to a browser helps you to avoid creating lengthy download times for your readers. You should 
check the download time for pages and objects before you upload your site to a Web server.

PageMill’s estimated download times are based on theoretical connection speeds. The actual 
time to transfer information may vary, for example, if the server is busy or if files are being 
downloaded from a great distance.
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To estimate the download time of pages and selected objects:

1 Do one of the following:

• Load a site (choose Site > Load), right-click a file in the Site Overview area, and choose 
Download Statistics.

• In Edit mode, place the insertion point in a page or frame or select an object and choose 
View > Download Statistics.

2 Choose the connection speed you expect readers to use:

• If your readers will be using modem connections, choose a modem speed.

• If your readers will be directly connected to the Internet or to an intranet, choose T1.

Note the following:

• The Object area shows the estimated download time for a selected object. 

• The Page area shows the estimated download time for the document plus its linked files. 

• When the document is a frameset file, the Frameset section shows the estimated download 
time for the frameset including all its source documents and linked files. 

• The green pie chart represents the first minute of download time. If the download will exceed 
one minute, PageMill uses a blue pie chart inside the green pie chart.

3 Click OK.
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Uploading Web sites
Your Web site becomes accessible to other people only after you’ve uploaded all the site’s files 
to a Web server. If you try to upload a single page without loading a site, PageMill insists that 
you define a site for it first. This is because all upload settings are contained in the settings for 
a site.

Before you upload a site, go through the following checklist:

• Check all local links for errors (see page 92).

• Test the links in framesets and image maps (see page 99).

• Gather all files and folders used in your site into a single local root folder (see page 161).

• Verify all remote links (see page 87).

• Spell-check the site (see page 41).

• Obtain from your ISP or webmaster the path and password for the server you’ll be uploading 
to.

• Obtain from your ISP or webmaster both the URL for your site once it’s uploaded and the 
name of the Web server. The public URL is often similar but rarely identical to the name of the 
Web server. For example, the public URL may be www.adobe.com but the server for that site 
may be something like ftp.adobe.corp.com.

About file-naming on Web servers

Even if a site is error-free on your hard disk, it sometimes will contain broken links by the time 
it reaches its final destination: a Web server. Links in your Web pages can break after you’ve 
uploaded them for several reasons:

• You used long filenames, but you moved the site to a location that doesn’t support long 
filenames (such as some Novell servers). Hence, the DOS filenames were used instead (you can 
view the DOS filename for a file in a site by right-clicking it and choosing Properties).

• You used characters in the filename that were legal in Windows but caused problems in the 
operating system of the Web server. (Many Web servers are UNIX systems, but they can be 
Windows NT or Mac OS machines as well.) For more on file-naming, see page 10.
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• You linked to a file by hand-typing its filename and used the capitalization as it appeared in 
Windows Explorer. For example, you typed Logo.gif in the Link To bar because that’s how the 
file was capitalized in Windows Explorer. Unfortunately, Windows Explorer does not always 
display filenames as they are actually capitalized on your hard disk—the actual capitalization 
may have been LOGO.GIF. (You can view the actual capitalization for a file in a site window by 
right-clicking it and choosing Properties.) Even though the link worked on your computer, it 
breaks when the site is uploaded to a case-sensitive Web server (and most of them are), because 
Logo.gif doesn’t match the true filename LOGO.GIF.

You can avoid these problems by doing the following:

• Keep the option “Treat Case-Sensitive URL Differences as Errors” turned on in the Resources 
page of the Preferences dialog box unless you’re sure the Web server you’re using is not case 
sensitive.

• Don’t create a link in the Link To bar by typing a path. Instead use the Browse button or drag 
a link into the page or into the Link To bar (see page 76).

• Don’t create filenames with spaces in them, which can be a problem on some UNIX systems.

• If you must work on a Novell server that doesn’t support filenames longer than eight 
characters and a three-character extension, redesign your site to use DOS-compatible 8.3 
filenames. (Be sure to rename the files using the Site Details windows to avoid breaking even 
more links.)

Uploading to a Web server

You can upload an entire Web site or a single page, object, or frameset. The single page, 
frameset, or object must be part of a site that you’ve already defined upload settings for.

If you encounter problems while uploading, check your connections to the Internet and the 
PageMill upload settings (see page 167). 

Note: If you’re working from a corporate location that uses an Internet security system (a firewall), 
you won’t be able to upload files outside of your domain without obtaining special commands from 
your system administrator or webmaster.

To upload a Web site:

1 Load a site (see page 151).

2 Choose Site > Upload. You can also right-click the local root folder and choose Upload. 
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3 Edit the upload settings as needed (see page 167).

4 Click OK. An error message appears if there is a problem during the uploading process.

To cancel uploading:

Click Cancel in the progress dialog box that appears when uploading.

To view a report on an upload:

Do one of the following:

• To see a summary report of what files you last uploaded, choose Site > Show Settings, click 
the site name you want to see the report for, and then click View Log. The log file opens in your 
system’s default browser and reports on details of the last upload to a Web server.

• To see a detailed report or all the commands from the last ftp session, open the file called 
ftp_log in a browser.This file is in the Uploader Logs folder within the Program Data folder.

To upload a single page, frameset, or object:

1 Do one of the following:

• Open the page or frameset you want to upload. Uploading a page uploads that page along 
with any files associated with it, such as graphics. Uploading a frameset uploads that frameset 
document and its associated files.

• Open the page and select the object you want to upload. Uploading an object uploads the file 
containing the object and any files associated with the object (such as an associated server-side 
image map file).

• Open the image you want to upload in an Image window.

2 Do one of the following:

• Choose File > Upload > Page.

• Choose File > Upload > Frameset.

• Choose File > Upload > Object.

• Choose File > Upload Image (available only when the Image window is active).

3 If PageMill can’t find any site settings for this file, it lets you create a new site (see page 167) 
for the upload. 
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To upload a single page or frameset from the Site Overview area:

Right-click the page or frameset and choose Upload. If PageMill can’t find any site settings for 
this file, it lets you specify settings (see page 167) for the upload. Only the page or frameset is 
uploaded, not any linked objects within the page or frameset (to upload a page plus all its 
linked contents, use open the page and use File > Upload > Page).

Adjusting upload settings

Before you upload a site (see page 165), you must enter its upload settings. Once you’ve 
specified these settings for a site, you don’t have to redo them unless, for example, you need to 
change the URL of the destination site.

To specify the basic upload settings for a site:

1 Choose Site > Show Settings. Click the site name you want to specify settings for and click 
Edit. 

2 Click the General tab and do the following:
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• To specify the address of your ISP, enter in the Host Name text box a domain name, such as 
ftp.isp.com, or the numeric IP address that your ISP provided, such as 123.00.000.45. To 
upload to an intranet, enter the name of the network server that your webmaster provided. 

Note: The host name is not necessarily the name that viewers will use to find your site. For example, 
viewers may use www.adobe.com to access your pages, but the host name may something like 
ftp.adobe.corp.com. Ask your ISP or webmaster for the exact host name (or numeric IP address) to 
use.

• To specify the name of the folder on the server that will store your files, enter a path in the 
Remote Folder text box. The path should be relative to where you log on to the server. For 
example, you may have to enter users/myspot/public_html/, or, if the Web server logs you in 
at your home directory, you may have to enter only public_html/. Don’t precede the pathname 
with a slash (/). 

• To enter the login name, enter the name that your ISP or webmaster gave you into the User 
Name text box. For example, enter my_username.

• To include the password with the settings, enter the password provided by your ISP into the 
Password text box. The password appears as a series of asterisks (*). If you don’t enter a 
password here, you’ll be asked for it when you upload.

• To avoid being asked for your password in the future, select Save Password.

3 Click OK and then click Close.

To specify files to ignore when uploading a site:

1 Choose Site > Show Settings. Click the site name you want to specify settings for and click 
Edit. 

2 Click the Ignore File Types tab and do the following:

• To specify that a type of file should not be uploaded (even though a file of this type may be 
within the root folder), enter its extension in the upper text box and click Add. For example, 
entering psd prevents Photoshop files from being uploaded, which lets you conveniently store 
the original image files in a site folder without accidentally uploading them.

• To remove a file type from the list of those to ignore when uploading, select it in the lower 
text box and click Remove.

3 Select Always Ignore Files (deselecting this option disables the file-ignore feature).

4 Click OK and then click Close.
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To specify how to upload types of files:

1 Choose Site > Show Settings. Click the site name you want to specify settings for and click 
Edit. 

2 Click the ASCII Transfer tab and do the following:

• To specify that a type of file should be uploaded using the ASCII transfer method, enter its 
extension in the upper text box and click Add. For example, enter .css to ensure that cascading 
stylesheets are uploaded as text. (PageMill automatically uploads .html, .htm, and .txt files 
using the ASCII transfer method, so you don’t have to enter these extensions.)

• To remove a file type from the list of those uploaded using the ASCII transfer method, select 
it in the lower text box and click Remove.

• To turn off ASCII transfer—even for .html, .htm, and .txt files—select Always Do Binary 
Transfer.

3 Click OK and then click Close.

To specify whether all files or only changed files are uploaded:

1 Choose Site > Show Settings. Click the site name you want to specify settings for and click 
Edit. 

2 Click the Advanced tab and do the following:

• To upload all the files in the local root folder, regardless of their modification date or whether 
they’re already on the server, click Always.

• To upload only files that are not found on the Web server location or files that have been 
modified since the last upload, click Newer Files.

• To upload files to the server and delete files from the server so that the site contents match the 
local root folder, click Synchronize Files.

• To be warned when files are going to be deleted, select the option “Warn Me of Files to Delete 
When Synchronizing.”

3 Click OK and then click Close.

To specify advanced connection settings for uploading:

1 Choose Site > Show Settings. Click the site name you want to specify settings for and click 
Edit. 

2 Click the Advanced tab and do the following:
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• To specify the number of times PageMill should try to establish a connection with the Web 
server before displaying an alert message, enter a value in the Retry text box.

• To specify how many seconds PageMill should wait for a response from the Web server before 
displaying an alert message, enter a value in the Timeout Seconds text box.

• To specify the port to which the upload should occur, enter a value in the Port Number text 
box.

3 Click OK and then click Close.
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Appendix A: Viewing and Editing 
HTML Code

TML (Hypertext Markup Language) is the underlying code that makes up Web pages. 
As you create a Web page, PageMill writes the correct HTML source code for that page. 
Ordinarily, you won’t need to look at the HTML code that PageMill writes. However, 

there may be times when you want to make slight changes in the HTML source code. 

For example, you might want to insert blinking text or other HTML tags not currently 
supported in PageMill. You could also check the HTML source code to verify the naming of one 
of your objects or links.

Note: If you insert nonsupported code, you can preview the effect only in Internet Explorer Preview 
mode.

Viewing the HTML code
HTML consists of ASCII text formatted by codes called tags. Tags appear in angle brackets 
(such as <TABLE>) and can indicate formatting, the type of object you’re inserting, the names 
and locations to the links in the page, and so on. For example,

<BLOCKQUOTE>
   <H4 ALIGN=CENTER>Welcome to our online catalog. Now you can order any item
   in stock by using our new interactive <A HREF="EWOrder.html">Order
   Form</A>.<STRONG><KBD>
   </KBD></STRONG></H4>
</BLOCKQUOTE>

You can look at the source code for any Web page (including frameset pages). You can drag and 
drop page items onto a page’s HTML source code, and PageMill converts them automatically 
to source code, and vice versa—pasting source code onto a page in Edit mode converts the code 
to what it describes, such as a graphic or text. 

The HTML source code uses the following color codes in PageMill so you can easily identify 
the elements:

• HTML tags appear in blue.

• Text on a page appears in black.

H



APPENDIX A172
Viewing and Editing HTML Code

• Comments appear in red.

You can change the display colors of comments and tags when you’re working in the HTML 
source code.

If you have a selection in Preview mode, that selection is kept when you switch to view the 
HTML code. The mechanism for preserving a selection is to use a special kind of comment tag, 
<!--SELECTION-->. By default, this comment tag is not saved as part of the HTML code when 
you save a file, but you can specify that it be included, if you want.

To show or hide the HTML code for a page:

In Edit mode, choose View > Source Mode.

To change the color codes:

1 Choose Edit > Preferences and click the HTML tab.

2 Choose a color from the Comment Color pop-up menu or from the Tag Color pop-up 
menu. You can also choose Default or Custom. If you choose Custom, select a new color from 
the Color dialog box.

3 Click OK. 

To open pages in Source mode by default:

1 Choose Edit > Preferences, and click the General tab.

2 Choose Source Mode from the Open Pages In pop-up menu.

3 Click OK. The default settings go into effect the next time you open a page.

To include the comment tags used for selections when you save a file:

1 Choose Edit > Preferences and click the HTML tab.

2 Select the option named “Save selection using HTML comment tags.”

3 Click OK.

To view the HTML source code of a frameset document:

1 Choose Edit > Preferences and click the General tab.

2 Choose Source Mode from the Open Pages In pop-up menu, and click OK.

3 Open a frameset document.
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Editing HTML code
PageMill has several features that are useful for editing a page’s source code. Some make it easier 
to read the code, and others protect the code from changes when the browser interprets it. You 
can hide these editing items when you view the page in Edit or Preview mode.

Caution: Do not edit the HTML source code unless you have some experience in HTML and have 
a backup of your file. If you accidentally introduce improper HTML code, PageMill displays a 
question mark icon.

To edit a page’s HTML code:

In Edit mode, choose View > Source Mode and edit HTML code as needed. 

To search and replace in HTML code for a site:

1 Follow the steps in the procedure on searching in a site (see page 68).

2 Choose Site from the Scope pop-up menu.

3 Select the Source Mode option to search or replace in the HTML source code for the pages.

To search and replace in HTML code for a page:

1 In Edit mode, choose View > Source Mode.

2 Choose Search > Find, fill in the dialog box as needed (see page 68), and then click Find 
Next.

To spell-check in HTML code for a site:

1 Follow the steps in the procedure on spell-checking in a site (see page 41).

2 Choose Site from the Scope pop-up menu.

3 Select the Source option to spell-check in the HTML source code for the pages.

To correct improper HTML code:

In Edit mode, select the question mark icon, which represents the incorrect HTML, and do one 
of the following:

• Choose View > Source Mode and edit HTML code as needed.

• Choose View > Inspector and edit the HTML in the Unrecognized HTML text box.
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Setting HTML preferences

You can specify which HTML tags to use for setting relative font sizes and for aligning 
paragraphs.

To specify which tags to use for relative font size:

1 Choose Edit > Preferences, click the HTML tab, and do one of the following: 

• To use a browser’s default tag for font sizes, choose Size Attribute from the Font Size pop-up 
menu.

• To use BIG and SMALL tags, choose <BIG>&<SMALL> Tags from the Font Size pop-up 
menu.

2 Click OK. 

For more information about relative font sizes, see “Changing fonts and font sizes” on page 36. 

To specify what tags to use for alignment of text and objects:

1 Choose Edit > Preferences, click the HTML tab, and do one of the following: 

• To use the DIV tag, choose <DIV> Tag from the Alignment pop-up menu. DIV is preferred 
by Navigator but is not interpreted correctly by Internet Explorer 2.x and earlier.

• To use the P tag for alignment, choose <P> Tag from the Alignment pop-up menu. Tables 
you align with the P tag do not appear centered in Navigator 3.0 and earlier, NCSA Mosaic 
3.0b4 and earlier, or the America Online Web Browser 1.1 or earlier. Text you align with the P 
tag appears left-aligned in the America Online Web Browser 1.1 or earlier. 

• To center-align text and objects, choose <CENTER> Tag from the Alignment pop-up menu. 
Older browsers may not interpret the CENTER tag correctly

2 Click OK. PageMill rewrites all the alignment tags when you resave the document.

Adding special HTML tags

You can use several commands to insert special HTML tags that facilitate working in HTML 
source code. You may also want to add a META tag to include keyword search information on 
your document. PageMill always inserts its own META command stating that the page was 
created in PageMill, but you can add your own META tag after it. 
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To insert special HTML tags:

1 In Edit mode, choose View > Source Mode and do one of the following:

• To add a comment, choose Insert > Comment. When View > Show Invisibles is chosen, a 
comment appears as an icon ( ) in Edit mode. For more information on using comments, see 
page 176.

• To add an anchor, choose Insert > Anchor. An anchor name appears in the source code. 
When View > Show Invisibles is chosen, an anchor appears as an icon ( ) in Edit mode. For 
more information about anchors, see page 82.

• To add a margin break, choose Insert > Margin Break. The code <BR CLEAR="ALL"> 
appears in the source code. When View > Show Invisibles is chosen, a margin break appears as 
an icon ( ). 

• To add a hidden field, choose Insert >Hidden Field. When View > Show Invisibles is chosen, 
a hidden field appears as an icon with an H in it ( ). For information on using hidden fields, 
see page 126.

Note: You can also enter comments, anchors, margin breaks, and hidden fields in Edit mode.

To add a META tag:

1 Make a backup of your file. (Improperly coded META tags can result in loss of data.)

2 In Edit mode, choose View > Source Mode.

3 Place the insertion point after PageMill’s default META tag and press Enter.

4 Type the new tag. For example, to add keyword search items for a Web page on gardening, 
you might type the following:

<META NAME="keywords" VALUE="gardens, gardening, flowers, plants">

For a list of other types of META tags, refer to an HTML reference site or book.

 Don’t use the same keyword more than seven times; most Web search engines won’t 
catalog words repeated eight times or more. The keywords should add up to no more than 
1000 characters.
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Hard and soft paragraph returns

Pressing Enter when editing a page inserts a hard return (using the P tag), which inserts a blank 
line between paragraphs. Pressing Shift+Enter inserts a soft return (using the BR tag), which 
starts a sentence on the next line without inserting a blank line between paragraphs.

Working with comments, placeholders, and scripts
Comments are lines of HTML code that are ignored by the browser. Comments can be simple 
notes to yourself (such as “updated on May 10th”) or can be put to more sophisticated uses 
such as enclosing JavaScript, VBScript, or JScript code to protect it from browsers that don’t 
support that scripting language. 

You can prevent PageMill from examining—or changing—HTML code by using a special type 
of comment called a placeholder. This instructs PageMill to leave the enclosed HTML 
unchanged. Placeholders use two special comments in the HTML page: <!--NOEDIT--> and 
<!--/NOEDIT-->. 

When PageMill reads an HTML page, any text between these two comments is stored as a place-
holder, and PageMill doesn’t try to interpret that text. When View > Show Invisibles is chosen, 
a placeholder appears as an icon ( ) in Edit mode. 

Placeholders are useful for entering scripts—such as those written in JavaScript—that PageMill 
does not itself test or run. To prevent PageMill from parsing or altering the script, insert it in a 
placeholder. You can also use regular comments by placing <!-- on the line before the script 
begins and --> on the line after it. In either case, the script interpreter in the browser ignores 
the comments and will process the script as expected. 

You can type or edit the no-edit HTML code directly in the Inspector or in Source mode. You 
can also use the Inspector to have a custom image appear instead of the default icon, which lets 
you, for example, use one icon for JavaScript and another for other types of placeholders, such 
as a CGI counter.

To insert a comment:

1 In Edit mode, choose Insert > Comment. 

2 Choose View > Source Mode and type your comment after the <!-- and then end it with -->. 
For example, enter <!--This is a comment-->. When View > Show Invisibles is chosen, a 
comment appears as an icon ( ) in Edit mode.
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To insert placeholder code or a script:

In Edit mode (but not in Source mode), choose Insert > Placeholder and do one of the 
following:

• Select the placeholder icon ( ), display the Inspector, and then type the code or JavaScript 
into the scrollable text box.

• Choose View > Source Mode and type the code or JavaScript between <!--NOEDIT--> and 
<!--/NOEDIT--> comments.

Note: Only the body of a JavaScript goes into the placeholder. You must also enter the SCRIPT 
LANGUAGE tag into the HEAD tag for the script to work. Refer to a JavaScript reference book for 
more information.

To insert a counter in a placeholder:

1 In Edit mode, choose Insert > Placeholder.

2 Select the placeholder icon ( ) and display the Inspector (choose View > Show Inspector).

3 Enter the image tag or the URL to the CGI script for the counter that your ISP supplies.

4 Upload the document or site to the Web server (see page 164) to preview and test the 
counter.

To change the image of a placeholder icon:

1 In Edit mode, select the placeholder icon ( ) and display the Inspector.

2 Do one of the following:

• In the Object panel, click the File button below the Placeholder Image area, and locate and 
open a file. 

• Drag a file from a desktop folder window into the Placeholder Image area.

• Drag an image from a PageMill page or from another application into the Placeholder Image 
area.
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Entering special characters as entities
When you enter a character that’s not on the keyboard (see page 26), PageMill converts it to the 
corresponding HTML entity, a special character code that begins with an ampersand (&) and 
ends with a semicolon (;). You can also enter characters by typing the entity directly in HTML 
source code.

To enter an entity for a special character:

1 In Edit mode, click where you want the special character and then choose View > Source 
mode.

2 Type a character entity from the following list. Be sure to include the ampersand and the 
semicolon and to use lowercase or uppercase letters exactly as shown.

Entity Description

&#133; ... Ellipsis

&#145; ‘ Opening curved single quotation

&#146; ’ Closing curved single quotation

&#147; “ Opening curved double quotation

&#148; ” Closing curved double quotation

&#149; • Bullet

&#150; – En dash

&#151; — Em dash

&copy; © (copyright symbol)

&reg; ® (registration mark)

&cent; ¢ (cent sign)

&quot; " Quotation mark 

&amp; & Ampersand 

&lt; < Less than 

&gt; > Greater than

&Agrave; À 
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&Aacute; Á

&Acirc; Â

&Atilde; Ã

&Auml; Ä

&Aring; Å

&AElig; Æ

&Ccedil; Ç

&Egrave; È

&Eacute; É

&Ecirc; Ê

&Euml; Ë

&Igrave; Ì

&Iacute; Í

&Icirc; Î

&Iuml; Ï

&ETH; Uppercase Icelandic eth

&Ntilde; Ñ

&Ograve; Ò

&Oacute; Ó

&Ocirc; Ô

&Otilde; Õ

&Ouml; Ö

&Oslash; Ø

&Ugrave; Ù

&Uacute; Ú

&Ucirc; Û

Entity Description
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&Uuml; Ü

&Yacute; Uppercase Y with acute accent

&THORN; Uppercase Icelandic thorn

&szlig; ß

&agrave; à

&aacute; á

&acirc; â

&atilde; ã

&auml; ä

&aring; å

&aelig; æ

&ccedil; ç

&egrave; è

&eacute; é

&ecirc; ê

&euml; ë

&igrave; ì

&iacute; í

&icirc; î

&iuml; ï

&eth; Lowercase Icelandic eth

&ntilde; ñ

&ograve; ò

&oacute; ó

&ocirc; ô

&otilde; õ

Entity Description
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&ouml; ö

&oslash; ø

&ugrave; ù

&uacute; ú

&ucirc; û

&uuml; ü

&yacute; Lowercase y with acute accent

&thorn; Lowercase Icelandic thorn

&yuml; ÿ

Entity Description
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A HREF tag 100

absolute pathnames 75, 104

accented letters, entering 26, 178
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Adobe Photoshop 6
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of images with text 55
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table text 113

text 33, 174

Alternate Label option 61

AMIPro 27
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dragging and dropping 83

hiding 84

linking to 82

naming 82

animated GIF files 47

playing 61

animations

formats of 46

playing 61
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images 59

applets. See Java applets

Ask Before Accessing a New Server 
(option) 162

AU files 47

Audio Interchange File Format 48

automatic scrollbars in frames 142

Automatically Show Details 
When Loading a New 
Site (option) 156

AVI files 47

playing 61

B

Back button 20

Back in Frame option 147

Background Image area 72

adding page backgrounds 
with 70

backgrounds

color of link 14

setting for pages 13

using images as 70

base font size 36

base targets 145

BIG tag 174

BMP files

converted to GIF 50

image format 46

where converted files are 
stored 12

body text format 29

bold character style 34

borders

adding to an image 58

removing from an image 58

table 113, 117

BR tag 176

Bring to Front option 98

Browser Plug-ins folder 49, 61
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browsers

See also Internet Explorer; 
Navigator

border display 58

defined 1

differences in 4

displaying interlaced images 
in 58

dragging links from 78

font display in 36

frame display in 134, 136

image display in 6

image formats in 46

link display in 75

Navigator 48

plug-ins 48

resolution display in 6

table display in 107

text labels for images in 61

bulleted list format 31

C

captions 120

cascading

stylesheets 18

windows 21

case

mismatches in 162, 165

sensitivity 11, 178

cells. See table cells

CENTER tag 174

CERN server type 100

CGI 99

CGI scripts

and forms 121

and image maps 104, 105

associating with forms 131

defined 99

path to 104

character entities 178

character styles 33

applying 34

bold 34

for computer code 35

for computer messages 35

for titles 35

for variables in computer 
instructions 35

italic 34

logical 34
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plain 34

teletype 34

to emphasize selected text 34

underline 34

characters 178

entering special 26, 178

checkboxes in forms 122

checking spelling. See spell-
checking

circular hotspots, adding 97, 102

Citation character style 35

ClarisWorks 27

Clear command 26

client-side image maps

adding hotspots to 96

creating 96

default links in 97

defined 95

hotspot tools 96, 98

previewing 99

resizing 99

testing 99

closing

files 59

sites 153

windows 21

Code character style 35

Color Panel 37

customizing 40

hiding and showing 22

using 39

Web-safe colors in 38

Color pop-up menus

customizing 38

locations of 38

colors

changing text 40

customizing 38

dithered 6

hex values of 41

using in hotspots 98

using in pages 38

Web-safe 6

columns

adding and deleting in tables 111

joining 119

comments

inserting 176

showing 172

using 176

Common Gateway Interface, 
defined 99

Confirm move or rename 
operations (option) 159

constraining heights and widths

images 56

table cells 114

tables 114

context menus, defined 21
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converting

Excel data to tables 108

pop-up menus to list-selection 
fields 128

copying

images 50

links 91

text 28

correcting

broken links 91

errors in sites 160

counters in placeholders 177

Create ActiveX Controls in Edit 
Mode (option) 67

D

default colors

in Color pop-up menus 38

links 13

text 13

Default Details Mode area 156

default links

in image maps 97

defaults

home page 12

page 13

resource folder 12, 45, 165

saving 14

site 11

definition list format 32

deleting

columns and rows from 
tables 112

data from tables 112

frames 136

links 91

text 26

designing a page 3

DIB files 46

dictionaries 41, 42

directory list format 31

directory paths 104

defined 3

Display alert if bad image map
 files are found in the site 
(option) 153

Display alert if locked files are 
found in the site (option) 153

displaying

Color Panel 39

comments 172

HTML 172

Inspector 23

invisibles 173

Java console 64

Pasteboard 22, 86

Site Details window 156

tags 172

toolbar 22

dithered colors 6

DIV tag 174

do 59

documents

defined 1

domains

defined 3

downloading

estimating times for 163

images 6

pages from the Web 15

speed of 163

statistics 163

dragging and dropping

anchors 83

images 51, 70

into frames 137

links 77, 78

restrictions 51

text 28

duplicating form objects 122

E

Edit mode 19

editing

ActiveX controls 66

forms 122

frames 138

hotspots 98

in Image window 58, 60

in-place 96

links 90

out-of-place 101

sites 157

e-mail 76

formatting addresses 30

links to addresses 78

Emphasis character style 34

Enable ActiveX Controls 
(option) 67

Enable Java Applets (option) 64

entities, using 178

errors

and external files 162

case 162, 165

correcting in sites 160

Errors folder 151

and correcting errors 160

extensions, filename 10, 14, 46

Externals folder 151

and correcting errors 160

for viewing paths 161
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F

File 76

file formats

ActiveX controls 48

AIFF 48

animation 46

AU 47

AVI 47

BMP 46

DIB 46

GIF 46

image 46

Java applets 48

JPEG 46

MIDI 48

movie 47

MPEG 47

PDF 46

ProJPEG 47

QuickTime 47

Shockwave 46

sound 47

specifying preferences for 100

suffixes for 100

TIFF 53

unsupported 53

WAV 48

File Transfer Protocol 76

filenames

extensions for 10, 14, 46

naming 10

files

 file formats

closing 59

creating 160

deleting 160

downloading 5, 163

external 161

importing 27

inserting with ActiveX 66

moving 158

naming 10, 158, 164

opening 51

opening in other applications 15

printing 24

saving 59

finding 68

and replacing 69

in sites 69, 157

firewalls 87

folders

creating 160

deleting 160

Errors 151

Externals 151

local root 151

moving 158

naming 10, 158

resource 12, 45, 165

site name 151

structure for sites 12

WWW Links 151, 159

fonts

base size 36

changing 36

fixed-width 30

relative size 37

setting size of 174

Form panel 22

formats 28

See also tags

applying 28

for addresses 30

for bulleted lists 31

for definitions 32

for directory lists 31

for headings 30

for lists 30, 32

for menu lists 31

for numbered lists 31

for preformatted files 30

for terms 32

in HTML 7

in toolbar 33

paragraph 29

formatting

See also formats

table text 113

text 28

forms

adding 121

and form scripts 121, 131

associating scripts with 131

breaks in 130

checkboxes in 122

creating 121, 130

defined 121

editing 122

fields in 125

hidden fields in 126

list selection fields in 127

multiple 130

multiple selections in 129

naming text fields in 125

objects in 122

pop-up menus in 127

radio buttons in 123

Reset buttons in 129

resizing text fields in 125

Submit buttons in 129

text fields in 124
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Forward button 20

Forward in Frame option 147

Frame panel 22

frame source documents 134

frames

adding 133

adding content to 137

defined 133

deleting 136

editing 138

inserting pages in 137

layout of 138

links in 144

margins of 142

moving forward and 
backward in 147

naming 139

nested 135, 141

no-frames messages in 136

non-resizable 144

placing objects in 137

previewing 146

printing 144

resizing 140, 144

saving 137

scrollbars in 142

targeting 146

frameset documents 134

tags for 172

viewing the HTML code of 171

framesets

creating 136

defined 134

opening 137, 140

printing 144

saving 137

spell-checking 137

uploading 166

FTP 76

ftp_log file 166

G

General page in Preferences 
dialog box 19, 88, 172

GET option 131

GIF files 6

format 59

image format 46

opening 51

GIF image icon 52

globe icon 18

Gopher protocol 76

Graphics Interchange Format, 
defined 6

graphics. See images

H

hard space characters 25

header table cells 113

heading formats 30

height

changing horizontal rule 73

changing image 57

table 114, 116

table cell 114

hex value of a color 41

hidden fields

adding to tags 173

in forms 126

hiding

anchors 84

Color Panel 22

Inspector 23

invisibles 84

Java console 64

Java scripts 176

Pasteboard 22, 86

Site Overview area 154

tags 172

toolbar 22

Home button 20

home pages

defaults for 12

defined 2

horizontal alignment

table 113

text 33

horizontal rules 72

adding 72

resizing 73

shading 72

hotspots

client-side 96

defined 95

server-side 95, 101

HTML 171

adding anchors in 175

adding hidden fields to 175

adding margin breaks in 175

defined 3

entities 178

font size in 174

formatting in 7

graphics considerations 5

layout considerations 4

naming pages 10

page in Preferences 
dialog box 172

paragraph alignment 174

typographical considerations 5

viewing 172
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HTTP, defined 3

Hypertext Markup Language, 
defined 3

Hypertext Transfer Protocol, 
defined 3

I

illegal characters in filenames 10

image formats 47

image maps. See client-side image 
maps; hotspots; server-side 
image maps

Image window

adding images from 51

editing in 58, 60

opening files into 51, 101, 103

images

adding borders to 58

adding labels to 61

adding to pages 50

aligning with text 55

and non-graphic browsers 61

anti-aliasing 6, 59

as page background 70

color palettes in 6

copying and pasting 50

downloading 6

dragging and dropping 51, 
52, 70

duplicating 7

file size of 5

including in a page 6

inserting 48

interlaced 58

labeling 61

positioning 5

progressive 58

resampling 6

resizing 6, 56

resolution of display 6

resource folder for 45

scaling 57

thumbnail 6, 49

transparent 59

using in HTML documents 5

width of display 6

wrapping text around 55

importing

See also inserting

by copying and pasting 28

by dragging and dropping 28, 51

images, movies, and sounds 50

spreadsheets 27

text files 27, 28

with Open command 27

indenting text 33

index.html file 2, 12, 13, 152

inserting

See also importing

anchors 82, 175

browser plug-ins 49

columns and rows in tables 111

comments 176

contrasted with linking 50

counters in placeholders 177

forms 121

frames 135

hidden fields 173

images 50

links 76

margin breaks 175

objects 51, 66

pages in frames 137

placeholders 177

scripts 177

tables 108

with ActiveX 66

Inspector

adding page backgrounds 
with 70

changing color with 39

displaying panels in 22

hiding and showing 23

resizing frames with 140

resizing tables with 114

interlaced images, GIF 58

International page in Preferences 
dialog box 43

Internet Explorer

 browsers

Internet Service Provider, 
defined 1

invisible

anchors 175

fields 173

margin breaks 56, 175

invisibles, displaying 173

ISO Latin-1 27

ISP

address 168

CGI script from 121, 123, 177

defined 1

image map script default 
information 97

password setup 124, 164

questions to ask of 9

server-side image map 
information 100, 101, 104

URLs 164, 177

italic character style 34
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J

Japanese text 42

Java applets 48

Java console 64

Java scripts

running 176

joining table cells 119

JPEG files 6, 58

image format 46

opening 51

K

kerning 5

Keyboard character style 35

L

labels

adding to images 61

layouts 7

maintaining in HTML 7

of frames 138

using tables as tool for 107

leading 5

letter spacing 5

line breaks 4, 5, 30, 56, 100

Link To bar

See also links

entering image map 
location in 104

entering links in 78

viewing links in 89

Link view 151

linking

contrasted with inserting 50

to an anchor 82

to same page 83

to text or images 77, 78

to URLs 75

to Web pages 76, 78

using Pasteboard 86

links

adding 78

appearance of 75

broken 93, 160

colors in 14, 38

copying 91

creating 76, 78

default for client-side image 
maps 97

default for server-side image 
maps 99

defined 8

deleting 91, 159

dragging and dropping 77, 78

editing 90

finding 68

fixing 92

frequently used 86

keeping valid 92

maintaining 45

moving 90

opening in frames 145

opening in windows 145

planning 9

previewing 19, 87

selecting 90

storing on Pasteboard 86

targeting in frames 144

testing 87

to image files 45

to objects 52

to PDF files 81

turning off display 103

using Link To bar 78, 165

viewing URL for 89

list format 30

List view 150

sorting 155

lists

creating 31

nested 32

list-selection fields 
in forms 127, 128

local aliases 84

for remote resources 100

for server-side image maps 100

setting up 84

viewing 85

Local Links option 20

local root folders

defined 12

location of 100

setting up 12

site 151

log files 166

logical character styles, defined 34

Lotus 1-2-3 27

M

Macromedia Shockwave 46

making progressive 58

maps. See client-side image maps; 
server-side image maps

margin breaks

adding to tags 175

inserting 56

marking up text, with tags 3

menu list format 31

menus

plug-in 24

pop-up 127, 128
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right-click 21

site selection 21

messages

alert 158, 162

in frames 136

META tags, adding 175

Microsoft Excel 27

creating tables from 108

Microsoft Word 27

MIDI files 48

modes 18

See also Edit mode; Preview 
mode; Source mode

monospaced

format 30

text 34

movies

adding to pages 50

animated GIF 47

AVI 47

file formats for 47

MPEG 47

playing 61

QuickTime 47

Shockwave 47

MPEG files 47

multiline text fields in forms 125

N

naming files 10

Navigator

See also browsers

dragging links from 78

plug-ins 48

NCSA 100

nesting

frames 135, 141

lists 32

tables 119

New Page command 13

New Site command 13

New Window option 20

no-frames messages 136

Nppdf32.dll file (PDF plug-in) 49

numbered list format 31

numeric entities 178

O

Object panel 22

Object Size search option 68

objects

aligning 55, 174

downloading 163

finding 68

form 122

linking to 52

replacing 69

uploading 166

Open as Site in PageMill 
command 152

Open command 15

importing with 27

Open Pages In (pop-up menu) 20

Open Pages with Toolbar Shown 
(option) 22

Open Remote Links Using 
(option) 88

opening

files 51

files in other applications 15

into Image window 51

links 145, 146

pages 14, 20, 172

remote links 88

sites 17, 151

P

P tag 174, 176

padding table cells 118

page names 3, 10

Page page in Preferences 
dialog box 13

Page panel 22

PageMill 21

PageMill Preview mode 18

PageMill_Resources folder 12, 
45, 161

pages

adding images to 50

adding movies to 50

adding sound to 50

background color and pattern 
for 13, 38

colors in 37, 39

creating 13

creating framesets in 136

defaults for new 13, 20, 22

defined 1

designing 3

determining the appearance of 7

downloading 163

finding 68

inserting in frames 137

links to 8

maintaining layout of 7

moving between 20

naming 10

opening 14, 20, 172

planning 9

preserving layout of 7

printing 24

resource folder for 12

saving 14

titles for 17
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unreferenced 92

uploading 166

using images as 
backgrounds in 70

viewing 17

viewing preferences for 19

paragraph formats. See formats

paragraphs

See also text

aligning 174

spacing of 5, 7, 176

password fields in forms 124

Pasteboard 86

and linking 86

hiding and showing 22, 86

moving objects to and from 86

pasting 91

images 50

links 91

text 28

pathnames 3

absolute 75, 104

relative 76, 104

PDF ActiveX control 80

PDF file

plug-in needed for viewing 49

PDF files 7

in Acrobat 82

linking to 81

read-only alert messages 
about 153

thumbnails of 81

pen-and-paper icon 19

photographs and JPEG 
format 46, 47

physical character styles, 
defined 34

placeholders 177

placing. See inserting

plain character style 34

playing sounds and movies 61

plug-ins

in Browser Plug-ins folder 48

PageMill 24

polygonal hotspots

adding 97, 102

pop-up menus in forms 127, 128

Portable Document Format files, 
defined 7

POST option 131

postal addresses, formatting 30

preferences

active content 64, 67

case sensitivity 11, 178

format 100

general 19, 88, 172

home page 12

HTML 172

international 43

page 13

resources 11, 45, 100, 165

saving 14

server 84

site 11, 12, 45, 153

switch to 16

preformatted format 30

Preview mode

defined 18

Internet Explorer 18

PageMill 18

switching between PageMill and 
Internet Explorer 20

previewing

defaults for 19, 172

frames 146

interlaced images 58

links 19, 87

remote links 87

printing

files 24

frames and framesets 144

ProJPEG files 6, 47

creating 58

properties

using the Inspector 22

viewing site 156

protocols, defined 3

Q

question mark icon 173

QuickTime files 46, 47

R

radio buttons in forms 123

read-only alert messages 153

rectangular hotspots

adding 97, 102

relative font size 37, 174

relative pathnames 76, 104

Reload Applets When Switching to 
Preview Mode (option) 64

removing. See deleting

replacing. See finding

resampling images 6

Reset buttons in forms 129

resizing

frames 140, 144

horizontal rules 73

images 6, 56

list-selection fields 129

table cells 114

tables 114
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text fields in forms 125

resource folder 12, 45, 165

for images 45

for pages 12

for sites 12, 161

Resources page in Preferences 
dialog box 11, 45, 100, 165

Revert to Saved command 15

Rich Text Format (RTF) 27

right-click menus 21

changing URLs 159

in sites 152

sorting Link view 154

switching Preview modes 20

targeting links 88

viewing aliases 85

root folders. See local root folders

rows

adding to tables 111

deleting from tables 111

joining 119

Run Applets in Edit Mode 
(option) 64

running

ActiveX 67

Java applets 63

Java scripts 176

movies 61

S

Sample character style 35

Save Automatically Before 
Previewing in Internet 
Explorer (option) 20

Save selection using HTML 
comment tags (option) 172

saving

defaults for 14

files 59

frames and framesets 137

pages 14

when switching Preview 
modes 20

scaling images 57

scripts

inserting 177

scripts. See CGI scripts; Java scripts

scrollbars in frames 142

search engine, adding 
keywords for 175

searching. See finding

secure newsgroup 76

secure World Wide Web 
connection 76

Send to Back option 99

server 105

Server page in Preferences dialog 
box 84

server requirements

determining 9

server-side image maps

creating 99

defined 95

drawing tools in 101

hotspots in 101, 103

image map file for 99

information needed for 99

linking 99, 100, 103

map file location 104

map formats 100

marking as 104

NCSA server 104

testing 105

turning off link display in 103

shading

horizontal rules 72

Shockwave files 47

showing

Color Panel 39

comments 172

HTML 172

Inspector 23

invisibles 173

Java console 64

Pasteboard 22, 86

Site Details window 156

tags 172

toolbar 22

shuffling hotspots 98

single-line text fields in forms 124

Site Details toolbar 152

Site Details window

and correcting errors 160

defaults for showing 156

site name folder 151

Site Overview area 150

hiding 154

Site page in Preferences 
dialog box 12, 45, 153

Site Resources Folder Name 
text box 162

Site Selection submenu 21

sites

alert messages in 153

building 9

closing 153

correcting errors in 160

creating 152

defined 2, 17, 149

designing 9

editing 157

finding in 157

loading 17, 152
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managing 11, 149

naming 152

opening 17, 151

organizing pages in 17

publishing 2

resource folder for 12, 161

sorting Link view of 154

sorting List view of 155

spell-checking 158

structuring 10

uploading 164

viewing 154

SMALL tag 174

sorting

Link view 154

List view 155

sounds 47

adding to pages 50

AU 47

Audio Interchange 
File Format 47

MIDI 47

playing 61

WAV 47

source code. See tags

Source mode 172

Source Mode command 173, 178

spaces

entering multiple 25

in filenames 165

spacing

changing table cell 118

special characters

entering 26, 178

spell-checking 41

determining scope of 42, 158

framesets 137

sites 158

site-wide 42, 158

tags 173

spelling dictionaries 41

splitting table cells 119

spreadsheets

importing 27

statistics, download 163

status bar

hiding and showing 22

Strong character style 34

structuring sites 10

stylesheets

cascading 18

Submit buttons in forms 129

suffixes for file formats 100

Switch To page in Preferences 
dialog box 16

switching modes 19

saving pages when 20

T

table cells

aligning contents of 113

changing height and 
width of 114

creating headers for 113

deleting 113

formatting 113

joining 119

padding 118

selecting 109, 110

spacing 118

splitting 119

word wrap in 115

tables

adding columns and rows to 111

aligning 174

aligning text in 113

as layout devices 107

borderless 107

borders of 113, 117

captions for 120

changing height and 
width of 114, 116

creating 108

deleting data from 112, 113

dynamic 115

entering data in 112

fixed-width 115

formatting 113

nested 119

resizing 114, 116

selecting 109

word wrap in 115

tabs 5

tags

See also formats

adding 171

anchor 175

color-coded 171

comment 172

defined 3

editing page 173

finding site 173

font size 174

hidden field 175

hiding 172

margin break 175

paragraph alignment 174

paragraph return 176

showing 172

spell-checking 173

unknown 14
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viewing 171

targets

base 145

overriding 146

telephone numbers, formatting 30

teletype character style 34

Telnet protocol 76

term list format 32

testing

image maps 99

links 87

text

See also paragraphs

adding 26

alignment 33, 55, 174

color in 13, 38

computer code 35

computer message 35

deleting 26

dragging and dropping 28

entering 25

fields in forms 124

finding 68

formats 28

importing 27

indenting 33

Japanese 42

monospaced 34

table cell 113

word wrap in tables 115

wrapping around images 55

Text Color pop-up menus 38

thumbnails

defined 6

PDF 81

using for images 49

TIFF files 53

tiling windows 21

Title pop-up menu 20

titles 17, 35

toolbars

hiding and displaying 22

tracking 5

transparency 59

Treat Case-Sensitive URL 
Differences as Errors 
(option) 162, 165

Treat Missing Externals as Errors 
(option) 162

typing special characters 178

typography and HTML 5

U

underline character style 34

Uniform Resource Locators, 
defined 75

Unrecognized HTML text box 173

unsupported tags 3

uploading

adjusting settings 167

advanced connection settings 
for 169

files to ignore when 168

framesets 166

log files 166

objects 166

single pages 166

sites 164

to Web servers 161

URLs 3

absolute 75, 104

case mismatches in 162

changing for WWW links 159

creating links to 75

defined 2, 75

entering into Link To bar 78

finding 68, 157

relative 76, 104

remote 52, 78

secure connection 76

viewing in Link To bar 89

Use CLASSPATH Environment 
Variable (option) 64

Usenet newsgroup 76

user dictionaries 41

V

Variable character style 35

verifying

links 87

WWW links 87

vertical alignment

table 113

Viewer Resizable option 144

viewing

frameset documents 171

HTML 172

Inspector 23

pages 17

Preview mode 17

toolbar 22

Visited Link Color option 14

W

WAV files 48

Web addresses 2

Web clients, defined 1

Web servers

defined 1

naming files on 164

uploading to 161

Web sites. See sites
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Web-safe colors 6

Whole Word search option 68

width

changing horizontal rule 73

changing image 57

frame 140

table 114, 116

table cell 114

windows

controlling display 21

moving to front 22

opening links in 145

word spacing 5

word wrap

adding, in text fields 25

preventing in tables 115

WordPerfect files 27

World Wide Web

defined 1

secure connection 76

wrapping text

around images 55

in multiline text fields 126

WWW Links folder 151, 159
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