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Welcome to PageMill

Welcome to Adobe® PageMill®—the easiest-to-use page-authoring and site 
management tool for the World Wide Web. With PageMill, you can enter 
and preview text, images, animations, sounds, frames, forms, tables, and 
links on a Web page. You can drag and drop images, objects, and links 
directly onto a Web page, and apply standard HTML formats and styles 
to text without typing HTML code. (But if you want to enter HTML code, 
you can do that too.)

In addition to working with single pages, you can work with entire Web 
sites (sets of linked pages). PageMill provides integrated site management 
features that help you keep a site error-free. When your site is ready, you 
can upload it to a Web server from within PageMill.

Before using PageMill, you should have a working knowledge of your 
computer and Microsoft® Windows® 95 or Windows NT®. For example, 
you should know how to use the mouse and standard menus and 
commands. You should also know how to open, save, and close files. If 
you need to review these techniques, see the documentation that came 
with your computer.

PageMill package contents

The PageMill package includes the following software and documen-
tation:

• The program CD, containing installer software, PageMill program files, 
online Help files, the PageMill User Guide (a printable version of Help), 
sample files, and other software and files that you can use with PageMill

• Adobe PageMill Getting Started (the manual you’re reading now)

• Registration card
1Welcome to PageMill
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Registration

So that Adobe can keep you informed about new PageMill developments 
and offer you technical support, please register your software. You can 
register online after installing the program, or register by mail using the 
enclosed registration card.

Installing and starting PageMill

Before using PageMill, you must install it onto your hard disk.

To install PageMill:

1 Exit all programs that run in Windows, and turn off virus-protection 
software. (After installation, you can turn on the software.)

2 Insert the PageMill CD into your CD-ROM drive and then do one of the 
following:
• If the autorun feature is enabled on your system, choose the region 
where you are located now and click Next. Then click Install Adobe 
PageMill 3.0 and continue with step 3. 

• If the autorun feature is disabled on your system, open the CD folder 
and double-click Install.exe. Then continue with step 4. 

3 Read the software license agreement and click Accept to accept the 
terms of the agreement.

4 Choose the region where you are located now and click Next.

5 Review the Welcome screen and click Next, and then click Yes to 
confirm your acceptance of the software license agreement. 

6 Specify the setup: 
• Select Typical to install the most common options.
eMill Getting Started



                       
• Select Custom to choose the options you want to install. The installer 
displays the amount of disk space required to install each set of program 
files, the total amount of disk space required for the selected files, and 
the amount of available disk space. Select the desired files and click Next.

• If you do not want to install PageMill in the preset installation folder, 
click Browse. Then enter the pathname of a different folder or select a 
folder.

7 Click Next.

8 Enter the requested user information and then click Next. (Type the 
serial number exactly as it appears on the registration card, including the 
hyphens.) 

9 Review your user information and click Yes to confirm it.

10 Click Next to confirm your selections and to begin the installation.

11 Do one of the following:
• If you want to register PageMill online, leave the online registration box 
checked and click Finish. Then follow the on-screen instructions. (If your 
modem is already in use, disconnect from your Internet Service Provider 
before registering.)

• If you want to register PageMill by completing and mailing the regis-
tration card in your package, click the online registration box to remove 
the check mark and then click Finish.

To start PageMill:

Choose Start > Programs > Adobe > PageMill 3.0 > Adobe 
PageMill 3.0.

Troubleshooting problems with installation and 
starting

If you encounter a problem, read the information in this section. Often, 
calling technical support will be unnecessary.
3Welcome to PageMill
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If you can’t install PageMill, try the following steps:

• Verify that you have the minimum system requirements to install and 
start PageMill, as listed on the box. 

• Make sure you are not trying to install PageMill 3.0 into a folder that 
contains PageMill 2.0. Installing both versions in the same folder is not 
recommended.

• Turn off virus-scanning software and other autorun programs. Then 
restart your computer (hold down Shift to prevent autorun programs 
from starting) and try to install PageMill again.

• Copy the installer folder to the hard disk. Then restart your computer 
in Safe mode (Windows 95) or in VGA mode (Windows NT) and try to 
install PageMill from the hard disk. See Windows Help for instructions on 
starting in Safe or VGA mode.

If you can’t start PageMill, try the following steps:

• Open the Readme file in the folder where PageMill was installed. This 
file has late-breaking information and may contain important trouble-
shooting tips.

• Make sure that you are not running PageMill 2.0 when you try to start 
PageMill 3.0. You can’t run the two versions at the same time.

• Make sure there is enough memory available to run PageMill. Close 
other applications and windows and then try again.

• Try to start PageMill in Safe mode (Windows 95) or in VGA mode 
(Windows NT), following instructions in Windows Help. If PageMill runs 
in Safe or VGA mode but not in the standard mode, there may be a 
conflict with system software, such as video card drivers. Download and 
install the latest version of the driver software for your video card, and 
then try to start PageMill again.
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Learning PageMill

Work through the tour in this guide to become familiar with the basics of 
creating a Web site and developing pages. Installing PageMill CD copies 
the sample files you’ll use as you complete the tour.

For complete information about using PageMill (and some basic infor-
mation about the World Wide Web), see the comprehensive online Help. 
Help topics include more detail than this printed guide, and are always 
immediately available. You can also use Adobe Acrobat® Reader to view 
or print the User Guide, a Portable Document Format (PDF) version of 
Help, from the PageMill CD. Online Help is accessible in several ways.

To locate a Help topic in the online table of contents:

Press F1 to start online Help, click the Contents tab, and then double-click 
a book icon to see the topics listed within it. Double-click to select a topic.

To locate a Help topic in the online index:

Press F1 to start online Help, click the Index tab, and then follow the 
on-screen directions.
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To find a specific word or phrase in online Help:

Press F1 to start online Help, click the Find tab, and follow the on-screen 
directions. If you are using Find for the first time, the Find Setup Wizard 
appears. Follow the on-screen directions to specify the search capabilities.

To get context-sensitive Help:

Do one of the following:

• Click the Help button in a dialog box.

• Press Shift+F1 and then click the item you want help on.

To get Help on menu commands or toolbar buttons:

Do one of the following:

• Highlight a menu command (but don’t choose it) and look at the status 
bar at the bottom of the PageMill window.

• Point to a toolbar button (but don’t click it) and wait for the tool tip.
eMill Getting Started



               
A Quick Tour of PageMill

This hands-on overview will get you up and running with PageMill. It 
includes some key tasks you’ll do as you create and manage your own 
Web site. As you work through the tour you’ll see suggestions for learning 
more about a topic and where to find that topic in PageMill online Help.

Creating a Web site

You can use PageMill to open individual Web pages or an entire Web site. 
Opening a Web site enables PageMill to manage the links between the 
files in the site, ensuring that the links will work properly when the site 
is published on the World Wide Web.

You’ll begin the tour by starting PageMill and loading the practice site 
located in the Tour folder. This site contains several Web pages and 
images. Before you start the tour, you may want to make a copy of the 
Tour folder in case you want to go through the tour a second time. (If 
someone has already taken the tour and changed the files in the Tour 
folder, you can reinstall the folder from the CD. Follow the instructions on 
page 2 and in step 4, choose Custom and select only the Tour folder.)

1 Start PageMill (see the instructions on page 3). The program opens 
with a blank page.

2 Close the blank page by choosing File > Close.

3 Choose Site > New and then enter MySite in the Name text box.

4 Click the Browse button to navigate to the Tour folder in the 
PageMill 3.0 folder. Notice that the Location text box displays the path to 
this folder on your hard drive. Then click OK.
7A Quick Tour of PageMill
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5 Click Create. The Site Overview area opens on the left side of the 
PageMill window, and the Site Details window opens on the right side. 
(The Inspector palette may also appear; you can close it if you like.)

The Site Overview area shows the hierarchical structure of a Web site and 
the folders, files, images, and objects within the site. The area contains 
the Tour folder (which holds the Web pages and images in this practice 
site) and lists of errors, external links, and World Wide Web links in the 
site. You’ll learn more about these special lists later. 

The Site Details window contains more information about files and links 
in the site. You won’t need this window until later in the tour.

6 Close the Site Details window.

7 In the Site Overview area, double-click the Tour folder or click the plus 
sign (+) next to it to expand the view of the site’s contents. You can use 
the Site Overview area to open your site’s Web pages and images.
eMill Getting Started



      
8 Double-click Home.html. This is the site’s home page—the first page 
that visitors to your site will see. You’ll examine the home page in a 
minute, but first you’ll hide the Site Overview area.

9 Click the arrow button ( ) at the top left of the Site Overview area. 
This button toggles the display of the Site Overview.

Previewing pages

You can work in Web pages in either Edit or Preview mode. In Edit mode, 
you create pages by entering text, inserting images, and creating links. In 
Preview mode, you can test links and see how your pages will look in a 
Web browser. You can preview your pages by using a built-in PageMill 
Preview mode, or you can set an option to use Microsoft Internet 
Explorer™ 3.0 or later (if installed) to preview your pages within PageMill. 

To change between Edit and Preview modes, you click the Mode button 
at the right side of the toolbar. 

1 Click the Mode button a few times to switch between the two modes. 
Notice that the icon on the button changes to indicate the current mode.
9A Quick Tour of PageMill
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2 Right-click the Mode button and choose Internet Explorer from the 
context menu that appears. If Internet Explorer is installed, the page is 
now previewed by using a version of Internet Explorer within the PageMill 
application window. The icon on the Mode button icon also changes.

   
Edit mode, Preview mode (PageMill), and Preview mode (Internet Explorer)

The home page was laid out by using a table. That’s how the page 
designer created the multicolumn effect. When you are in Edit mode, the 
dotted grid lines you see are the table cell borders. Later you’ll lay out a 
page by using a table. 

Exploring links

Most Web pages contain links, special objects or text that take you to 
another location when you click them.

1 Right-click the Mode button and change to PageMill Preview mode. 
Then move the pointer over the underlined text Order Form near the 
bottom of the page. The underline indicates that the text is linked. 

As you move the pointer over the underlined text, the pointer changes to 
a hand and the destination of the link appears in the Link To bar at the 
bottom of the window.
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2 Click the underlined text. The destination page, Order.html, opens (to 
check its filename, look in the title bar of the PageMill window).

3 In the Order.html window, click the Back button in the toolbar to return 
to Home.html.

4 Click the Title pop-up menu in the toolbar to see a list of the Web pages 
that you have viewed in PageMill preview mode. You can use the list to 
retrace your steps and open previously visited pages in the site. For now, 
don’t choose a page from the list.

5 Choose File > Close to close the home page. Don’t save any changes 
you may have made while you were looking at the page.

Creating pages and adding a background image

Now you’re ready to create a page and work with text.

1 Click the arrow button at the upper left to redisplay the Site Overview 
area.

2 In the Site Overview area, right-click the Tour folder and then choose 
New Blank Page. A new file appears under the Tour folder, with the 
filename NewPage.html. NewPage is selected to make it easy to change 
just this part of the filename. (Be sure not to select the extension .html.)

3 Type Plants and press Enter. The page name changes to Plants.html.
11A Quick Tour of PageMill
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4 Double-click to open the page, and then click the Mode button at the 
upper right to change to Edit mode. 

Notice that the page icon appears to the left of the Title text box. You’ll 
use this icon later to create links.

5 Select the contents of the Title text box, type Plants Catalog, and press 

Enter. Plants Catalog is the name readers will see in the title bar of their 
Web browsers. A title can contain spaces and any other characters except 
quotation marks (unlike a filename, which should contain only alphanu-
meric characters, underscores, and hyphens).

Next, you’ll display the Inspector, a floating palette that provides a conve-
nient way to view or change settings for page elements. The Inspector 
includes tabbed panels containing properties for frames, pages, forms, 
and objects. The appropriate panel is available for the type of element you 
select. If more than one panel of properties could apply, you can click a 
tab to display a different panel.
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6 If the Inspector is not already visible, choose View > Show Inspector.

A. Frame tab B. Page tab
C. Form tab D. Object tab

The Page panel currently appears in the Inspector. In this panel, you can 
set the default color for a page’s text, colors for links, and a color or an 
image for the page background. For this page, you’ll use an image to add 
a pattern for the background.

7 In the Site Overview area, double-click the Images folder (or click the 
plus sign next to it) to expand the view of its contents. Then drag the 
image file named Bkgrd.gif into the Background Image area at the bottom 
of the Inspector. The pattern appears on the page.

8 Click the arrow button in the upper left to hide the Site Overview area. 
If the Inspector obscures your view of the page, drag it out of the way.

A B C D
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Typing and formatting text

Now you’ll type and format text on the page, starting with the headings.

1 Click in the page and type Plants (don’t press Enter yet).

2 In the toolbar, click the Center Align Text button ( ). 

3 Choose Larger Heading from the Format pop-up menu in the toolbar.

4 Press Enter and type Our collection includes (the line retains the 
formatting of the previous line, but you’ll change it).

5 In the toolbar, choose Paragraph from the Format pop-up menu and 
then click the Left Align Text button ( ).

6 Press Enter, type Herbs, and then choose Large Heading from the 
Format pop-up menu in the toolbar.

7 Press Enter and choose Bullet List from the Format pop-up menu in the 
toolbar. Then type Rosemary, Oregano, and Sage, pressing Enter after 
each item.
eMill Getting Started



8 Type Vegetables and then choose Large Heading from the Format 
pop-up menu in the toolbar.

9 Press Enter and then choose Bullet List from the Format pop-up menu.

10 Type the names of three favorite vegetables. Press Enter after the first 
two names, but not after the third.

Next, you’ll specify a font for the text on this page. To see your pages 
displayed with fonts other than the default fonts for their Web browsers, 
your readers must use browsers that support the HTML font attribute—
and they must have those fonts installed. 

11 Choose Edit > Select All, and then choose a font from the Font pop-
up menu in the toolbar. Use a font that your readers are likely to have 
installed, such as Arial.

Finally, you’ll right-indent the text on the page.

12 With all the text still selected, click the Indent Right button ( ) on 
the toolbar and then click anywhere on the page to deselect the text.

13 Choose File > Save Page.
15A Quick Tour of PageMill
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There are many more ways you can format text. For example, you can 
apply color to text or make the font size larger or smaller. For full details, 
see the topics under “Working with Text” in online Help.

Adding images

You can easily add images and multimedia objects to your Web pages. In 
this section, you’ll practice a few ways to work with images in PageMill. 

You’ll work only with GIF images in this tour. (When setting up your own 
Web pages, you should use GIF files for line art only, and use JPEG files 
for photographs and scanned images.) For details on working with JPEG 
images, movies, sounds, Java applets, and ActiveX™ controls, refer to 
“Adding Images and Multimedia Objects” in online Help.

1 Display the Site Overview area by clicking the arrow button at the 
upper left (just to the left of the toolbar). The contents of the Tour folder 
should be showing; if they are not, double-click the Tour folder.
eMill Getting Started



2 Double-click Home.html to open it.

Next, you’ll copy the image you’ll use as a page banner from the home 
page to the PageMill Pasteboard. The Pasteboard provides five tabbed 
panels, which are convenient places to store images and links that you’ll 
use many times as you build your site. Items remain on the Pasteboard 
after you exit, so they’re available the next time you start PageMill.

3 Choose View > Show Pasteboard. You may have to drag the title bar 
of the Pasteboard to move it so that you can work in both the page and 
the Pasteboard.

4 Make sure that you’re in Edit mode and then select and drag the Earth 
and Ware banner image from the top of the home page to the Pasteboard. 
This copies the image there.

Now you’re ready to add the banner image to the page that you created 
earlier.
17A Quick Tour of PageMill
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5 Press Control+Tab to bring the Plants.html file to the front (or open it 
if you closed it). Control+Tab cycles through the open windows and is a 
convenient way to switch quickly between them. 

6 Click in front of the word Plants and press Enter.

7 Hold down Control and drag the banner image from the Pasteboard to 
the top of the Plants.html page, right above the word Plants. (If you don’t 
hold down Control when you drag, the image is moved rather than 
copied.)

8 Choose View > Hide Pasteboard.

Making parts of an image transparent

Now you’ll add another image to the Plants.html page and use a tool in 
the Image window to make part of it transparent.

1 In the Plants.html window, click to the right of the banner image (you 
may have to enlarge the window before clicking). Then press Enter to 
position the insertion point.

2 Choose Insert > Object > Image. Select the Leaves.gif file in the 
Tour\Images folder, and click Place.
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3 Hold down Control and double-click the image to open it in the Image 
window. 

You can make the image blend into the page by giving it a transparent 
background. 

4 In the left side of the Image window, click the Make Transparent tool 

( ), and then click the white background of the image. The background 
turns gray to indicate transparency.

Original background and with transparency applied

5 Choose File > Close to close the Image window. At the prompt, click 
Yes to save the changes.
19A Quick Tour of PageMill
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6 Choose File > Save Page to save Plants.html, but don’t close it.

You probably noticed that there were many other tools in the Image 
window. Most of these are for working with image maps, images that 
contain clickable, linked areas. This tour doesn’t cover image maps, but 
you can learn all about them by reading “Creating Image Maps” in online 
Help.

Creating links

A link takes you from one location (the source) to another (the desti-
nation). The destination can be on the same page, on another page in 
your Web site, or somewhere else on the Web. The link can be either text 
or a graphic.

One way to create a link is by dragging the page icon from the destination 
page onto a selection on the source page. You’ll do that next.

1 Return to the Home.html page (you can press Control+Tab again) and 
double-click the word PLANTS at the top of the page to select it.

2 Choose Window > Tile Vertically to show the Home.html and 
Plants.html windows side by side. You want both the selected text on the 
source page (Home.html) and the page icon ( ) of the destination page 
(Plants.html) to be visible. 
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3 Drag the page icon from the Plants.html window onto the selected text 
in the Home.html window. The selected text becomes underlined and the 
color changes, indicating that it is now linked to Plants.html. 

Next, you’ll copy and paste a link. You can paste a link from one page to 
another or to a different place on the same page.

4 Maximize the Home.html window and select the entire paragraph near 
the bottom of Home.html that includes the order form link. Then choose 
Edit > Copy.

5 Press Control+Tab to display the Plants.html page. Click at the end of 
the last bulleted item on the page, and press Enter.
21A Quick Tour of PageMill
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6 Choose Paragraph from the Format pop-up menu, and then choose 
Edit > Paste. The link is duplicated where you pasted

Another way to create a link is to enter the links’s address—its Uniform 
Resource Locator (URL)—in the Link To bar the page. Linking by typing 
a URL is useful when the destination page is at an external Web site or 
when you link to other Web resources (such as e-mail). You’ll use this 
technique to link to a page outside your Web site.

7 Press Control+Tab to display the Home.html page, and then select 
Adobe Systems Incorporated in the last paragraph.

The URL of the Adobe web site is http://www.adobe.com. You’ll use a 
Tab key shortcut to enter the first part of the URL. (You can also use the 
Right Arrow key instead of Tab, and use shortcuts for other parts of a 
URL.)

8 Click in the Link To bar at the bottom of the window, type h, and press 

Tab. This enters http:// in the text box. Then type www.adobe.com.

URL in the Link To bar

9 Press Enter. The selected text becomes a link, indicated by underlining 
and the changed color of the text.

10 Save the page and click the Mode button to switch to Preview mode. 

11 Test the links that you just created by clicking them. 

To test the link to the Adobe Web site, you must be connected to the 
Internet. You must also be using Internet Explorer Preview mode, or you 
must have specified another browser, such as Netscape™ Navigator, by 
setting an Open Remote Links preference (see “Testing and verifying 
links” in online Help for information).
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12 Close Plants.html and Home.html, and save Plants. html when 
prompted.

PageMill lets you create links in many ways besides the ones you used 
here. For example, in addition to copying and pasting, you can select a 
link and drag a copy to a new location.You can also use the Pasteboard to 
temporarily store a link—as you did earlier with an image. For full infor-
mation on links, see “Working with Links” in online Help.

Inserting a table

You can include tables in your Web pages to organize information by rows 
and columns. Tables can contain text, images, and other objects, 
including other tables. As you’ll see, tables are also useful for laying out 
pages.

First, you’ll insert a table.

1 In the Site Overview area, open the Tools.html file in the Tour folder by 
double-clicking the file.

2 Make sure you’re in Edit mode. (If necessary, click the Mode button at 
the right of the toolbar.) Then click after the word Tools and press Enter. 
This is where you’ll insert the table.
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3 In the toolbar, click the Insert Table button ( ), and then enter 2 in the 

Rows text box and 2 in the Columns text box. Leave the other settings at 
their default values and click OK.

Before you enter information in the table, you’ll select the cells and set 
their alignment. You can select cells by dragging, but this time you’ll use 
keyboard shortcuts.

4 Click in the upper left cell to place the insertion point and then press 
Control+9 to select the cell. 

5 Shift-click the lower-left cell to extend the selection. A black line 
around the cells indicates they are selected. The thick dashed line around 
the table indicates that you’re working in the table, with either an 
insertion point in a cell, or with one or more cells selected. (Later you’ll 
see how to select the entire table.)

When cells are selected, the Table Cell properties appear in the Inspector.
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6 If necessary, choose View > Show Inspector.

7 In the Inspector, select Center for horizontal alignment.

Adding images and text in table cells

Images of tools will go into the left column, and text will go into the right 
column. 

1 Click in the upper left cell of the table. and then click the Insert Object 
button ( ) in the toolbar. 

2 Select the Tincan.gif file in the Tour\Images folder and click Place. The 
watering can image appears in the cell. 

Each cell in a newly inserted table contains a nonbreaking space (because 
when a cell is a completely empty, it does not have a visible border). 
When you add text and images, you can delete the space so that the 
contents align properly.

3 Delete the space to the right of the image.

Next, you’ll drag a graphic from the Site Overview area into a table cell.
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4 In the Site Overview area, double-click the Images folder to show its 
contents and then drag the Trowel.gif file to the lower-left cell in the table.

5 Delete the space to the right of the image.

Now you are ready to type and format text in the cells.
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6 Click in the upper right cell and delete the space in the cell. Then 
choose Large Heading from the Format pop-up menu in the toolbar. 

7 Type Watering Can and press Enter. 

8 Choose Small Heading from the Format pop-up menu, type Made of 

galvanized steel, and press Enter.

9 Type the can’s product code number: T333

10 Select the contents of the cell by dragging across all the text, and then 
click the Center Align Text button ( ).

You can use the text formatting in this cell for the next cell by copying the 
formatted text and then replacing it.

11 Choose Edit > Copy, click in the lower right cell, and then delete the 
space in the cell.
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12 Choose Edit > Paste and then edit the pasted text as shown in the 
illustration.

Formatting the table

To improve the look of the page, you’ll adjust the size of the cells and 
remove the border.

1 Click in the upper left cell and press Control+9 to select the cell.
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2 Move the pointer over the right border of the selected cell until the 
pointer changes to a double arrow ( ). Drag the border to the left to 
narrow the column width, so that the column is only slightly wider than 
the images.

3 Press Control+9 again to select the entire table. When an entire table 
is selected, it has a thin border with handles and there is no thick, dashed-
line border.

4 If the Inspector is not visible, choose View > Inspector. When a table 
is selected, the Table properties are visible in the Inspector.

5 Change the value in the Border text box to 0 and press Enter. This 
removes the borders from view. Using a table without borders is one way 
to achieve a column layout.

6 Save the page and then switch to Preview mode to see the result. 

7 Close the page when you’re finished.

You can do many more things with tables. For example, you can constrain 
a table to be a certain size, place a table within another table, and join 
cells for special effects. For details and for information on how tables 
appear with different browsers, see “Adding Tables” in online Help. 
29A Quick Tour of PageMill



30 Adobe Pag
Setting up frames

Frames visually divide a Web browser window into different areas, each 
displaying a separate page. Frames are useful when you want to update 
only part of a page—for example, when you want an unchanging table of 
contents on one side of the page that links to an adjoining frame whose 
contents change depending on what the reader clicks.

All the frames in a window make up a special file called a frameset. You’ll 
create a frameset and add an image and pages to it. 

1 Choose File > New Page.

2 Hold down Control and move the pointer over the top edge of the page. 
When the pointer turns into a down arrow, drag down about 2 inches.

3 Hold down Control and move the pointer over the lower left edge of the 
window. When the pointer turns into a right arrow, drag right about 
2 inches.
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You now have three frames. Don’t worry about the precise sizes of the 
frames.

You can use the Inspector to name frames (the names are used by other 
pages to identify targets for a link) and to set properties for size, margins, 
borders, and scroll bars. You’ll specify just the scroll bar setting now. You 
can read about the other settings in “Using Frames” in online Help.
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4 If necessary, choose View > Show Inspector.

5 Click in the top frame, and in the Frames panel of the Inspector, choose 
No in the Scrollbars pop-up menu. This prevents scrollbars from 
appearing in the top frame (which will contain a banner image). 

You won’t change the default setting for scrollbars (Auto) for the two 
lower frames. With the Auto setting, scrollbars will appear in the reader’s 
Web browser only when necessary to view all the contents of the frame.

Filling frames

Next you’ll fill the frames. The top frame will contain an image, the left 
frame will contain a table of contents, and the right frame will contain 
product information. 

1 If necessary, display the Site Overview area and the contents of the 
Images folder.

2 Drag the Banner.gif file from the Site Overview area to the top frame of 
the frameset.

3 Click the Center Align button ( ) on the toolbar to center the image.

Now you’ll add the table of contents. 
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4 Click in the left frame and choose File > Frameset > Insert Page. 
Select the Toc.html file in the Tour folder and click Open.

5 If necessary, resize the frame so that the text is displayed without too 
much word wrapping. To resize a frame, move the pointer over the border 

between two frames until it turns into a double-headed arrow ( ), and 
then drag the border.

Next, you’ll save the frames and the frameset. When you save a frame, 
you save its contents (the page in the frame). When you save the 
frameset, you save the layout and some properties of the frames. 

6 Choose File > Frameset > Save Everything. The highlight around the 
top frame indicates that you will save this frame first.
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7 Save the top frame in the Tour folder as Frame1.html. Now the right 
frame is highlighted.

8 Save the right frame in the Tour folder as Frame2.html. You will not be 
asked to save the left frame, because the page in that frame is already 
saved (as TOC.html).

9 Save the frameset in the Tour folder as Frameset.html.

Targeting a frame

The page that the right frame displays depends on which link the reader 
clicks in the table of contents frame on the left. You’ll create one of the 
links in the table of contents and then target the link to display the page 
in the frame on the right.

1 Select the word CHAIRS in the frame on the left.

2 Create the link by dragging the Chairs.html file from the Site Overview 
area onto the selected text in the frame. 
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Now you’ll target the link you just created so that the page it links to 
appears in the frame at the right. 

3 Right-click the selected link. In the pop-up menu that appears, move 
the pointer over the thumbnail image of the frames until the frame at the 
lower right is highlighted, and then release the mouse button.

4 Chose File > Save Frame. 
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5 Click the Mode button at the right of the toolbar to switch to Preview 
mode, and then click the Chairs link to test it. When you click the link in 
the left frame, the Chairs.html page appears in the frame to the right.

6 Close the frameset page by choosing File > Close, and when 
prompted, save the page.
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In addition to defining individual targets in a frame, you can specify a 
base target, a destination the browser uses for any links that don’t have 
defined targets. For details, see “Using Frames” in online Help.

Creating a form

Creating an interactive form for the Web is a two-part process. First you 
lay out the form’s objects and then you link the objects to scripts. In this 
section, you’ll add some objects to an existing form.

1 In the Site Overview area, double-click the Order.html file to open it.

2 Click before Credit Card #. Then type Name and press Shift+Enter. 
(Shift+Enter moves the insertion point to a new line but does not start a 
new paragraph.)

3 Type Address and press Shift+Enter.
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Next, you’ll insert two text fields where readers can enter their names and 
addresses.

4 Click immediately after Name and then click the Insert Text Field 
button ( ) on the toolbar. This adds a one-line text field. 

5 Click the text field to select it, and then hold down Control while you 
drag the field to the right of the Address label. This makes a copy of the 
text field.

6 Resize each field as needed by clicking to select it and dragging the 
handle.

Next, you’ll add radio buttons to the form. You use radio buttons to offer 
a set of mutually exclusive choices: selecting one radio button automati-
cally deselects the other options in the group. 

7 Click to the right of the Method of Payment text, and then click Insert 
Radio Button ( ) on the toolbar. 

8 Select the radio button, and then hold down Control and drag the 
button to the right. Copying radio buttons by Control-dragging keeps the 
buttons in the same group of mutually exclusive options. (If you had 
created the second button by clicking Insert Radio Button, it would not 
be in the same group as the first button.)

9 Click between the first and second buttons, and type Credit Card

10 Click to the right of the second button, and type Check
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You’ll complete your form by adding a Submit button (all forms must 
have this button).

11 Click after the text at the bottom of the page and press Enter.

12 If necessary, resize the PageMill window and the page display so that 
all the buttons on the toolbar are visible, and then click Insert Submit 
Button ( ). This places a Submit button on the form. 

13 Click the Mode button at the right of the toolbar to enter Preview 
mode, and then test the components of the form by typing in the text 
fields and clicking radio buttons. (The Submit button has no effect in 
Preview mode.) Notice that selecting one radio button automatically 
deselects the previously selected one. 

14 Choose File > Close. When prompted to save changes, click Yes. 

Before your form is ready to use on the Web, you’ll need to associate it 
and its buttons and text fields with CGI scripts running on your Web 
server. Contact your Internet service provider or the administrator of your 
Web server to see which CGI scripts are available. For more information, 
see “About form scripts” and “Associating a CGI script with a form” in 
online Help.

Displaying information about your site

PageMill makes it easy to manage your Web site. You’ve already used the 
Site Overview area to list the files and folders in a site, open files, and 
create links. Now you’ll learn how to display detailed information about 
page links, fix broken links, rename files, and automatically update page 
links.

1 In the Site Overview area, right-click the Tour folder and choose Show 
Details. When the Site Details window appears, maximize the window to 
see more of its contents.
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The top pane of the window lists all the files and folders in your site, and 
incoming and outgoing links. This is called the List view.

2 In the List view, click the underlined 1 in the Chairs.html row of the In 
column. The pop-up menu shows the link from TOC.html into 
Chairs.html. (A red x in the In column indicates that there are no 
incoming links to a page.)

3 Press Escape to close the pop-up menu.

4 Click the underlined 4 in the Chairs.html row of the Out column. The 
pop-up menu shows all the links in Chairs.html to other pages, or links 
from anchors (particular locations) on Chairs.html, and references to 
image files or other objects on Chairs.html. (A blue dash in the Out 
column indicates that there are no outgoing links from a page.)
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5 Press Escape to close the pop-up menu.

6 In the List view, click Home.html. The lower pane now shows the Link 
view, a graphical view of all the linked files for Home.html. (If necessary, 
drag the border line between the two panes so that you can see both views 
more fully.) In the Link view, you can show or hide links by clicking the 
plus or minus sign in the small box. A red arrow indicates a broken link. 
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Renaming files and correcting errors

By using the Site Overview area and the Details window (rather than the 
Windows Explorer) to modify your site, you ensure that all the files in the 
site are correctly linked together and will function when uploaded to a 
Web server. 

You can use the List View (or the Site Overview area) to rename a file in 
your site. PageMill automatically adjusts the links in any files in the site 
that refer to the renamed file.

1 In the List view, right-click Plants.html and then choose Rename from 
the pop-up menu.

2 Type EWPlants to rename the file, press Enter, and then click OK to 
modify the file. Be sure to keep the .html extension when you rename the 
file. (Always keep extensions such as .html, .gif, or .jpg when renaming 
files in a site.) 

PageMill moves the file to its proper location in the alphabetical list and 
modifies the links to the file.

Now you’ll fix the broken links in your site.

3 Click the Errors folder near the bottom of the Site Overview area. The 
list shows one error in the site.
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4 In the List View, click Etools.html. The Link view shows a broken link 
from Home.html to Etools.html. 

Etools.html is no longer part of the site, so you’ll establish a link to its 
replacement page, Tools.html.

5 Double-click Etools.html. (You can do this in any of the three places it 
appears—in the Link view, the List view, or the Site Overview area.) 

6 In the Correct Error dialog box, select Tools.html, click Open, and then 
click OK.

PageMill has many other site management features—for example, site-
wide spell-checking and searching, and automatic copying of externally 
linked files. See “Working with Web sites” in online Help for more 
information.

Uploading a site

When your site is complete and error free (and all external files have been 
gathered within the site folder and Web links verified), it’s ready to 
upload to a Web server. The Web server is usually running on another 
computer—either on an internal network if your site is part of a company 
intranet, or at an Internet service provider if your site will be available on 
the World Wide Web.

In any case, you’ll need to obtain some important information such as the 
File Transfer Protocol (FTP) host name, the path to your public directory 
on the server, and your FTP user name and password. Once you know 
this information, you can use PageMill to upload your site. Before you 
upload, it’s a good idea to check the site statistics to see its overall size 
and to look for errors.
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1 Choose Site > Show Statistics. 

2 Click the Site Content and the Site Resources tabs to see the contents 
and status of your site. (There should be no errors shown in Site 
Resources.) Then click OK.

Now you can configure your site’s upload settings.

3 Right-click the MySite folder in the Site Overview area and choose Edit 
Current Site Settings.

4 In the General panel of the Edit Site Settings dialog box, enter the name 
of your host computer and the path to your folder on that computer in the 
Host Name and Remote Folder text boxes. You’ll also need to enter the 
user name and password that you use to log into your Internet service 
provider. (If you don’t know this information, don’t enter text in these 
boxes. You won’t actually be uploading this Tour site.)

5 Click OK.
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When you’re ready to upload your own site you’ll need to make a 
connection to your Web server. Most likely you will log on to your 
Internet service provider. At that point, you would do the following step.

6 Choose Site > Upload and click OK.

PageMill provides several settings to customize your site upload. For 
example, after you upload your site, you might want to re-upload only 
revised files. See “Uploading Web sites” in online Help for complete infor-
mation.

You’re done!

That’s the end of this quick tour. PageMill has many powerful capabilities 
not covered here, including features for editing HTML code and for 
working with Java applets. Remember to reach for online Help when you 
need information on specific PageMill topics.
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